aboutsummaryrefslogtreecommitdiff
path: root/graphics/libfpx
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2008-01-26 23:43:36 +0000
committerMikhail Teterin <mi@FreeBSD.org>2008-01-26 23:43:36 +0000
commite56a4705d569f5b03073d90fefe07583c3f4e8ec (patch)
tree93b91cd58fef27d0d0cf64f841d7994ec3d5c4e8 /graphics/libfpx
parentf35161e0feac7959e22e983fed520bde7ac2497c (diff)
downloadports-e56a4705d569f5b03073d90fefe07583c3f4e8ec.tar.gz
ports-e56a4705d569f5b03073d90fefe07583c3f4e8ec.zip
When WARNS is set in a Makefile even to 1, the flag ``-Wsystem-headers''
is added to the list of compiler's warning-flags. This triggers a warning like: /usr/include/c++/4.2/bits/basic_ios.h:156: warning: empty body in an if-statement in g++42. When this compiler is used, where NO_WERROR is set, the port fails to build, as warnings are treated as errors. This, pretty much, means, that NO C++ code can currently be compiled with WARNS set to anything on FreeBSD. Work-around the deficiency for now by removing the ``-Wsystem-headers'' from CXXFLAGS after including bsd.lib.mk. This fixes graphics/libfpx on 8.x as well as allows the port to be built by gcc-4.2 on 6.x and 5.x. Continuously reminded of by: pav
Notes
Notes: svn path=/head/; revision=206269
Diffstat (limited to 'graphics/libfpx')
-rw-r--r--graphics/libfpx/files/Makefile.bsd4
1 files changed, 4 insertions, 0 deletions
diff --git a/graphics/libfpx/files/Makefile.bsd b/graphics/libfpx/files/Makefile.bsd
index ceb593dbb099..985f3c7a43ba 100644
--- a/graphics/libfpx/files/Makefile.bsd
+++ b/graphics/libfpx/files/Makefile.bsd
@@ -41,3 +41,7 @@ CXXFLAGS+= -I${.CURDIR}/$d
CXXFLAGS+= -I${LOCALBASE}/include -D_UNIX
.include <bsd.lib.mk>
+
+# Work-around the bug in g++4.2's system header:
+# /usr/include/c++/4.2/bits/basic_ios.h:156: warning: empty body in an if-statement
+CXXFLAGS:= ${CXXFLAGS:N-Wsystem-headers}