aboutsummaryrefslogtreecommitdiff
path: root/graphics/libfreehand
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-10-03 20:35:29 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-10-03 20:35:29 +0000
commit4bbb4133b2730df60a15c7e7fb495841ffdb32c4 (patch)
treeb325616b604b3f18f851e5b3104e0289676790a9 /graphics/libfreehand
parent947645f5a712ad72340b44481d1d177bfd777110 (diff)
downloadports-4bbb4133b2730df60a15c7e7fb495841ffdb32c4.tar.gz
ports-4bbb4133b2730df60a15c7e7fb495841ffdb32c4.zip
devel/icu: update to 65.1
Notes
Notes: svn path=/head/; revision=513733
Diffstat (limited to 'graphics/libfreehand')
-rw-r--r--graphics/libfreehand/Makefile2
-rw-r--r--graphics/libfreehand/files/patch-src_lib_libfreehand__utils.cpp40
2 files changed, 41 insertions, 1 deletions
diff --git a/graphics/libfreehand/Makefile b/graphics/libfreehand/Makefile
index abab027415b5..4a5a47068ca2 100644
--- a/graphics/libfreehand/Makefile
+++ b/graphics/libfreehand/Makefile
@@ -2,7 +2,7 @@
PORTNAME= libfreehand
PORTVERSION= 0.1.2
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= graphics
MASTER_SITES= LODEV
diff --git a/graphics/libfreehand/files/patch-src_lib_libfreehand__utils.cpp b/graphics/libfreehand/files/patch-src_lib_libfreehand__utils.cpp
new file mode 100644
index 000000000000..5cac85099929
--- /dev/null
+++ b/graphics/libfreehand/files/patch-src_lib_libfreehand__utils.cpp
@@ -0,0 +1,40 @@
+Regressed by https://github.com/unicode-org/icu/commit/480bec3ea652
+
+libfreehand_utils.cpp:165:30: error: expected ';' after do/while statement
+ U16_NEXT(s, j, length, c)
+ ^
+ ;
+libfreehand_utils.cpp:168:23: error: use of undeclared identifier 'outbuf'
+ U8_APPEND_UNSAFE(&outbuf[0], i, c);
+ ^
+libfreehand_utils.cpp:168:23: error: use of undeclared identifier 'outbuf'
+libfreehand_utils.cpp:168:23: error: use of undeclared identifier 'outbuf'
+libfreehand_utils.cpp:168:23: error: use of undeclared identifier 'outbuf'
+libfreehand_utils.cpp:168:23: error: use of undeclared identifier 'outbuf'
+libfreehand_utils.cpp:168:23: error: use of undeclared identifier 'outbuf'
+libfreehand_utils.cpp:168:23: error: use of undeclared identifier 'outbuf'
+libfreehand_utils.cpp:169:5: error: use of undeclared identifier 'outbuf'; did you mean 'setbuf'?
+ outbuf[i] = 0;
+ ^~~~~~
+ setbuf
+/usr/include/stdio.h:283:7: note: 'setbuf' declared here
+void setbuf(FILE * __restrict, char * __restrict);
+ ^
+libfreehand_utils.cpp:169:5: error: subscript of pointer to function type 'void (FILE *, char *)' (aka 'void (__sFILE *, char *)')
+ outbuf[i] = 0;
+ ^~~~~~
+libfreehand_utils.cpp:171:25: error: use of undeclared identifier 'outbuf'
+ text.append((char *)outbuf);
+ ^
+
+--- src/lib/libfreehand_utils.cpp.orig 2017-09-16 10:28:50 UTC
++++ src/lib/libfreehand_utils.cpp
+@@ -162,7 +162,7 @@ void libfreehand::_appendUTF16(librevenge::RVNGString
+ while (j < length)
+ {
+ UChar32 c;
+- U16_NEXT(s, j, length, c)
++ U16_NEXT(s, j, length, c);
+ unsigned char outbuf[U8_MAX_LENGTH+1];
+ int i = 0;
+ U8_APPEND_UNSAFE(&outbuf[0], i, c);