aboutsummaryrefslogtreecommitdiff
path: root/graphics/libgltext
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-05-23 02:35:26 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-05-23 02:35:26 +0000
commitacbbee2bc7634b209abf38ef09ce1f48197a4fe4 (patch)
tree989dd8e1b1e6c8900e5268efdd3d75a25a3b7268 /graphics/libgltext
parent70cb44a9d71c560e2e4ab944c63d47e386b5f5a1 (diff)
downloadports-acbbee2bc7634b209abf38ef09ce1f48197a4fe4.tar.gz
ports-acbbee2bc7634b209abf38ef09ce1f48197a4fe4.zip
- adoption of optionsNG
- convert to USES in some cases (pkgconfig,pathfix) - trim COMMENT/historical headers in some cases Approved by: portmgr (miwi)
Notes
Notes: svn path=/head/; revision=318829
Diffstat (limited to 'graphics/libgltext')
-rw-r--r--graphics/libgltext/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/graphics/libgltext/Makefile b/graphics/libgltext/Makefile
index a66b9fd193eb..4235031c8a6a 100644
--- a/graphics/libgltext/Makefile
+++ b/graphics/libgltext/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libgltext
-# Date created: 2006-02-20
-# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
-#
+# Created by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
# $FreeBSD$
-#
PORTNAME= libgltext
PORTVERSION= 0.3.1
@@ -24,11 +20,12 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
-OPTIONS= EXAMPLES "Compile examples, need libglut" off
+OPTIONS_DEFINE= EXAMPLES
+EXAMPLES_DESC= Compile examples, need libglut
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_EXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
USE_GL= glut
FLAG_EXAMPLES= true
PLIST_SUB+= EXAMPLES=""
@@ -49,7 +46,7 @@ do-install:
${LN} -s ${PORTNAME}.so.0 ${PORTNAME}.so
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/doc/tutorial.txt ${DOCSDIR}
.endif
@@ -65,4 +62,4 @@ post-install:
@${ECHO_MSG} ""
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>