aboutsummaryrefslogtreecommitdiff
path: root/graphics/libglvnd
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-06-15 14:32:08 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-06-15 14:32:08 +0000
commit1f36073a789131d6af8eaa300abe954164bd5492 (patch)
treec5ab7ae8f3530fd34158aa1c25ba88ca04b97898 /graphics/libglvnd
parente85ea1173a8705b600f30837954a82cdd6d9d94c (diff)
downloadports-1f36073a789131d6af8eaa300abe954164bd5492.tar.gz
ports-1f36073a789131d6af8eaa300abe954164bd5492.zip
graphics/libglvnd: fix build on powerpc64 elfv2
Clang fails to build this port, use GCC for now.
Notes
Notes: svn path=/head/; revision=538880
Diffstat (limited to 'graphics/libglvnd')
-rw-r--r--graphics/libglvnd/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/graphics/libglvnd/Makefile b/graphics/libglvnd/Makefile
index 93c3b906746b..e0abf3c91ed3 100644
--- a/graphics/libglvnd/Makefile
+++ b/graphics/libglvnd/Makefile
@@ -12,7 +12,7 @@ LICENSE_COMB= multi
CONFLICTS_INSTALL= mesa-libs # include/GL/gl.h
-USES= compiler:c++11-lib localbase meson pkgconfig
+USES= localbase meson pkgconfig
USE_LDCONFIG= yes
USE_GITLAB= yes
@@ -28,6 +28,14 @@ X11_USES= xorg
X11_USE= XORG=x11,xext,xorgproto
X11_MESON_ENABLED= x11 glx
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == powerpc64
+USES+= compiler:gcc-c++11-lib
+.else
+USES+= compiler:c++11-lib
+.endif
+
# Lots of software expects gl.pc even when it can build with EGL only
post-install-X11-off:
${LN} -s opengl.pc ${STAGEDIR}${PREFIX}/libdata/pkgconfig/gl.pc