aboutsummaryrefslogtreecommitdiff
path: root/graphics/libgphoto2
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-07-25 18:55:01 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-07-25 18:55:01 +0000
commit3e04c2ddb854c9df2661d05a3cc061ae18f2701d (patch)
tree82a185f3f7aa0d00854b17bb5c7aa4eeb2a87e3b /graphics/libgphoto2
parent8f27531f5e01a35e9b0dbb0647f115d43017cbd6 (diff)
downloadports-3e04c2ddb854c9df2661d05a3cc061ae18f2701d.tar.gz
ports-3e04c2ddb854c9df2661d05a3cc061ae18f2701d.zip
Unbreak after base rev 253637
While here remove unused patch PR: ports/180825 Submitted by: rpaulo@
Notes
Notes: svn path=/head/; revision=323662
Diffstat (limited to 'graphics/libgphoto2')
-rw-r--r--graphics/libgphoto2/Makefile12
-rw-r--r--graphics/libgphoto2/files/extra-patch-usb2011
2 files changed, 9 insertions, 14 deletions
diff --git a/graphics/libgphoto2/Makefile b/graphics/libgphoto2/Makefile
index 698609a6c3d2..36a947addcf4 100644
--- a/graphics/libgphoto2/Makefile
+++ b/graphics/libgphoto2/Makefile
@@ -22,9 +22,7 @@ USE_AUTOTOOLS= libtool libltdl
LIBTOOLFILES= configure libgphoto2_port/configure
USE_LDCONFIG= yes
CONFIGURE_ENV= LTDLINCL="-I${LOCALBASE}/include" \
- LIBLTDL="-L${LOCALBASE}/lib -lltdl" \
- LIBUSB_CFLAGS="-I/usr/include" \
- LIBUSB_LIBS="-lusb"
+ LIBLTDL="-L${LOCALBASE}/lib -lltdl"
PLIST_SUB= VERSION="${PORTVERSION}" VERSION_PORT=0.8.0
@@ -32,6 +30,14 @@ MAN3= libgphoto2.3 libgphoto2_port.3
.include <bsd.port.options.mk>
+.if ${OSVERSION} < 1000040
+CONFIGURE_ENV+= LIBUSB_CFLAGS="-I/usr/include" \
+ LIBUSB_LIBS="-lusb"
+.else
+# Safe because it's never used
+CFLAGS+= -DENODATA=0
+.endif
+
.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
diff --git a/graphics/libgphoto2/files/extra-patch-usb20 b/graphics/libgphoto2/files/extra-patch-usb20
deleted file mode 100644
index adcfd2317858..000000000000
--- a/graphics/libgphoto2/files/extra-patch-usb20
+++ /dev/null
@@ -1,11 +0,0 @@
---- libgphoto2_port/usb/libusb.c.orig 2008-11-21 19:24:40.000000000 +0100
-+++ libgphoto2_port/usb/libusb.c 2009-03-08 18:58:56.000000000 +0100
-@@ -33,6 +33,8 @@
- #include <string.h>
-
- #include <usb.h>
-+#include <libusb20.h>
-+#include <libusb20_compat10.h>
-
- #include <gphoto2/gphoto2-port.h>
- #include <gphoto2/gphoto2-port-result.h>