aboutsummaryrefslogtreecommitdiff
path: root/graphics/libimg
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-06-03 10:45:18 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-06-03 10:45:18 +0000
commit7d061b73dceaa0d568f76a4c7db602401293c771 (patch)
tree0780601d5e6b9cc04355e043a320f8f50125d708 /graphics/libimg
parent28605e5fabd4e7c2fec3509f99cafe6abb8757c3 (diff)
downloadports-7d061b73dceaa0d568f76a4c7db602401293c771.tar.gz
ports-7d061b73dceaa0d568f76a4c7db602401293c771.zip
- Convert to new LIB_DEPENDS format
- STAGE-clean
Notes
Notes: svn path=/head/; revision=356320
Diffstat (limited to 'graphics/libimg')
-rw-r--r--graphics/libimg/Makefile13
-rw-r--r--graphics/libimg/files/Makefile.bsd4
2 files changed, 7 insertions, 10 deletions
diff --git a/graphics/libimg/Makefile b/graphics/libimg/Makefile
index da0ea3bf1b0e..55e736921281 100644
--- a/graphics/libimg/Makefile
+++ b/graphics/libimg/Makefile
@@ -11,9 +11,9 @@ DISTNAME= img${PORTVERSION}
MAINTAINER= mi@aldan.algebra.com
COMMENT= A library of image format handlers for Tk4.1 and later
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- jpeg:${PORTSDIR}/graphics/jpeg \
- tiff:${PORTSDIR}/graphics/tiff
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libtiff.so:${PORTSDIR}/graphics/tiff
DIR= lib/Img1.2
@@ -28,7 +28,6 @@ MAKEFILE= ${FILESDIR}/Makefile.bsd
USES= tk
MAKE_ENV+= TCL_VER=${TCL_VER}
-NO_STAGE= yes
# We don't need the bundled libraries:
EXTRACT_AFTER_ARGS= --exclude '*/libz/*' \
--exclude '*/compat/*' --exclude '*/libtiff/*' \
@@ -41,11 +40,9 @@ MAKE_ARGS= PORTVERSION="${PORTVERSION}" LOCALBASE="${LOCALBASE}" \
USE_LDCONFIG= yes
-.if !defined(NOPORTDOCS)
post-install:
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
-.endif
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${STAGEDIR}${DOCSDIR}
.include <bsd.port.pre.mk>
diff --git a/graphics/libimg/files/Makefile.bsd b/graphics/libimg/files/Makefile.bsd
index 7170d7467a7d..de70cbac30c0 100644
--- a/graphics/libimg/files/Makefile.bsd
+++ b/graphics/libimg/files/Makefile.bsd
@@ -41,8 +41,8 @@ pkgIndex.tcl: pkgIndex.tcl.in
< pkgIndex.tcl.in > pkgIndex.tcl
DIR? = lib/Img1.2
-INSTDIR = ${LOCALBASE}/${DIR}
-LIBDIR = ${LOCALBASE}/lib
+INSTDIR = ${DESTDIR}${PREFIX}/${DIR}
+LIBDIR = ${PREFIX}/lib
${INSTDIR} ${INSTDIR}/msgs:
${MKDIR} $@