aboutsummaryrefslogtreecommitdiff
path: root/graphics/libjpeg-turbo/Makefile
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2012-03-13 06:07:10 +0000
committerMikhail Teterin <mi@FreeBSD.org>2012-03-13 06:07:10 +0000
commit5c933611015ff018eae3066e1fd28ff65b5738f9 (patch)
tree747f7154f98c61013b1eb8f4565b176ef7cdf963 /graphics/libjpeg-turbo/Makefile
parenta3de89d837fe47b8022bd13bea12ad8df2a3dcb5 (diff)
downloadports-5c933611015ff018eae3066e1fd28ff65b5738f9.tar.gz
ports-5c933611015ff018eae3066e1fd28ff65b5738f9.zip
Some minor improvements:
* change CONFLICTS to CONFLICTS_INSTALL -- this port can build with the traditional jpeg present, conflict arises only at install-time; * use parallel builds * run the author's self-tests after building to catch any mis- -compilations or overly agressive optimizations. Approved by: Denis Podolsky (maintainer) Feature safe: yes
Notes
Notes: svn path=/head/; revision=293206
Diffstat (limited to 'graphics/libjpeg-turbo/Makefile')
-rw-r--r--graphics/libjpeg-turbo/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/graphics/libjpeg-turbo/Makefile b/graphics/libjpeg-turbo/Makefile
index 788826ce08d0..fdbcc3cdb75b 100644
--- a/graphics/libjpeg-turbo/Makefile
+++ b/graphics/libjpeg-turbo/Makefile
@@ -17,12 +17,14 @@ COMMENT= SIMD-accelerated JPEG codec which provides both the libjpeg,TurboJPEG
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
-CONFLICTS= jpeg-[0-9]*
+CONFLICTS_INSTALL= jpeg-[0-9]*
ONLY_FOR_ARCHS= amd64 i386
USE_AUTOTOOLS= libtool
CONFIGURE_ENV= SO_MAJOR_VERSION=${SOVERSION}
CONFIGURE_ARGS= --with-jpeg8
USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
+ALL_TARGET= test
MAN1= cjpeg.1 djpeg.1 jpegtran.1 rdjpgcom.1 wrjpgcom.1
PLIST_SUB= SOVERSION=${SOVERSION}