aboutsummaryrefslogtreecommitdiff
path: root/graphics/libkdcraw
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-04-08 17:01:54 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-04-08 17:01:54 +0000
commit01fe74759a97eff36f905d70ada1f1c0c99ef2fc (patch)
tree2ba2c4cb6277c4a2e3c07ebccf9e0955e52c9699 /graphics/libkdcraw
parent67b30d480ee85ff6fb999fcda086a702e8f90749 (diff)
downloadports-01fe74759a97eff36f905d70ada1f1c0c99ef2fc.tar.gz
ports-01fe74759a97eff36f905d70ada1f1c0c99ef2fc.zip
New ports: KDE Applications graphics/
* graphics/gwenview * graphics/kamera * graphics/kcolorchooser * graphics/kdegraphics-mobipocket * graphics/kdegraphics-svgpart * graphics/kdegraphics-thumbnailers * graphics/kimagemapeditor * graphics/kolourpaint * graphics/libkdcraw * graphics/libkexiv2 * graphics/libkipi * graphics/libksane * graphics/okular * graphics/spectacle This is the current version of KDE Applications <foo>. Note that users of KDE SC4 should stick with <foo>-kde4. Differential Revision: https://reviews.freebsd.org/D14833
Notes
Notes: svn path=/head/; revision=466806
Diffstat (limited to 'graphics/libkdcraw')
-rw-r--r--graphics/libkdcraw/Makefile24
-rw-r--r--graphics/libkdcraw/distinfo3
-rw-r--r--graphics/libkdcraw/pkg-descr4
-rw-r--r--graphics/libkdcraw/pkg-plist17
4 files changed, 48 insertions, 0 deletions
diff --git a/graphics/libkdcraw/Makefile b/graphics/libkdcraw/Makefile
new file mode 100644
index 000000000000..962b73859fa4
--- /dev/null
+++ b/graphics/libkdcraw/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= libkdcraw
+DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+CATEGORIES= graphics kde kde-applications
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= LibRaw interface for KDE
+
+LIB_DEPENDS= libjasper.so:graphics/jasper \
+ liblcms.so:graphics/lcms \
+ libxml2.so:textproc/libxml2 \
+ libraw.so:graphics/libraw
+
+CMAKE_ARGS+= -DWITH_OpenMP:BOOL=False \
+ -DENABLE_RAWSPEED=True
+
+USES= cmake:outsource compiler:c++11-lang jpeg kde:5 pkgconfig tar:xz
+USE_KDE= ecm
+USE_QT5= core gui \
+ buildtools_build qmake_build
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/libkdcraw/distinfo b/graphics/libkdcraw/distinfo
new file mode 100644
index 000000000000..b079c53e5778
--- /dev/null
+++ b/graphics/libkdcraw/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1520519289
+SHA256 (KDE/applications/17.12.3/libkdcraw-17.12.3.tar.xz) = cc02d7bfef7fed0f35ea5e1467e6d67939ca0bf2ca5551169cc4e7b11b2de286
+SIZE (KDE/applications/17.12.3/libkdcraw-17.12.3.tar.xz) = 41840
diff --git a/graphics/libkdcraw/pkg-descr b/graphics/libkdcraw/pkg-descr
new file mode 100644
index 000000000000..a2e7bb2545bc
--- /dev/null
+++ b/graphics/libkdcraw/pkg-descr
@@ -0,0 +1,4 @@
+libkdcraw is a C++ interface around the LibRaw library
+used to decode RAW picture files.
+
+WWW: http://www.digikam.org/
diff --git a/graphics/libkdcraw/pkg-plist b/graphics/libkdcraw/pkg-plist
new file mode 100644
index 000000000000..f798c8074dce
--- /dev/null
+++ b/graphics/libkdcraw/pkg-plist
@@ -0,0 +1,17 @@
+include/KF5/KDCRAW/KDCRAW/DcrawInfoContainer
+include/KF5/KDCRAW/KDCRAW/KDcraw
+include/KF5/KDCRAW/KDCRAW/RawDecodingSettings
+include/KF5/KDCRAW/KDCRAW/RawFiles
+include/KF5/KDCRAW/kdcraw/dcrawinfocontainer.h
+include/KF5/KDCRAW/kdcraw/kdcraw.h
+include/KF5/KDCRAW/kdcraw/libkdcraw_export.h
+include/KF5/KDCRAW/kdcraw/rawdecodingsettings.h
+include/KF5/KDCRAW/kdcraw/rawfiles.h
+include/KF5/libkdcraw_version.h
+lib/cmake/KF5KDcraw/KF5KDcrawConfig.cmake
+lib/cmake/KF5KDcraw/KF5KDcrawConfigVersion.cmake
+lib/cmake/KF5KDcraw/KF5KDcrawTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/KF5KDcraw/KF5KDcrawTargets.cmake
+lib/libKF5KDcraw.so
+lib/libKF5KDcraw.so.5
+lib/libKF5KDcraw.so.5.0.0