aboutsummaryrefslogtreecommitdiff
path: root/graphics/libopenraw
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2020-10-13 21:30:22 +0000
committerJason E. Hale <jhale@FreeBSD.org>2020-10-13 21:30:22 +0000
commitfa85125e0389ae064e8fdd8b8a22174fa373dcac (patch)
treee9fbd6320341044d74b5e6723d7691748df0c851 /graphics/libopenraw
parent491bb8951beb615f33c19fff42c7565753588f3c (diff)
downloadports-fa85125e0389ae064e8fdd8b8a22174fa373dcac.tar.gz
ports-fa85125e0389ae064e8fdd8b8a22174fa373dcac.zip
graphics/libopenraw: Update to 0.2.3
Notes
Notes: svn path=/head/; revision=552285
Diffstat (limited to 'graphics/libopenraw')
-rw-r--r--graphics/libopenraw/Makefile80
-rw-r--r--graphics/libopenraw/distinfo120
-rw-r--r--graphics/libopenraw/files/patch-gnome_include_libopenraw-gnome_Makefile.in12
-rw-r--r--graphics/libopenraw/pkg-plist45
4 files changed, 216 insertions, 41 deletions
diff --git a/graphics/libopenraw/Makefile b/graphics/libopenraw/Makefile
index f38410fb4c30..bdedeb4341f2 100644
--- a/graphics/libopenraw/Makefile
+++ b/graphics/libopenraw/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= libopenraw
-PORTVERSION= 0.1.3
-PORTREVISION= 7
+PORTVERSION= 0.2.3
CATEGORIES= graphics
MASTER_SITES= http://libopenraw.freedesktop.org/download/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= jhale@FreeBSD.org
COMMENT= Library for camera RAW files decoding
@@ -14,8 +14,9 @@ LICENSE= LGPL3+
LICENSE_FILE= ${WRKSRC}/COPYING.LESSER
BUILD_DEPENDS= ${LOCALBASE}/include/boost/variant.hpp:devel/boost-libs
+TEST_DEPENDS= curl:ftp/curl
-USES= compiler:c++11-lib gnome jpeg libtool localbase pkgconfig \
+USES= cargo compiler:c++11-lib gnome jpeg libtool localbase pkgconfig \
tar:bz2
USE_GNOME= libxml2
USE_LDCONFIG= yes
@@ -26,6 +27,71 @@ CONFIGURE_ARGS= --with-boost=${LOCALBASE}/include \
INSTALL_TARGET= install-strip
TEST_TARGET= check
+CARGO_CRATES= ahash-0.3.8 \
+ aho-corasick-0.7.13 \
+ ansi_term-0.11.0 \
+ atty-0.2.14 \
+ autocfg-1.0.1 \
+ bitflags-1.2.1 \
+ bitreader-0.3.2 \
+ byteorder-1.3.4 \
+ cbindgen-0.5.2 \
+ cfg-if-0.1.10 \
+ clap-2.33.3 \
+ env_logger-0.7.1 \
+ fuchsia-cprng-0.1.1 \
+ hashbrown-0.7.2 \
+ hermit-abi-0.1.17 \
+ humantime-1.3.0 \
+ itoa-0.4.6 \
+ lazy_static-1.4.0 \
+ libc-0.2.79 \
+ log-0.3.9 \
+ log-0.4.11 \
+ memchr-2.3.3 \
+ num-traits-0.2.12 \
+ proc-macro2-0.2.3 \
+ quick-error-1.2.3 \
+ quote-0.3.15 \
+ rand-0.4.6 \
+ rand_core-0.3.1 \
+ rand_core-0.4.2 \
+ rdrand-0.4.0 \
+ regex-1.3.9 \
+ regex-syntax-0.6.18 \
+ remove_dir_all-0.5.3 \
+ ryu-1.0.5 \
+ serde-1.0.102 \
+ serde_derive-1.0.21 \
+ serde_derive_internals-0.17.0 \
+ serde_json-1.0.58 \
+ standalone-quote-0.5.0 \
+ standalone-syn-0.13.0 \
+ static_assertions-1.1.0 \
+ strsim-0.8.0 \
+ syn-0.11.11 \
+ synom-0.11.3 \
+ tempdir-0.3.7 \
+ termcolor-1.1.0 \
+ textwrap-0.11.0 \
+ thread_local-1.0.1 \
+ toml-0.4.10 \
+ unicode-width-0.1.8 \
+ unicode-xid-0.0.4 \
+ unicode-xid-0.1.0 \
+ vec_map-0.8.2 \
+ winapi-0.3.9 \
+ winapi-i686-pc-windows-gnu-0.4.0 \
+ winapi-util-0.1.5 \
+ winapi-x86_64-pc-windows-gnu-0.4.0
+CARGO_CARGOTOML=${WRKSRC}/lib/mp4/Cargo.toml
+CARGO_CARGOLOCK=${WRKSRC}/lib/mp4/mp4parse_capi/Cargo.lock
+CARGO_BUILD= no
+CARGO_INSTALL= no
+CARGO_TEST= no
+
+PLIST_SUB= VER=${PORTVERSION:R}
+
OPTIONS_DEFINE= GNOME TEST
OPTIONS_DEFAULT= GNOME
OPTIONS_SUB= yes
@@ -34,13 +100,19 @@ GNOME_CONFIGURE_ENABLE= gnome
GNOME_USES= gettext-runtime
GNOME_USE= GNOME=glib20,gdkpixbuf2
+TEST_BUILD_DEPENDS= curl:ftp/curl
+
post-patch:
@${REINPLACE_CMD} -E \
-e 's|\{libdir\}/pkgconfig|{prefix}/libdata/pkgconfig|g' \
- -e '/^(CFLAGS|CXXFLAGS)/s|-g||g' \
${WRKSRC}/configure
post-patch-TEST-off:
@${REINPLACE_CMD} -e 's|testsuite ||' ${WRKSRC}/Makefile.in
+pre-configure:
+ @${CARGO_CARGO_RUN} update \
+ --manifest-path ${WRKSRC}/lib/mp4/mp4parse_capi/Cargo.toml \
+ --verbose
+
.include <bsd.port.mk>
diff --git a/graphics/libopenraw/distinfo b/graphics/libopenraw/distinfo
index 21642d543771..d27ba40780f1 100644
--- a/graphics/libopenraw/distinfo
+++ b/graphics/libopenraw/distinfo
@@ -1,3 +1,117 @@
-TIMESTAMP = 1533075086
-SHA256 (libopenraw-0.1.3.tar.bz2) = 6405634f555849eb01cb028e2a63936e7b841151ea2a1571ac5b5b10431cfab9
-SIZE (libopenraw-0.1.3.tar.bz2) = 565458
+TIMESTAMP = 1602554519
+SHA256 (libopenraw-0.2.3.tar.bz2) = aef60cf4d91e8428c82adcf50a5bda80cacae484b1433dc965650232fde3db9a
+SIZE (libopenraw-0.2.3.tar.bz2) = 621988
+SHA256 (rust/crates/ahash-0.3.8.tar.gz) = e8fd72866655d1904d6b0997d0b07ba561047d070fbe29de039031c641b61217
+SIZE (rust/crates/ahash-0.3.8.tar.gz) = 28650
+SHA256 (rust/crates/aho-corasick-0.7.13.tar.gz) = 043164d8ba5c4c3035fec9bbee8647c0261d788f3474306f93bb65901cae0e86
+SIZE (rust/crates/aho-corasick-0.7.13.tar.gz) = 111381
+SHA256 (rust/crates/ansi_term-0.11.0.tar.gz) = ee49baf6cb617b853aa8d93bf420db2383fab46d314482ca2803b40d5fde979b
+SIZE (rust/crates/ansi_term-0.11.0.tar.gz) = 17087
+SHA256 (rust/crates/atty-0.2.14.tar.gz) = d9b39be18770d11421cdb1b9947a45dd3f37e93092cbf377614828a319d5fee8
+SIZE (rust/crates/atty-0.2.14.tar.gz) = 5470
+SHA256 (rust/crates/autocfg-1.0.1.tar.gz) = cdb031dd78e28731d87d56cc8ffef4a8f36ca26c38fe2de700543e627f8a464a
+SIZE (rust/crates/autocfg-1.0.1.tar.gz) = 12908
+SHA256 (rust/crates/bitflags-1.2.1.tar.gz) = cf1de2fe8c75bc145a2f577add951f8134889b4795d47466a54a5c846d691693
+SIZE (rust/crates/bitflags-1.2.1.tar.gz) = 16745
+SHA256 (rust/crates/bitreader-0.3.2.tar.gz) = 5fa7f0adf37cd5472c978a1ff4be89c1880a923d10df4cfef6a10855a666e09b
+SIZE (rust/crates/bitreader-0.3.2.tar.gz) = 10778
+SHA256 (rust/crates/byteorder-1.3.4.tar.gz) = 08c48aae112d48ed9f069b33538ea9e3e90aa263cfa3d1c24309612b1f7472de
+SIZE (rust/crates/byteorder-1.3.4.tar.gz) = 21943
+SHA256 (rust/crates/cbindgen-0.5.2.tar.gz) = efd8d98004eaf27861f76000ea304b888f869191fefeada9d7496c9c24f111cd
+SIZE (rust/crates/cbindgen-0.5.2.tar.gz) = 50806
+SHA256 (rust/crates/cfg-if-0.1.10.tar.gz) = 4785bdd1c96b2a846b2bd7cc02e86b6b3dbf14e7e53446c4f54c92a361040822
+SIZE (rust/crates/cfg-if-0.1.10.tar.gz) = 7933
+SHA256 (rust/crates/clap-2.33.3.tar.gz) = 37e58ac78573c40708d45522f0d80fa2f01cc4f9b4e2bf749807255454312002
+SIZE (rust/crates/clap-2.33.3.tar.gz) = 201925
+SHA256 (rust/crates/env_logger-0.7.1.tar.gz) = 44533bbbb3bb3c1fa17d9f2e4e38bbbaf8396ba82193c4cb1b6445d711445d36
+SIZE (rust/crates/env_logger-0.7.1.tar.gz) = 32281
+SHA256 (rust/crates/fuchsia-cprng-0.1.1.tar.gz) = a06f77d526c1a601b7c4cdd98f54b5eaabffc14d5f2f0296febdc7f357c6d3ba
+SIZE (rust/crates/fuchsia-cprng-0.1.1.tar.gz) = 2950
+SHA256 (rust/crates/hashbrown-0.7.2.tar.gz) = 96282e96bfcd3da0d3aa9938bedf1e50df3269b6db08b4876d2da0bb1a0841cf
+SIZE (rust/crates/hashbrown-0.7.2.tar.gz) = 70480
+SHA256 (rust/crates/hermit-abi-0.1.17.tar.gz) = 5aca5565f760fb5b220e499d72710ed156fdb74e631659e99377d9ebfbd13ae8
+SIZE (rust/crates/hermit-abi-0.1.17.tar.gz) = 10065
+SHA256 (rust/crates/humantime-1.3.0.tar.gz) = df004cfca50ef23c36850aaaa59ad52cc70d0e90243c3c7737a4dd32dc7a3c4f
+SIZE (rust/crates/humantime-1.3.0.tar.gz) = 17020
+SHA256 (rust/crates/itoa-0.4.6.tar.gz) = dc6f3ad7b9d11a0c00842ff8de1b60ee58661048eb8049ed33c73594f359d7e6
+SIZE (rust/crates/itoa-0.4.6.tar.gz) = 12167
+SHA256 (rust/crates/lazy_static-1.4.0.tar.gz) = e2abad23fbc42b3700f2f279844dc832adb2b2eb069b2df918f455c4e18cc646
+SIZE (rust/crates/lazy_static-1.4.0.tar.gz) = 10443
+SHA256 (rust/crates/libc-0.2.79.tar.gz) = 2448f6066e80e3bfc792e9c98bf705b4b0fc6e8ef5b43e5889aff0eaa9c58743
+SIZE (rust/crates/libc-0.2.79.tar.gz) = 511752
+SHA256 (rust/crates/log-0.3.9.tar.gz) = e19e8d5c34a3e0e2223db8e060f9e8264aeeb5c5fc64a4ee9965c062211c024b
+SIZE (rust/crates/log-0.3.9.tar.gz) = 16686
+SHA256 (rust/crates/log-0.4.11.tar.gz) = 4fabed175da42fed1fa0746b0ea71f412aa9d35e76e95e59b192c64b9dc2bf8b
+SIZE (rust/crates/log-0.4.11.tar.gz) = 36276
+SHA256 (rust/crates/memchr-2.3.3.tar.gz) = 3728d817d99e5ac407411fa471ff9800a778d88a24685968b36824eaf4bee400
+SIZE (rust/crates/memchr-2.3.3.tar.gz) = 22566
+SHA256 (rust/crates/num-traits-0.2.12.tar.gz) = ac267bcc07f48ee5f8935ab0d24f316fb722d7a1292e2913f0cc196b29ffd611
+SIZE (rust/crates/num-traits-0.2.12.tar.gz) = 43807
+SHA256 (rust/crates/proc-macro2-0.2.3.tar.gz) = cd07deb3c6d1d9ff827999c7f9b04cdfd66b1b17ae508e14fe47b620f2282ae0
+SIZE (rust/crates/proc-macro2-0.2.3.tar.gz) = 21558
+SHA256 (rust/crates/quick-error-1.2.3.tar.gz) = a1d01941d82fa2ab50be1e79e6714289dd7cde78eba4c074bc5a4374f650dfe0
+SIZE (rust/crates/quick-error-1.2.3.tar.gz) = 15066
+SHA256 (rust/crates/quote-0.3.15.tar.gz) = 7a6e920b65c65f10b2ae65c831a81a073a89edd28c7cce89475bff467ab4167a
+SIZE (rust/crates/quote-0.3.15.tar.gz) = 12041
+SHA256 (rust/crates/rand-0.4.6.tar.gz) = 552840b97013b1a26992c11eac34bdd778e464601a4c2054b5f0bff7c6761293
+SIZE (rust/crates/rand-0.4.6.tar.gz) = 76401
+SHA256 (rust/crates/rand_core-0.3.1.tar.gz) = 7a6fdeb83b075e8266dcc8762c22776f6877a63111121f5f8c7411e5be7eed4b
+SIZE (rust/crates/rand_core-0.3.1.tar.gz) = 15483
+SHA256 (rust/crates/rand_core-0.4.2.tar.gz) = 9c33a3c44ca05fa6f1807d8e6743f3824e8509beca625669633be0acbdf509dc
+SIZE (rust/crates/rand_core-0.4.2.tar.gz) = 20243
+SHA256 (rust/crates/rdrand-0.4.0.tar.gz) = 678054eb77286b51581ba43620cc911abf02758c91f93f479767aed0f90458b2
+SIZE (rust/crates/rdrand-0.4.0.tar.gz) = 6456
+SHA256 (rust/crates/regex-1.3.9.tar.gz) = 9c3780fcf44b193bc4d09f36d2a3c87b251da4a046c87795a0d35f4f927ad8e6
+SIZE (rust/crates/regex-1.3.9.tar.gz) = 236683
+SHA256 (rust/crates/regex-syntax-0.6.18.tar.gz) = 26412eb97c6b088a6997e05f69403a802a92d520de2f8e63c2b65f9e0f47c4e8
+SIZE (rust/crates/regex-syntax-0.6.18.tar.gz) = 294440
+SHA256 (rust/crates/remove_dir_all-0.5.3.tar.gz) = 3acd125665422973a33ac9d3dd2df85edad0f4ae9b00dafb1a05e43a9f5ef8e7
+SIZE (rust/crates/remove_dir_all-0.5.3.tar.gz) = 9184
+SHA256 (rust/crates/ryu-1.0.5.tar.gz) = 71d301d4193d031abdd79ff7e3dd721168a9572ef3fe51a1517aba235bd8f86e
+SIZE (rust/crates/ryu-1.0.5.tar.gz) = 49570
+SHA256 (rust/crates/serde-1.0.102.tar.gz) = 0c4b39bd9b0b087684013a792c59e3e07a46a01d2322518d8a1104641a0b1be0
+SIZE (rust/crates/serde-1.0.102.tar.gz) = 73356
+SHA256 (rust/crates/serde_derive-1.0.21.tar.gz) = 652bc323d694dc925829725ec6c890156d8e70ae5202919869cb00fe2eff3788
+SIZE (rust/crates/serde_derive-1.0.21.tar.gz) = 25544
+SHA256 (rust/crates/serde_derive_internals-0.17.0.tar.gz) = 32f1926285523b2db55df263d2aa4eb69ddcfa7a7eade6430323637866b513ab
+SIZE (rust/crates/serde_derive_internals-0.17.0.tar.gz) = 17674
+SHA256 (rust/crates/serde_json-1.0.58.tar.gz) = a230ea9107ca2220eea9d46de97eddcb04cd00e92d13dda78e478dd33fa82bd4
+SIZE (rust/crates/serde_json-1.0.58.tar.gz) = 114933
+SHA256 (rust/crates/standalone-quote-0.5.0.tar.gz) = dcedac1d6d98e7e9d1d6e628f5635af9566688ae5f6cea70a3976f495ae8d839
+SIZE (rust/crates/standalone-quote-0.5.0.tar.gz) = 14929
+SHA256 (rust/crates/standalone-syn-0.13.0.tar.gz) = 115808f5187c07c23cb93eee49d542fae54c6e8285d3a24c6ff683fcde9243db
+SIZE (rust/crates/standalone-syn-0.13.0.tar.gz) = 132366
+SHA256 (rust/crates/static_assertions-1.1.0.tar.gz) = a2eb9349b6444b326872e140eb1cf5e7c522154d69e7a0ffb0fb81c06b37543f
+SIZE (rust/crates/static_assertions-1.1.0.tar.gz) = 18480
+SHA256 (rust/crates/strsim-0.8.0.tar.gz) = 8ea5119cdb4c55b55d432abb513a0429384878c15dde60cc77b1c99de1a95a6a
+SIZE (rust/crates/strsim-0.8.0.tar.gz) = 9309
+SHA256 (rust/crates/syn-0.11.11.tar.gz) = d3b891b9015c88c576343b9b3e41c2c11a51c219ef067b264bd9c8aa9b441dad
+SIZE (rust/crates/syn-0.11.11.tar.gz) = 63309
+SHA256 (rust/crates/synom-0.11.3.tar.gz) = a393066ed9010ebaed60b9eafa373d4b1baac186dd7e008555b0f702b51945b6
+SIZE (rust/crates/synom-0.11.3.tar.gz) = 17120
+SHA256 (rust/crates/tempdir-0.3.7.tar.gz) = 15f2b5fb00ccdf689e0149d1b1b3c03fead81c2b37735d812fa8bddbbf41b6d8
+SIZE (rust/crates/tempdir-0.3.7.tar.gz) = 11468
+SHA256 (rust/crates/termcolor-1.1.0.tar.gz) = bb6bfa289a4d7c5766392812c0a1f4c1ba45afa1ad47803c11e1f407d846d75f
+SIZE (rust/crates/termcolor-1.1.0.tar.gz) = 17193
+SHA256 (rust/crates/textwrap-0.11.0.tar.gz) = d326610f408c7a4eb6f51c37c330e496b08506c9457c9d34287ecc38809fb060
+SIZE (rust/crates/textwrap-0.11.0.tar.gz) = 17322
+SHA256 (rust/crates/thread_local-1.0.1.tar.gz) = d40c6d1b69745a6ec6fb1ca717914848da4b44ae29d9b3080cbee91d72a69b14
+SIZE (rust/crates/thread_local-1.0.1.tar.gz) = 12609
+SHA256 (rust/crates/toml-0.4.10.tar.gz) = 758664fc71a3a69038656bee8b6be6477d2a6c315a6b81f7081f591bffa4111f
+SIZE (rust/crates/toml-0.4.10.tar.gz) = 47534
+SHA256 (rust/crates/unicode-width-0.1.8.tar.gz) = 9337591893a19b88d8d87f2cec1e73fad5cdfd10e5a6f349f498ad6ea2ffb1e3
+SIZE (rust/crates/unicode-width-0.1.8.tar.gz) = 16732
+SHA256 (rust/crates/unicode-xid-0.0.4.tar.gz) = 8c1f860d7d29cf02cb2f3f359fd35991af3d30bac52c57d265a3c461074cb4dc
+SIZE (rust/crates/unicode-xid-0.0.4.tar.gz) = 16034
+SHA256 (rust/crates/unicode-xid-0.1.0.tar.gz) = fc72304796d0818e357ead4e000d19c9c174ab23dc11093ac919054d20a6a7fc
+SIZE (rust/crates/unicode-xid-0.1.0.tar.gz) = 16000
+SHA256 (rust/crates/vec_map-0.8.2.tar.gz) = f1bddf1187be692e79c5ffeab891132dfb0f236ed36a43c7ed39f1165ee20191
+SIZE (rust/crates/vec_map-0.8.2.tar.gz) = 14466
+SHA256 (rust/crates/winapi-0.3.9.tar.gz) = 5c839a674fcd7a98952e593242ea400abe93992746761e38641405d28b00f419
+SIZE (rust/crates/winapi-0.3.9.tar.gz) = 1200382
+SHA256 (rust/crates/winapi-i686-pc-windows-gnu-0.4.0.tar.gz) = ac3b87c63620426dd9b991e5ce0329eff545bccbbb34f3be09ff6fb6ab51b7b6
+SIZE (rust/crates/winapi-i686-pc-windows-gnu-0.4.0.tar.gz) = 2918815
+SHA256 (rust/crates/winapi-util-0.1.5.tar.gz) = 70ec6ce85bb158151cae5e5c87f95a8e97d2c0c4b001223f33a334e3ce5de178
+SIZE (rust/crates/winapi-util-0.1.5.tar.gz) = 10164
+SHA256 (rust/crates/winapi-x86_64-pc-windows-gnu-0.4.0.tar.gz) = 712e227841d057c1ee1cd2fb22fa7e5a5461ae8e48fa2ca79ec42cfc1931183f
+SIZE (rust/crates/winapi-x86_64-pc-windows-gnu-0.4.0.tar.gz) = 2947998
diff --git a/graphics/libopenraw/files/patch-gnome_include_libopenraw-gnome_Makefile.in b/graphics/libopenraw/files/patch-gnome_include_libopenraw-gnome_Makefile.in
deleted file mode 100644
index 54b17d96c699..000000000000
--- a/graphics/libopenraw/files/patch-gnome_include_libopenraw-gnome_Makefile.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- gnome/include/libopenraw-gnome/Makefile.in.orig 2016-11-27 01:53:40 UTC
-+++ gnome/include/libopenraw-gnome/Makefile.in
-@@ -529,7 +529,8 @@ info: info-am
-
- info-am:
-
--install-data-am: install-libopenrawgnomeHEADERS
-+@BUILD_GNOME_SUPPORT_TRUE@install-data-am: install-libopenrawgnomeHEADERS
-+@BUILD_GNOME_SUPPORT_FALSE@install-data-am:
-
- install-dvi: install-dvi-am
-
diff --git a/graphics/libopenraw/pkg-plist b/graphics/libopenraw/pkg-plist
index a205311e817e..b3dc120929e4 100644
--- a/graphics/libopenraw/pkg-plist
+++ b/graphics/libopenraw/pkg-plist
@@ -1,28 +1,29 @@
-%%GNOME%%include/libopenraw-0.1/libopenraw-gnome/gdkpixbuf.h
-include/libopenraw-0.1/libopenraw/bitmapdata.h
-include/libopenraw-0.1/libopenraw/cameraids.h
-include/libopenraw-0.1/libopenraw/cfapattern.h
-include/libopenraw-0.1/libopenraw/consts.h
-include/libopenraw-0.1/libopenraw/debug.h
-include/libopenraw-0.1/libopenraw/demosaic.h
-include/libopenraw-0.1/libopenraw/exif.h
-include/libopenraw-0.1/libopenraw/io.h
-include/libopenraw-0.1/libopenraw/libopenraw.h
-include/libopenraw-0.1/libopenraw/metadata.h
-include/libopenraw-0.1/libopenraw/prefix.h
-include/libopenraw-0.1/libopenraw/rawdata.h
-include/libopenraw-0.1/libopenraw/rawfile.h
-include/libopenraw-0.1/libopenraw/thumbnails.h
-include/libopenraw-0.1/libopenraw/types.h
+%%GNOME%%include/libopenraw-%%VER%%/libopenraw-gnome/gdkpixbuf.h
+include/libopenraw-%%VER%%/libopenraw/bitmapdata.h
+include/libopenraw-%%VER%%/libopenraw/cameraids.h
+include/libopenraw-%%VER%%/libopenraw/consts.h
+include/libopenraw-%%VER%%/libopenraw/debug.h
+include/libopenraw-%%VER%%/libopenraw/demosaic.h
+include/libopenraw-%%VER%%/libopenraw/exif.h
+include/libopenraw-%%VER%%/libopenraw/ifd.h
+include/libopenraw-%%VER%%/libopenraw/io.h
+include/libopenraw-%%VER%%/libopenraw/libopenraw.h
+include/libopenraw-%%VER%%/libopenraw/metadata.h
+include/libopenraw-%%VER%%/libopenraw/mosaicinfo.h
+include/libopenraw-%%VER%%/libopenraw/prefix.h
+include/libopenraw-%%VER%%/libopenraw/rawdata.h
+include/libopenraw-%%VER%%/libopenraw/rawfile.h
+include/libopenraw-%%VER%%/libopenraw/thumbnails.h
+include/libopenraw-%%VER%%/libopenraw/types.h
%%GNOME%%lib/gdk-pixbuf-2.0/%%GTK2_VERSION%%/loaders/libopenraw_pixbuf.a
%%GNOME%%lib/gdk-pixbuf-2.0/%%GTK2_VERSION%%/loaders/libopenraw_pixbuf.so
lib/libopenraw.a
lib/libopenraw.so
-lib/libopenraw.so.7
-lib/libopenraw.so.7.0.3
+lib/libopenraw.so.8
+lib/libopenraw.so.8.0.3
%%GNOME%%lib/libopenrawgnome.a
%%GNOME%%lib/libopenrawgnome.so
-%%GNOME%%lib/libopenrawgnome.so.7
-%%GNOME%%lib/libopenrawgnome.so.7.0.3
-libdata/pkgconfig/libopenraw-0.1.pc
-%%GNOME%%libdata/pkgconfig/libopenraw-gnome-0.1.pc
+%%GNOME%%lib/libopenrawgnome.so.8
+%%GNOME%%lib/libopenrawgnome.so.8.0.3
+libdata/pkgconfig/libopenraw-%%VER%%.pc
+%%GNOME%%libdata/pkgconfig/libopenraw-gnome-%%VER%%.pc