aboutsummaryrefslogtreecommitdiff
path: root/graphics/libosmesa
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-09-17 18:07:25 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-09-17 18:07:25 +0000
commit05360ec71eab4f178074bd97c1373e7659a59bbb (patch)
treea430ad3dbd823ddb88d16ecc11a7a7035985cf79 /graphics/libosmesa
parent7bc4660db0fb55cc34f11c9263904d676fc7445b (diff)
downloadports-05360ec71eab4f178074bd97c1373e7659a59bbb.tar.gz
ports-05360ec71eab4f178074bd97c1373e7659a59bbb.zip
Update Mesa port to 10.6.6 and add Clover.
Add beignet 1.1.0. Add clinfo, clblas, clfft and clrng. The major change is that all Mesa ports are now configured the same way. This fixes several problems and enables new features. The details are described in this blog post: http://blogs.freebsdish.org/graphics/2015/03/18/unifying-mesa-ports-configure/ The second important change is the OpenCL support. Mesa's implementation, Clover, is enabled as well as Beignet. Clover targets all Gallium drivers, only Radeon GPUs in our case. Beignet is for Intel GPUs starting with Ivy Bridge. Thanks to Johannes Dieterich, O. Hartman, and Koop Mast for their work on OpenCL! As a bonus, there are several OpenCL-based math ports added (clblas, clfft and clrng). For more information and known issues, please see https://wiki.freebsd.org/Graphics/OpenCL The third change is the removal of Mesa 9.1.7 which was installed on FreeBSD 9.3-RELEASE. There is now only one version of Mesa in the Ports tree (10.6.6) for all supported versions of FreeBSD. Other, smaller changes: * Include libosmesa into the Mesa framework; this changes libOSMesa shlib version. * bsd.mesalib.mk was renamed and split up in two files namely Makefile.common and Makefile.targets. So ports can overwrite variables set by Makefile.common and are used by Makefile.targets. * Some text in the pkg-descr files was wrong, clean it up. While here, update the WWW to the main mesa3d.org upstream page. * devel/clinfo was added, a glxinfo like program but for OpenCL. Non-x86 hardware reports are very welcome since we changed the framework quite a bit. Obtained from: Graphics team development repo.
Notes
Notes: svn path=/head/; revision=397198
Diffstat (limited to 'graphics/libosmesa')
-rw-r--r--graphics/libosmesa/Makefile77
-rw-r--r--graphics/libosmesa/files/patch-Makefile.in13
-rw-r--r--graphics/libosmesa/files/patch-src-mesa-main_macros.h10
-rw-r--r--graphics/libosmesa/pkg-plist14
4 files changed, 28 insertions, 86 deletions
diff --git a/graphics/libosmesa/Makefile b/graphics/libosmesa/Makefile
index cd51967d56cd..80d0a00b09ba 100644
--- a/graphics/libosmesa/Makefile
+++ b/graphics/libosmesa/Makefile
@@ -2,59 +2,32 @@
# $FreeBSD$
PORTNAME= libosmesa
-PORTVERSION= 10.2.7
-PORTREVISION= 1
+PORTVERSION= ${MESAVERSION}
+PORTREVISION= 0
CATEGORIES= graphics
-MASTER_SITES= ftp://ftp.freedesktop.org/pub/mesa/${PORTVERSION}/
-DISTNAME= MesaLib-${PORTVERSION}
-MAINTAINER= x11@FreeBSD.org
COMMENT= Off-Screen Mesa implementation of the OpenGL API
-LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
-BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/libxml2mod.so:${PORTSDIR}/textproc/py-libxml2 \
- ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
-
-USES= bison gmake pkgconfig tar:bzip2 libtool python:2
-USE_LDCONFIG= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV+= ac_cv_prog_YACC=${LOCALBASE}/bin/bison \
- ac_cv_prog_LEX=${LOCALBASE}/bin/flex
-CONFIGURE_ARGS+=--enable-osmesa \
- --disable-driglx-direct \
- --disable-gallium-llvm \
- --disable-glx \
- --disable-dri \
- --disable-egl \
- --with-gallium-drivers=swrast
-CFLAGS+= -I${LOCALBASE}/include
-
-WRKSRC= ${WRKDIR}/Mesa-${PORTVERSION}
-MAKE_JOBS_UNSAFE=yes
-
-INCLUDES= gl.h gl_mangle.h glext.h glx.h glx_mangle.h \
- glxext.h osmesa.h wglext.h wmesa.h
-
-.include <bsd.port.pre.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1100000 && ${ARCH} == i386
-BROKEN= Doesn't build
-.endif
-
-post-patch:
- ${REINPLACE_CMD} \
- -e '/^OSMESA_VERSION=/s|8|9|' \
- -e 's|-fno-builtin-memcmp||g' \
- ${WRKSRC}/configure
-
-do-install:
- ${MKDIR} ${STAGEDIR}${PREFIX}/include/Mesa/GL
-.for inc in ${INCLUDES}
- ${INSTALL_DATA} ${WRKSRC}/include/GL/${inc} ${STAGEDIR}${PREFIX}/include/Mesa/GL/
-.endfor
- ${INSTALL_LIB} ${WRKSRC}/src/mesa/drivers/osmesa/.libs/libOSMesa.so.9.0.0 ${STAGEDIR}${PREFIX}/lib
- ${LN} -s libOSMesa.so.9.0.0 ${STAGEDIR}${PREFIX}/lib/libOSMesa.so.9
- ${LN} -s libOSMesa.so.9.0.0 ${STAGEDIR}${PREFIX}/lib/libOSMesa.so
- ${INSTALL_DATA} ${WRKSRC}/src/mesa/drivers/osmesa/osmesa.pc ${STAGEDIR}${PREFIX}/libdata/pkgconfig/osmesa.pc
-
-.include <bsd.port.post.mk>
+LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libglapi.so:${PORTSDIR}/graphics/libglapi
+
+USE_XORG= x11 xau xcb xdmcp xvmc
+# libosmesa doesn't link agains libGL but osmesa.h needs GL/gl.h
+# and both headers are intalled by libGL ....
+USE_GL= gl
+
+.include <bsd.port.options.mk>
+
+.include "${.CURDIR}/../../graphics/libGL/Makefile.common"
+
+#MESA_BUILD_WRKSRC= src/util src/glsl src/mesa #/drivers/osmesa
+MESA_INSTALL_WRKSRC= src/mesa/drivers/osmesa
+
+.include "${.CURDIR}/../../graphics/libGL/Makefile.targets"
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/include/GL
+ ${INSTALL_DATA} ${WRKSRC}/include/GL/osmesa.h \
+ ${STAGEDIR}${PREFIX}/include/GL
+
+.include <bsd.port.mk>
diff --git a/graphics/libosmesa/files/patch-Makefile.in b/graphics/libosmesa/files/patch-Makefile.in
deleted file mode 100644
index 03465fd412e5..000000000000
--- a/graphics/libosmesa/files/patch-Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- Makefile.in.orig 2014-06-10 10:07:40.000000000 +0200
-+++ Makefile.in 2014-06-10 10:08:27.000000000 +0200
-@@ -85,9 +85,7 @@
- $(top_srcdir)/m4/ax_gcc_builtin.m4 \
- $(top_srcdir)/m4/ax_prog_bison.m4 \
- $(top_srcdir)/m4/ax_prog_flex.m4 \
-- $(top_srcdir)/m4/ax_pthread.m4 $(top_srcdir)/m4/libtool.m4 \
-- $(top_srcdir)/m4/ltoptions.m4 $(top_srcdir)/m4/ltsugar.m4 \
-- $(top_srcdir)/m4/ltversion.m4 $(top_srcdir)/m4/lt~obsolete.m4 \
-+ $(top_srcdir)/m4/ax_pthread.m4 \
- $(top_srcdir)/VERSION $(top_srcdir)/configure.ac
- am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
- $(ACLOCAL_M4)
diff --git a/graphics/libosmesa/files/patch-src-mesa-main_macros.h b/graphics/libosmesa/files/patch-src-mesa-main_macros.h
deleted file mode 100644
index 4b51ae98ce55..000000000000
--- a/graphics/libosmesa/files/patch-src-mesa-main_macros.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/mesa/main/macros.h.orig 2010-10-19 08:03:53.000000000 +0000
-+++ src/mesa/main/macros.h 2010-10-19 08:05:32.000000000 +0000
-@@ -33,6 +33,7 @@
-
- #include "imports.h"
-
-+#define log2(x) (log(x) / log(2))
-
- /**
- * \name Integer / float conversion for colors, normals, etc.
diff --git a/graphics/libosmesa/pkg-plist b/graphics/libosmesa/pkg-plist
index 5355f93fe090..32252afe1a29 100644
--- a/graphics/libosmesa/pkg-plist
+++ b/graphics/libosmesa/pkg-plist
@@ -1,13 +1,5 @@
-include/Mesa/GL/gl.h
-include/Mesa/GL/gl_mangle.h
-include/Mesa/GL/glext.h
-include/Mesa/GL/glx.h
-include/Mesa/GL/glx_mangle.h
-include/Mesa/GL/glxext.h
-include/Mesa/GL/osmesa.h
-include/Mesa/GL/wglext.h
-include/Mesa/GL/wmesa.h
+include/GL/osmesa.h
lib/libOSMesa.so
-lib/libOSMesa.so.9
-lib/libOSMesa.so.9.0.0
+lib/libOSMesa.so.8
+lib/libOSMesa.so.8.0.0
libdata/pkgconfig/osmesa.pc