aboutsummaryrefslogtreecommitdiff
path: root/graphics/libosmesa
diff options
context:
space:
mode:
authorEmmanuel Vadot <manu@FreeBSD.org>2020-10-12 08:30:54 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2020-10-12 08:30:54 +0000
commit57ce68a0c0cab56c3d08120e6f55c11a8c248f06 (patch)
tree88e8ad4aa5aa680ec7c0bbc956676c47044a89fc /graphics/libosmesa
parent3870ad6c4bb281c7abf1b06de72b9adfd658d96f (diff)
downloadports-57ce68a0c0cab56c3d08120e6f55c11a8c248f06.tar.gz
ports-57ce68a0c0cab56c3d08120e6f55c11a8c248f06.zip
graphics/mesa*: Update to 20.2
Update to 20.2 Move graphics/libxatracker to graphics/mesa-gallium-xa Remove VAAPI and VDPAU options in mesa-libs in favor of two new ports : mesa-gallium-va and mesa-gallium-vdpau Bump needed llvm to llvm10 Change a lot of meson option from false to disabled as it's deprecated. Remove the drm and surfaceless platform from mesa* as it's always enabled now. Add zstd option, used for shader cache. Reviewed by: x11 (zeising@) Differential Revision: https://reviews.freebsd.org/D26682
Notes
Notes: svn path=/head/; revision=552109
Diffstat (limited to 'graphics/libosmesa')
-rw-r--r--graphics/libosmesa/Makefile23
1 files changed, 11 insertions, 12 deletions
diff --git a/graphics/libosmesa/Makefile b/graphics/libosmesa/Makefile
index fe362f82f16a..bf34ae47b11b 100644
--- a/graphics/libosmesa/Makefile
+++ b/graphics/libosmesa/Makefile
@@ -3,7 +3,6 @@
PORTNAME= libosmesa
PORTVERSION= ${MESAVERSION}
-PORTREVISION= 1
CATEGORIES= graphics
COMMENT= Off-Screen Mesa implementation of the OpenGL API
@@ -14,26 +13,26 @@ USE_XORG= xorgproto
.include <bsd.port.options.mk>
.include "${.CURDIR:H:H}/graphics/mesa-dri/Makefile.common"
-
# Disable some options
MESON_ARGS+= -Ddri-drivers="" \
-Dgallium-drivers=swrast \
-Dvulkan-drivers="" \
-Dplatforms="" \
- -Dgallium-vdpau=false \
+ -Dgallium-vdpau=disabled \
-Dgallium-omx=disabled \
- -Dgallium-va=false \
+ -Dgallium-va=disabled \
-Dgallium-opencl=disabled \
- -Dgallium-xa=false \
- -Dgallium-xvmc=false \
+ -Dgallium-xa=disabled \
+ -Dgallium-xvmc=disabled \
-Dgallium-nine=false \
- -Dgles1=false \
- -Dgles2=false \
- -Dopengl=false \
+ -Dgles1=disabled \
+ -Dgles2=disabled \
+ -Dopengl=true \
-Dglx=disabled \
- -Degl=false \
- -Dgbm=false \
- -Dtools=""
+ -Degl=disabled \
+ -Dgbm=disabled \
+ -Dtools="" \
+ -Dzstd=disabled
LDFLAGS_i386= -Wl,-znotext
.if ${ARCH} == sparc64