aboutsummaryrefslogtreecommitdiff
path: root/graphics/libosmesa
diff options
context:
space:
mode:
authorEd Maste <emaste@FreeBSD.org>2018-09-20 19:07:00 +0000
committerEd Maste <emaste@FreeBSD.org>2018-09-20 19:07:00 +0000
commit5b7798fc9ead82614262ec22345cd443440b09f0 (patch)
treec753fd9988aa376ebcb5d9eabecc744d408af5e1 /graphics/libosmesa
parente40327df3155f55c2b0d074aa616da14c2fb273b (diff)
downloadports-5b7798fc9ead82614262ec22345cd443440b09f0.tar.gz
ports-5b7798fc9ead82614262ec22345cd443440b09f0.zip
graphics/libosmesa: add -znotext to LDFLAGS on i386, for lld
This port links some non-PIC code, which fails with lld as it defaults to disallowing relocations against read-only segments. For i386 we can just add -znotext unconditionally: for GNU BFD ld it just affirms BFD's existing default. PR: 214864 Approved by: portmgr (lld blanket) Sponsored by: The FreeBSD Foundation
Notes
Notes: svn path=/head/; revision=480190
Diffstat (limited to 'graphics/libosmesa')
-rw-r--r--graphics/libosmesa/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/graphics/libosmesa/Makefile b/graphics/libosmesa/Makefile
index c09d71bb3df7..e00d7ffa4d80 100644
--- a/graphics/libosmesa/Makefile
+++ b/graphics/libosmesa/Makefile
@@ -16,6 +16,7 @@ USE_XORG= xorgproto
CONFIGURE_ARGS+= --disable-dri --disable-egl --disable-gbm \
--disable-gles2 --with-gallium-drivers=swrast
MESA_BUILD_WRKSRC= src/util src/compiler src/mapi src/mesa
+LDFLAGS_i386= -Wl,-znotext
.if "${MESA_LLVM_VER}" != ""
CONFIGURE_ARGS+= --enable-osmesa-gallium