aboutsummaryrefslogtreecommitdiff
path: root/graphics/libosmesa
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-06-04 11:04:27 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-06-04 11:04:27 +0000
commit89e3f88888bf450b5ff7bdb57986afc33860f67d (patch)
treeeab54485a0d606b4f9e02fff39b268f941e3f5a6 /graphics/libosmesa
parentc66c9859ac1b8da135396d81c5b56187dfb03e51 (diff)
downloadports-89e3f88888bf450b5ff7bdb57986afc33860f67d.tar.gz
ports-89e3f88888bf450b5ff7bdb57986afc33860f67d.zip
Mark libosmesa broken on 11-i386 for now. This should stop
the fallout mail. We have a fix for the build issue but the fix depends on other changes to the mesa ports. This mesa update will be commit after 8.4-R has gone EOL.
Notes
Notes: svn path=/head/; revision=388522
Diffstat (limited to 'graphics/libosmesa')
-rw-r--r--graphics/libosmesa/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/graphics/libosmesa/Makefile b/graphics/libosmesa/Makefile
index f82d79c63985..cd51967d56cd 100644
--- a/graphics/libosmesa/Makefile
+++ b/graphics/libosmesa/Makefile
@@ -35,6 +35,12 @@ MAKE_JOBS_UNSAFE=yes
INCLUDES= gl.h gl_mangle.h glext.h glx.h glx_mangle.h \
glxext.h osmesa.h wglext.h wmesa.h
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1100000 && ${ARCH} == i386
+BROKEN= Doesn't build
+.endif
+
post-patch:
${REINPLACE_CMD} \
-e '/^OSMESA_VERSION=/s|8|9|' \
@@ -51,4 +57,4 @@ do-install:
${LN} -s libOSMesa.so.9.0.0 ${STAGEDIR}${PREFIX}/lib/libOSMesa.so
${INSTALL_DATA} ${WRKSRC}/src/mesa/drivers/osmesa/osmesa.pc ${STAGEDIR}${PREFIX}/libdata/pkgconfig/osmesa.pc
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>