aboutsummaryrefslogtreecommitdiff
path: root/graphics/libosmesa
diff options
context:
space:
mode:
authorMatthew Rezny <rezny@FreeBSD.org>2017-05-12 18:46:53 +0000
committerMatthew Rezny <rezny@FreeBSD.org>2017-05-12 18:46:53 +0000
commite6acde078ce1b7bc02fb9d8eefbbf31b95dc03c1 (patch)
tree6651ec21aaf32f47dda7b92dcfb61385f580c8c9 /graphics/libosmesa
parenta23420f8df8cc1c52c521c259b55df007d4fa211 (diff)
downloadports-e6acde078ce1b7bc02fb9d8eefbbf31b95dc03c1.tar.gz
ports-e6acde078ce1b7bc02fb9d8eefbbf31b95dc03c1.zip
Consolidate the Mesa ports, update to 17.0.4, and add Wayland option
* libGL, libEGL, libglesv2, libglapi, and gbm have been moved into mesa-libs, graphics/dri has been renamed to mesa-dri, and USE_GL has been adjusted * mesa-libs has a new WAYLAND option that enables platform support in libEGL * mesa-dri now depends on graphics/s2tc for compressed texture support [1] * re-remove obsolete dependency on makedepends [2] * correct sed fix backported from 17.1 [3] PR: 218799 (exp-run), 212762 [1], 218552 [2], 218562 [3] Submitted by: dbn [1], jbeich [2,3] Reported by: afiskon@devzen.ru [1] Reviewed by: kwm, johalun0@gmail.com Approved by: portmgr, swills (mentor) Differential Revision: https://reviews.freebsd.org/D10448
Notes
Notes: svn path=/head/; revision=440699
Diffstat (limited to 'graphics/libosmesa')
-rw-r--r--graphics/libosmesa/Makefile27
1 files changed, 16 insertions, 11 deletions
diff --git a/graphics/libosmesa/Makefile b/graphics/libosmesa/Makefile
index 04502b6cdae1..bc31ed35fec6 100644
--- a/graphics/libosmesa/Makefile
+++ b/graphics/libosmesa/Makefile
@@ -3,27 +3,32 @@
PORTNAME= libosmesa
PORTVERSION= ${MESAVERSION}
-PORTREVISION= 0
CATEGORIES= graphics
COMMENT= Off-Screen Mesa implementation of the OpenGL API
LIB_DEPENDS= libexpat.so:textproc/expat2 \
- libglapi.so:graphics/libglapi
+ libglapi.so:graphics/mesa-libs
-USE_XORG= dri2proto dri3proto glproto presentproto x11 xau xcb xdmcp xvmc
-# libosmesa doesn't link agains libGL but osmesa.h needs GL/gl.h
-# and both headers are intalled by libGL ....
-USE_GL= gl
+USE_XORG= glproto
.include <bsd.port.options.mk>
-
-.include "${.CURDIR}/../../graphics/libGL/Makefile.common"
-
-#MESA_BUILD_WRKSRC= src/util src/glsl src/mesa #/drivers/osmesa
+.include "${.CURDIR}/../../graphics/mesa-dri/Makefile.common"
+
+CONFIGURE_ARGS+= --disable-dri --disable-egl --disable-gbm \
+ --with-gallium-drivers=swrast
+MESA_BUILD_WRKSRC= src/util src/compiler src/mapi src/mesa
+
+.if "${MESA_LLVM_VER}" != ""
+CONFGIURE_ARGS+= --enable-osmesa-gallium
+MESA_BUILD_WRKSRC+= src/gallium
+MESA_INSTALL_WRKSRC= src/gallium/state_trackers/osmesa src/gallium/targets/osmesa
+.else
+CONFIGURE_ARGS+= --enable-osmesa
MESA_INSTALL_WRKSRC= src/mesa/drivers/osmesa
+.endif
-.include "${.CURDIR}/../../graphics/libGL/Makefile.targets"
+.include "${.CURDIR}/../../graphics/mesa-dri/Makefile.targets"
post-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/include/GL