aboutsummaryrefslogtreecommitdiff
path: root/graphics/libplacebo
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-02-25 22:07:54 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-02-25 22:07:54 +0000
commit0335c38a4b27892d8da53dbbdb70b1fffc6aba0b (patch)
tree2616b56081f1f233cbc8261e31e92505ef25daee /graphics/libplacebo
parent884c315c62251cecb08e804006318ef02b8aa1a9 (diff)
downloadports-0335c38a4b27892d8da53dbbdb70b1fffc6aba0b.tar.gz
ports-0335c38a4b27892d8da53dbbdb70b1fffc6aba0b.zip
Add option helper for MESON_ARGS = -Dfoo=enabled
feature options define combo like auto/yes/no in a standand way. In other words, upstream projects of ports that use _MESON_YES are supposed to migrate to _MESON_ENABLED. https://mesonbuild.com/Build-options.html#features Reviewed by: tobik (implicit) Approved by: portmgr (mat) Differential Revision: https://reviews.freebsd.org/D19127
Notes
Notes: svn path=/head/; revision=493901
Diffstat (limited to 'graphics/libplacebo')
-rw-r--r--graphics/libplacebo/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/graphics/libplacebo/Makefile b/graphics/libplacebo/Makefile
index ca38dd255bde..2f09765b5899 100644
--- a/graphics/libplacebo/Makefile
+++ b/graphics/libplacebo/Makefile
@@ -27,18 +27,15 @@ OPTIONS_SINGLE_VULKAN= GLSLANG SHADERC
GLSLANG_DESC= glslang SPIR-V compiler
GLSLANG_BUILD_DEPENDS= glslang>0:devel/glslang
-GLSLANG_MESON_ON= -Dglslang=enabled
-GLSLANG_MESON_OFF= -Dglslang=disabled
+GLSLANG_MESON_ENABLED= glslang
GLSLANG_IMPLIES= VULKAN
LCMS2_LIB_DEPENDS= liblcms2.so:graphics/lcms2
-LCMS2_MESON_ON= -Dlcms=enabled
-LCMS2_MESON_OFF= -Dlcms=disabled
+LCMS2_MESON_ENABLED= lcms
SHADERC_DESC= libshaderc SPIR-V compiler
SHADERC_LIB_DEPENDS= libshaderc_shared.so:graphics/shaderc
-SHADERC_MESON_ON= -Dshaderc=enabled
-SHADERC_MESON_OFF= -Dshaderc=disabled
+SHADERC_MESON_ENABLED= shaderc
SHADERC_IMPLIES= VULKAN
TEST_MESON_TRUE= tests
@@ -46,8 +43,7 @@ TEST_MESON_TRUE= tests
VULKAN_DESC= Vulkan-based renderer
VULKAN_BUILD_DEPENDS= ${LOCALBASE}/include/vulkan/vulkan.h:devel/vulkan-headers
VULKAN_LIB_DEPENDS= libvulkan.so:graphics/vulkan-loader
-VULKAN_MESON_ON= -Dvulkan=enabled
-VULKAN_MESON_OFF= -Dvulkan=disabled
+VULKAN_MESON_ENABLED= vulkan
post-patch:
# Extract (snapshot) version from port version instead of meson.build