aboutsummaryrefslogtreecommitdiff
path: root/graphics/libplacebo
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-06-12 16:08:06 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-06-12 16:08:06 +0000
commit576dc75fa7ba10eca270ef55f3d1b394844de08e (patch)
tree0f5b6209308881075dba0f7e9fa860223b998042 /graphics/libplacebo
parent652b649d2d2f42ed74a62bbd2f31f1855ac6765f (diff)
downloadports-576dc75fa7ba10eca270ef55f3d1b394844de08e.tar.gz
ports-576dc75fa7ba10eca270ef55f3d1b394844de08e.zip
graphics/libplacebo: unbreak GLSLANG after r535260
src/meson.build:64:2: ERROR: C++ library 'glslang' not found Running compile: Working directory: /wrkdirs/usr/ports/graphics/libplacebo/work/libplacebo-2.72.0/_build/meson-private/tmpnxxyvdwe Command line: c++ -L/usr/local/lib /wrkdirs/usr/ports/graphics/libplacebo/work/libplacebo-2.72.0/_build/meson-private/tmpnxxyvdwe/testfile.cpp -o /wrkdirs/usr/ports/graphics/libplacebo/work/libplacebo-2.72.0/_build/meson-private/tmpnxxyvdwe/output.exe -pipe -O2 -fstack-protector-strong -isystem /usr/local/include -fno-strict-aliasing -isystem /usr/local/include -isystem /usr/local/include -D_FILE_OFFSET_BITS=64 -O0 -fpermissive -Wl,--start-group -lglslang -Wl,--end-group -Wl,--allow-shlib-undefined Code: int main(void) { return 0; } Compiler stdout: Compiler stderr: ld: error: undefined symbol: glslang::OS_GetTLSValue(void*) >>> referenced by PoolAlloc.cpp >>> PoolAlloc.cpp.o:(glslang::GetThreadPoolAllocator()) in archive /usr/local/lib/libglslang.a ld: error: undefined symbol: glslang::OS_SetTLSValue(void*, void*) >>> referenced by PoolAlloc.cpp >>> PoolAlloc.cpp.o:(glslang::SetThreadPoolAllocator(glslang::TPoolAllocator*)) in archive /usr/local/lib/libglslang.a ld: error: undefined symbol: glslang::OS_AllocTLSIndex() >>> referenced by PoolAlloc.cpp >>> PoolAlloc.cpp.o:(glslang::InitializePoolIndex()) in archive /usr/local/lib/libglslang.a ld: error: undefined symbol: glslang::GlslangToSpv(glslang::TIntermediate const&, std::__1::vector<unsigned int, std::__1::allocator<unsigned int> >&, spv::SpvBuildLogger*, glslang::SpvOptions*) >>> referenced by glslang_c_interface.cpp >>> glslang_c_interface.cpp.o:(glslang_program_SPIRV_generate) in archive /usr/local/lib/libglslang.a ld: error: undefined symbol: spv::SpvBuildLogger::getAllMessages() const >>> referenced by glslang_c_interface.cpp >>> glslang_c_interface.cpp.o:(glslang_program_SPIRV_generate) in archive /usr/local/lib/libglslang.a ld: error: undefined symbol: glslang::InitGlobalLock() >>> referenced by ShaderLang.cpp >>> ShaderLang.cpp.o:(ShInitialize) in archive /usr/local/lib/libglslang.a ld: error: undefined symbol: glslang::InitProcess() >>> referenced by ShaderLang.cpp >>> ShaderLang.cpp.o:(ShInitialize) in archive /usr/local/lib/libglslang.a ld: error: undefined symbol: glslang::GetGlobalLock() >>> referenced by ShaderLang.cpp >>> ShaderLang.cpp.o:(ShInitialize) in archive /usr/local/lib/libglslang.a ld: error: undefined symbol: glslang::ReleaseGlobalLock() >>> referenced by ShaderLang.cpp >>> ShaderLang.cpp.o:(ShInitialize) in archive /usr/local/lib/libglslang.a ld: error: undefined symbol: glslang::HlslScanContext::fillInKeywordMap() >>> referenced by ShaderLang.cpp >>> ShaderLang.cpp.o:(ShInitialize) in archive /usr/local/lib/libglslang.a ld: error: undefined symbol: glslang::InitThread() >>> referenced by ShaderLang.cpp >>> ShaderLang.cpp.o:(ShConstructCompiler) in archive /usr/local/lib/libglslang.a ld: error: undefined symbol: glslang::InitThread() >>> referenced by ShaderLang.cpp >>> ShaderLang.cpp.o:(ShConstructLinker) in archive /usr/local/lib/libglslang.a ld: error: undefined symbol: glslang::InitThread() >>> referenced by ShaderLang.cpp >>> ShaderLang.cpp.o:(ShConstructUniformMap) in archive /usr/local/lib/libglslang.a ld: error: undefined symbol: glslang::GetGlobalLock() >>> referenced by ShaderLang.cpp >>> ShaderLang.cpp.o:(ShFinalize) in archive /usr/local/lib/libglslang.a ld: error: undefined symbol: glslang::ReleaseGlobalLock() >>> referenced by ShaderLang.cpp >>> ShaderLang.cpp.o:(ShFinalize) in archive /usr/local/lib/libglslang.a ld: error: undefined symbol: glslang::HlslScanContext::deleteKeywordMap() >>> referenced by ShaderLang.cpp >>> ShaderLang.cpp.o:(ShFinalize) in archive /usr/local/lib/libglslang.a ld: error: undefined symbol: glslang::InitThread() >>> referenced by ShaderLang.cpp >>> ShaderLang.cpp.o:(glslang::TShader::parse(TBuiltInResource const*, int, EProfile, bool, bool, EShMessages, glslang::TShader::Includer&)) in archive /usr/local/lib/libglslang.a ld: error: undefined symbol: glslang::InitThread() >>> referenced by ShaderLang.cpp >>> ShaderLang.cpp.o:(glslang::TShader::preprocess(TBuiltInResource const*, int, EProfile, bool, bool, EShMessages, std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> >*, glslang::TShader::Includer&)) in archive /usr/local/lib/libglslang.a ld: error: undefined symbol: glslang::GetGlobalLock() >>> referenced by ShaderLang.cpp >>> ShaderLang.cpp.o:((anonymous namespace)::SetupBuiltinSymbolTable(int, EProfile, glslang::SpvVersion const&, glslang::EShSource)) in archive /usr/local/lib/libglslang.a ld: error: undefined symbol: glslang::ReleaseGlobalLock() >>> referenced by ShaderLang.cpp >>> ShaderLang.cpp.o:((anonymous namespace)::SetupBuiltinSymbolTable(int, EProfile, glslang::SpvVersion const&, glslang::EShSource)) in archive /usr/local/lib/libglslang.a ld: error: too many errors emitted, stopping now (use -error-limit=0 to see all errors) c++: error: linker command failed with exit code 1 (use -v to see invocation) Reported by: VVD <vvd@unislabs.com>
Notes
Notes: svn path=/head/; revision=538625
Diffstat (limited to 'graphics/libplacebo')
-rw-r--r--graphics/libplacebo/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/graphics/libplacebo/Makefile b/graphics/libplacebo/Makefile
index a7a8cdaa696b..4345dda20bca 100644
--- a/graphics/libplacebo/Makefile
+++ b/graphics/libplacebo/Makefile
@@ -25,6 +25,7 @@ OPTIONS_SUB= yes
GLSLANG_DESC= glslang SPIR-V compiler
GLSLANG_BUILD_DEPENDS= glslang>0:devel/glslang
GLSLANG_MESON_ENABLED= glslang
+GLSLANG_VARS= LLD_UNSAFE=yes
GLSLANG_IMPLIES= VULKAN
LCMS2_LIB_DEPENDS= liblcms2.so:graphics/lcms2