aboutsummaryrefslogtreecommitdiff
path: root/graphics/libprojectm/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-02-14 03:27:15 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-02-14 03:27:15 +0000
commit359ee6f331dc34ff5978e1a6616a6eaf97395940 (patch)
treef43483c7710e265285865bad5bacfe295d1dc48f /graphics/libprojectm/Makefile
parent4b047a51f34f0b2a9e043d9e7a30761aad614ba7 (diff)
downloadports-359ee6f331dc34ff5978e1a6616a6eaf97395940.tar.gz
ports-359ee6f331dc34ff5978e1a6616a6eaf97395940.zip
Notes
Diffstat (limited to 'graphics/libprojectm/Makefile')
-rw-r--r--graphics/libprojectm/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/graphics/libprojectm/Makefile b/graphics/libprojectm/Makefile
new file mode 100644
index 000000000000..0b00bb15c8f0
--- /dev/null
+++ b/graphics/libprojectm/Makefile
@@ -0,0 +1,42 @@
+# New ports collection Makefile for: libprojectM
+# Date created: 8 December 2010
+# Whom: utisoft@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= libprojectM
+PORTVERSION= 2.0.1
+CATEGORIES= graphics audio
+MASTER_SITES= SF/${PORTNAME:L:S/lib//}/${PORTVERSION}/
+DISTNAME= ${PORTNAME:S/lib//}-${DISTVERSION}-Source
+
+MAINTAINER= utisoft@gmail.com
+COMMENT= An awesome music visualiser
+
+LICENSE= LGPL21
+
+LIB_DEPENDS= ftgl:${PORTSDIR}/graphics/ftgl \
+ GLEW:${PORTSDIR}/graphics/glew \
+ freetype:${PORTSDIR}/print/freetype2
+
+USE_CMAKE= yes
+CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+USE_LDCONFIG= yes
+
+post-patch:
+# Install config.inp.sample instead of overwriting user's file.
+# Needs to be specific enough not to rename config.inp.in too!
+ @${REINPLACE_CMD} -e 's/config.inp\([\" ]\)/config.inp.sample\1/' \
+ -e 's#/pkgconfig#data/pkgconfig#' \
+ ${WRKSRC}/CMakeLists.txt
+ @${REINPLACE_CMD} -e 's#/usr/X11R6#${LOCALBASE}#' \
+ ${WRKSRC}/cmake/FindFreetype2.cmake
+
+post-install:
+ @if [ ! -f ${PREFIX}/share/projectM/config.inp ]; then \
+ ${CP} -p ${PREFIX}/share/projectM/config.inp.sample \
+ ${PREFIX}/share/projectM/config.inp ; \
+ fi
+
+.include <bsd.port.mk>