aboutsummaryrefslogtreecommitdiff
path: root/graphics/libqrencode
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2006-12-14 02:53:29 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2006-12-14 02:53:29 +0000
commit4c3225c14cf2d596314e33a0b78752d2cc6501f8 (patch)
tree9e2d4b90d261506b928ea451313d95e206f619e6 /graphics/libqrencode
parent96f2e196c2b70cc5ed990a1e57d64e903864fdc8 (diff)
downloadports-4c3225c14cf2d596314e33a0b78752d2cc6501f8.tar.gz
ports-4c3225c14cf2d596314e33a0b78752d2cc6501f8.zip
add libqrencode 1.0.0
A C library for encoding data in a QR Code symbol
Notes
Notes: svn path=/head/; revision=179700
Diffstat (limited to 'graphics/libqrencode')
-rw-r--r--graphics/libqrencode/Makefile33
-rw-r--r--graphics/libqrencode/distinfo3
-rw-r--r--graphics/libqrencode/files/patch-use-ltmain.sh15
-rw-r--r--graphics/libqrencode/pkg-descr14
4 files changed, 65 insertions, 0 deletions
diff --git a/graphics/libqrencode/Makefile b/graphics/libqrencode/Makefile
new file mode 100644
index 000000000000..3c472f3e0581
--- /dev/null
+++ b/graphics/libqrencode/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# Ports collection makefile for: libqrencode
+# Date created: Dec 14, 2006
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= libqrencode
+PORTVERSION= 1.0.0
+CATEGORIES= graphics
+MASTER_SITES= http://megaui.net/fukuchi/works/qrencode/
+DISTNAME= qrencode-${PORTVERSION}
+
+MAINTAINER= ijliao@FreeBSD.org
+COMMENT= A C library for encoding data in a QR Code symbol
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+
+USE_SDL= sdl
+USE_GNOME= gnometarget gnomehack
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+CFLAGS+= -I${LOCALBASE}/include
+USE_LDCONFIG= yes
+
+PLIST_FILES= bin/qrencode \
+ include/qrencode.h \
+ lib/libqrencode.so \
+ lib/libqrencode.so.1 \
+ libdata/pkgconfig/libqrencode.pc
+
+.include <bsd.port.mk>
diff --git a/graphics/libqrencode/distinfo b/graphics/libqrencode/distinfo
new file mode 100644
index 000000000000..7ff6299a778f
--- /dev/null
+++ b/graphics/libqrencode/distinfo
@@ -0,0 +1,3 @@
+MD5 (qrencode-1.0.0.tar.gz) = edde6d0944164d7b0d95afbfd8413dcb
+SHA256 (qrencode-1.0.0.tar.gz) = 6a4173a89adecab2fc13d9bdf3d2ce954262d5463529538b96c96eabe9ef3c5a
+SIZE (qrencode-1.0.0.tar.gz) = 351520
diff --git a/graphics/libqrencode/files/patch-use-ltmain.sh b/graphics/libqrencode/files/patch-use-ltmain.sh
new file mode 100644
index 000000000000..2b9ddcece519
--- /dev/null
+++ b/graphics/libqrencode/files/patch-use-ltmain.sh
@@ -0,0 +1,15 @@
+--- use/ltmain.sh.orig Thu Dec 14 10:47:37 2006
++++ use/ltmain.sh Thu Dec 14 10:47:48 2006
+@@ -6003,10 +6003,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false ; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/graphics/libqrencode/pkg-descr b/graphics/libqrencode/pkg-descr
new file mode 100644
index 000000000000..c8fef0561b1b
--- /dev/null
+++ b/graphics/libqrencode/pkg-descr
@@ -0,0 +1,14 @@
+Libqrencode is a C library for encoding data in a QR Code symbol, a kind of
+2D symbology that can be scanned by handy terminals such as a mobile phone
+with CCD. The capacity of QR Code is up to 7000 digits or 4000 characters,
+and is highly robustness.
+
+Libqrencode supports QR Code model 2, described in JIS (Japanese Industrial
+Standards) X0510:2004 or ISO/IEC 18004. Currently the following features are
+not supported:
+ * ECI and FNC1 mode
+ * Structured Append Feature
+ * Micro QR Code
+ * QR Code model 1
+
+WWW: http://megaui.net/fukuchi/works/qrencode/index.en.html