aboutsummaryrefslogtreecommitdiff
path: root/graphics/libraw
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-01-26 21:20:03 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-01-26 21:20:03 +0000
commit7c72067efc12eee939fde286e322f31d479ce0f2 (patch)
tree87048797fcd1dbafb55834ec0957ef165ac7ac49 /graphics/libraw
parentda19de7cdd63939399c817e1b8ae7bbf84fa81f9 (diff)
downloadports-7c72067efc12eee939fde286e322f31d479ce0f2.tar.gz
ports-7c72067efc12eee939fde286e322f31d479ce0f2.zip
- Update libraw to 0.15.4.
This update is needed for further KDE updates. - Use the new OPTIONS syntax. - Use the new LIB_DEPENDS syntax. - Stop redefining do-install; the port has its own `make install' that does the same thing provided we use USES=pathfix and tune Makefile.in. - Support staging. Bump PORTREVISION in ports that depend on libraw. PR: ports/185118 Submitted by: rakuco@ Approved by: maintainer timeout (35 days)
Notes
Notes: svn path=/head/; revision=341289
Diffstat (limited to 'graphics/libraw')
-rw-r--r--graphics/libraw/Makefile95
-rw-r--r--graphics/libraw/distinfo12
-rw-r--r--graphics/libraw/files/patch-Makefile.in16
-rw-r--r--graphics/libraw/files/patch-configure41
-rw-r--r--graphics/libraw/pkg-plist6
5 files changed, 55 insertions, 115 deletions
diff --git a/graphics/libraw/Makefile b/graphics/libraw/Makefile
index a429ad84d308..051d2d01fa99 100644
--- a/graphics/libraw/Makefile
+++ b/graphics/libraw/Makefile
@@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= libraw
-PORTVERSION= 0.14.7
+PORTVERSION= 0.15.4
CATEGORIES= graphics
-MASTER_SITES= http://www.libraw.su/data/
+MASTER_SITES= http://www.libraw.org/data/
DISTNAME= LibRaw-${PORTVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
@@ -14,15 +14,16 @@ COMMENT= Library for manipulating raw images
LICENSE= LGPL21 CDDL
LICENSE_COMB= dual
-LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
USE_LDCONFIG= yes
-USES= pkgconfig
+USES= pathfix pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-examples --disable-jasper
CFLAGS+= -fPIC
-OPTIONS_DEFINE= DEMOSAIC_PACK_GPL2 DEMOSAIC_PACK_GPL3 LCMS2 OPTIMIZED_CFLAGS OPENMP
+OPTIONS_DEFINE= DEMOSAIC_PACK_GPL2 DEMOSAIC_PACK_GPL3 DOCS EXAMPLES LCMS2 \
+ OPTIMIZED_CFLAGS OPENMP
OPTIONS_DEFAULT= LCMS2
DEMOSAIC_PACK_GPL2_DESC= Enable GPLv2 demosaic pack
@@ -30,7 +31,17 @@ DEMOSAIC_PACK_GPL3_DESC= Enable GPLv3 demosaic pack
OPTIMIZED_CFLAGS_DESC= Enable optimizations (on x86)
OPENMP_DESC= Enable OpenMP (implies GCC 4.6+)
-NO_STAGE= yes
+DEMOSAIC_PACK_GPL2_CONFIGURE_OFF= --disable-demosaic-pack-gpl2
+DEMOSAIC_PACK_GPL2_CONFIGURE_ON= --enable-demosaic-pack-gpl2=../LibRaw-demosaic-pack-GPL2-${PORTVERSION}
+DEMOSAIC_PACK_GPL2_DISTFILES= LibRaw-demosaic-pack-GPL2-${PORTVERSION}.tar.gz
+DEMOSAIC_PACK_GPL3_CONFIGURE_OFF= --disable-demosaic-pack-gpl3
+DEMOSAIC_PACK_GPL3_CONFIGURE_ON= --enable-demosaic-pack-gpl3=../LibRaw-demosaic-pack-GPL3-${PORTVERSION}
+DEMOSAIC_PACK_GPL3_DISTFILES= LibRaw-demosaic-pack-GPL3-${PORTVERSION}.tar.gz
+LCMS2_CONFIGURE_ENABLE= lcms
+LCMS2_LIB_DEPENDS= liblcms2.so:${PORTSDIR}/graphics/lcms2
+OPENMP_CONFIGURE_ENABLE= openmp
+OPENMP_USE= GCC=yes
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
@@ -39,78 +50,30 @@ CFLAGS+= -O3
.endif
.endif
-.if ${PORT_OPTIONS:MOPENMP}
-USE_GCC= yes
-CONFIGURE_ARGS+=--enable-openmp
-.else
-CONFIGURE_ARGS+=--disable-openmp
-.endif
-
-.if ${PORT_OPTIONS:MLCMS2}
-LIB_DEPENDS+= lcms2.2:${PORTSDIR}/graphics/lcms2
-CONFIGURE_ARGS+=--enable-lcms
-.else
-CONFIGURE_ARGS+=--disable-lcms
-.endif
-
.if ${PORT_OPTIONS:MDEMOSAIC_PACK_GPL2}
LICENSE= GPLv2
LICENSE_COMB= single
-DISTFILES+= LibRaw-demosaic-pack-GPL2-${PORTVERSION}.tar.gz
-CONFIGURE_ARGS+=--enable-demosaic-pack-gpl2=../LibRaw-demosaic-pack-GPL2-${PORTVERSION}
-.else
-CONFIGURE_ARGS+=--disable-demosaic-pack-gpl2
.endif
.if ${PORT_OPTIONS:MDEMOSAIC_PACK_GPL3}
LICENSE= GPLv3
LICENSE_COMB= single
-DISTFILES+= LibRaw-demosaic-pack-GPL3-${PORTVERSION}.tar.gz
-CONFIGURE_ARGS+=--enable-demosaic-pack-gpl3=../LibRaw-demosaic-pack-GPL3-${PORTVERSION}
-.else
-CONFIGURE_ARGS+=--disable-demosaic-pack-gpl3
.endif
-PORTDOCS= API-C-eng.html API-C-rus.html API-CXX-eng.html \
- API-CXX-rus.html API-datastruct-eng.html \
- API-datastruct-rus.html API-notes-eng.html API-notes-rus.html \
- API-overview-eng.html API-overview-rus.html \
- Install-LibRaw-eng.html Install-LibRaw-rus.html \
- Samples-LibRaw-eng.html Samples-LibRaw-rus.html \
- Why-LibRaw-eng.html Why-LibRaw-rus.html \
- index-eng.html index-rus.html index.html
-
-PORTEXAMPLES= Makefile README-samples.rus 4channels.cpp dcraw_emu.cpp \
- dcraw_half.c half_mt.c mem_image.cpp \
- multirender_test.cpp postprocessing_benchmark.cpp \
- raw-identify.cpp simple_dcraw.cpp unprocessed_raw.cpp
-
-do-install:
- @${MKDIR} ${PREFIX}/include/libraw
-
-.for f in libraw.h libraw_alloc.h libraw_const.h libraw_datastream.h \
- libraw_internal.h libraw_types.h libraw_version.h
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}/${f} ${PREFIX}/include/libraw
-.endfor
-.for f in libraw.a libraw_r.a libraw.so.5 libraw_r.so.5
- ${INSTALL_DATA} ${WRKSRC}/lib/.libs/${f} ${PREFIX}/lib
-.endfor
-.for f in libraw libraw_r
- @cd ${PREFIX}/lib ; ${LN} -sf ${f}.so.5 ${f}.so
-.endfor
-
-.for f in libraw.pc libraw_r.pc
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/libdata/pkgconfig
-.endfor
-
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/doc/,} ${DOCSDIR}
+PORTDOCS= *
+PORTEXAMPLES= *
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/doc && \
+ ${COPYTREE_SHARE} \* ${STAGEDIR}${DOCSDIR}
.endif
-.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${PORTEXAMPLES:S,^,${WRKSRC}/samples/,} ${EXAMPLESDIR}
+.if ${PORT_OPTIONS:MEXAMPLES}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/samples && \
+ ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR}
.endif
post-patch:
diff --git a/graphics/libraw/distinfo b/graphics/libraw/distinfo
index 12d78e4038bf..b15dc50196e8 100644
--- a/graphics/libraw/distinfo
+++ b/graphics/libraw/distinfo
@@ -1,6 +1,6 @@
-SHA256 (LibRaw-0.14.7.tar.gz) = 7307a607249043bb544f3ab3b3a999e1923d72fbed12e4e2239d172e522143da
-SIZE (LibRaw-0.14.7.tar.gz) = 1366794
-SHA256 (LibRaw-demosaic-pack-GPL2-0.14.7.tar.gz) = 4f20cb3f085204159071c2bd965f294ad6be76308a27d7a60d23f7447449cae2
-SIZE (LibRaw-demosaic-pack-GPL2-0.14.7.tar.gz) = 31765
-SHA256 (LibRaw-demosaic-pack-GPL3-0.14.7.tar.gz) = 5fe67a89849f031c4dda96442acbf7dbed036c04662c9180ad8cafb045f8c891
-SIZE (LibRaw-demosaic-pack-GPL3-0.14.7.tar.gz) = 37439
+SHA256 (LibRaw-0.15.4.tar.gz) = 8d3a164674acfe6ff7164ab60397242c6e3144912fda7fa792c250c280e70746
+SIZE (LibRaw-0.15.4.tar.gz) = 1439235
+SHA256 (LibRaw-demosaic-pack-GPL2-0.15.4.tar.gz) = 5413e1e3283f356142b8a88492ace3c80e5c6837074c04109186f58e81837609
+SIZE (LibRaw-demosaic-pack-GPL2-0.15.4.tar.gz) = 31118
+SHA256 (LibRaw-demosaic-pack-GPL3-0.15.4.tar.gz) = be2440dabb7df46aa22de10b96d5e3cc7b2eb006ae491e7598611f11aba4dfe0
+SIZE (LibRaw-demosaic-pack-GPL3-0.15.4.tar.gz) = 38186
diff --git a/graphics/libraw/files/patch-Makefile.in b/graphics/libraw/files/patch-Makefile.in
new file mode 100644
index 000000000000..9c10d81c15f8
--- /dev/null
+++ b/graphics/libraw/files/patch-Makefile.in
@@ -0,0 +1,16 @@
+--- Makefile.in.orig 2013-12-23 02:36:04.000000000 +0200
++++ Makefile.in 2013-12-23 02:36:23.000000000 +0200
+@@ -462,12 +462,7 @@
+
+
+ # Docs
+-doc_DATA = COPYRIGHT \
+- LICENSE.CDDL \
+- LICENSE.LGPL \
+- LICENSE.LibRaw.pdf \
+- Changelog.txt
+-
++doc_DATA =
+
+ # pkg-config .pc files
+ pkgconfigdir = $(libdir)/pkgconfig
diff --git a/graphics/libraw/files/patch-configure b/graphics/libraw/files/patch-configure
index dd5639056ae2..5781f77f33c8 100644
--- a/graphics/libraw/files/patch-configure
+++ b/graphics/libraw/files/patch-configure
@@ -9,44 +9,3 @@
do
# Extract the first word of "$ac_prog", so it can be a program name with args.
set dummy $ac_prog; ac_word=$2
-@@ -4129,42 +4129,6 @@
-
-
-
--pkg_failed=no
--{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for LCMS" >&5
--$as_echo_n "checking for LCMS... " >&6; }
--
--if test -n "$LCMS_CFLAGS"; then
-- pkg_cv_LCMS_CFLAGS="$LCMS_CFLAGS"
-- elif test -n "$PKG_CONFIG"; then
-- if test -n "$PKG_CONFIG" && \
-- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"lcms\""; } >&5
-- ($PKG_CONFIG --exists --print-errors "lcms") 2>&5
-- ac_status=$?
-- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
-- test $ac_status = 0; }; then
-- pkg_cv_LCMS_CFLAGS=`$PKG_CONFIG --cflags "lcms" 2>/dev/null`
--else
-- pkg_failed=yes
--fi
-- else
-- pkg_failed=untried
--fi
--if test -n "$LCMS_LIBS"; then
-- pkg_cv_LCMS_LIBS="$LCMS_LIBS"
-- elif test -n "$PKG_CONFIG"; then
-- if test -n "$PKG_CONFIG" && \
-- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"lcms\""; } >&5
-- ($PKG_CONFIG --exists --print-errors "lcms") 2>&5
-- ac_status=$?
-- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
-- test $ac_status = 0; }; then
-- pkg_cv_LCMS_LIBS=`$PKG_CONFIG --libs "lcms" 2>/dev/null`
--else
-- pkg_failed=yes
--fi
-- else
-- pkg_failed=untried
--fi
-
diff --git a/graphics/libraw/pkg-plist b/graphics/libraw/pkg-plist
index 14e430a4bbe9..8280653682fb 100644
--- a/graphics/libraw/pkg-plist
+++ b/graphics/libraw/pkg-plist
@@ -6,11 +6,13 @@ include/libraw/libraw_internal.h
include/libraw/libraw_types.h
include/libraw/libraw_version.h
lib/libraw.a
+lib/libraw.la
lib/libraw.so
-lib/libraw.so.5
+lib/libraw.so.9
lib/libraw_r.a
+lib/libraw_r.la
lib/libraw_r.so
-lib/libraw_r.so.5
+lib/libraw_r.so.9
libdata/pkgconfig/libraw.pc
libdata/pkgconfig/libraw_r.pc
@dirrm include/libraw