aboutsummaryrefslogtreecommitdiff
path: root/graphics/libraw
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2012-05-29 22:53:29 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2012-05-29 22:53:29 +0000
commitc7e99f44daa6748bf6974fdd71ffca58c122a1e8 (patch)
tree6d5bdffd66157d1c802605499801c761eb1a7815 /graphics/libraw
parentfa28dc947699d2df09a8a5ef0a38565be18a9d22 (diff)
downloadports-c7e99f44daa6748bf6974fdd71ffca58c122a1e8.tar.gz
ports-c7e99f44daa6748bf6974fdd71ffca58c122a1e8.zip
OptionsNGfy.
Notes
Notes: svn path=/head/; revision=297716
Diffstat (limited to 'graphics/libraw')
-rw-r--r--graphics/libraw/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/graphics/libraw/Makefile b/graphics/libraw/Makefile
index 580cf51c336a..55dd080dc468 100644
--- a/graphics/libraw/Makefile
+++ b/graphics/libraw/Makefile
@@ -26,27 +26,29 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-examples --disable-jasper
CFLAGS+= -fPIC
-OPTIONS= DEMOSAIC_PACK_GPL2 "Enable GPLv2 demosaic pack" off \
- DEMOSAIC_PACK_GPL3 "Enable GPLv3 demosaic pack" off \
- LCMS "Build with LCMS support" on \
- OPTIMIZED_CFLAGS "Enable optimizations (on x86)" off
+OPTIONS_DEFINE= DEMOSAIC_PACK_GPL2 DEMOSAIC_PACK_GPL3 LCMS2 OPTIMIZED_CFLAGS
+OPTIONS_DEFAULT= LCMS2
+
+DEMOSAIC_PACK_GPL2_DESC= Enable GPLv2 demosaic pack
+DEMOSAIC_PACK_GPL3_DESC= Enable GPLv3 demosaic pack
+OPTIMIZED_CFLAGS_DESC= "Enable optimizations (on x86)"
.include <bsd.port.options.mk>
-.if defined(WITH_OPTIMIZED_CFLAGS)
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
.if ${ARCH} == "i386"
CFLAGS+= -O3
.endif
.endif
-.if defined(WITH_LCMS)
+.if ${PORT_OPTIONS:MLCMS2}
LIB_DEPENDS+= lcms2.2:${PORTSDIR}/graphics/lcms2
CONFIGURE_ARGS+=--enable-lcms
.else
CONFIGURE_ARGS+=--disable-lcms
.endif
-.if defined(WITH_DEMOSAIC_PACK_GPL2)
+.if ${PORT_OPTIONS:MDEMOSAIC_PACK_GPL2}
LICENSE+= GPLv2
DISTFILES+= LibRaw-demosaic-pack-GPL2-${PORTVERSION}.tar.gz
CONFIGURE_ARGS+=--enable-demosaic-pack-gpl2=../LibRaw-demosaic-pack-GPL2-${PORTVERSION}
@@ -54,7 +56,7 @@ CONFIGURE_ARGS+=--enable-demosaic-pack-gpl2=../LibRaw-demosaic-pack-GPL2-${PORTV
CONFIGURE_ARGS+=--disable-demosaic-pack-gpl2
.endif
-.if defined(WITH_DEMOSAIC_PACK_GPL3)
+.if ${PORT_OPTIONS:MDEMOSAIC_PACK_GPL3)
LICENSE+= GPLv3
DISTFILES+= LibRaw-demosaic-pack-GPL3-${PORTVERSION}.tar.gz
CONFIGURE_ARGS+=--enable-demosaic-pack-gpl3=../LibRaw-demosaic-pack-GPL3-${PORTVERSION}