aboutsummaryrefslogtreecommitdiff
path: root/graphics/linux-c7-cairo
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2016-10-19 14:50:26 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2016-10-19 14:50:26 +0000
commit1675ff649cded4c85d65feb0f4c5cc87010242eb (patch)
tree3e3556f1e26a35be0250e7f749680b9fc30e9c6b /graphics/linux-c7-cairo
parent4fd1b570a8aec1244c7b8469c29c309a96a46804 (diff)
downloadports-1675ff649cded4c85d65feb0f4c5cc87010242eb.tar.gz
ports-1675ff649cded4c85d65feb0f4c5cc87010242eb.zip
Add Linux CentOS 7 infrastructure ports.
Mk/Uses/linux.mk changes: - Add support for architecture neutral (noarch) distfiles. - Add support for 64-bit only ports: set IGNORE on i386 and don't install 32-bit compat libraries on amd64. Submitted by: Piotr Kubaj <pkubaj@anongoth.pl> Differential Revision: https://reviews.freebsd.org/D7886
Notes
Notes: svn path=/head/; revision=424259
Diffstat (limited to 'graphics/linux-c7-cairo')
-rw-r--r--graphics/linux-c7-cairo/Makefile22
-rw-r--r--graphics/linux-c7-cairo/distinfo.i3865
-rw-r--r--graphics/linux-c7-cairo/distinfo.x86_647
-rw-r--r--graphics/linux-c7-cairo/pkg-descr15
-rw-r--r--graphics/linux-c7-cairo/pkg-plist.i3862
-rw-r--r--graphics/linux-c7-cairo/pkg-plist.x86_644
6 files changed, 55 insertions, 0 deletions
diff --git a/graphics/linux-c7-cairo/Makefile b/graphics/linux-c7-cairo/Makefile
new file mode 100644
index 000000000000..4762ce24fdc3
--- /dev/null
+++ b/graphics/linux-c7-cairo/Makefile
@@ -0,0 +1,22 @@
+# Created by: Piotr Kubaj <pkubaj@anongoth.pl>
+# $FreeBSD$
+
+PORTNAME= cairo
+PORTVERSION= 1.14.2
+CATEGORIES= graphics linux
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= Vector graphics library Cairo (Linux CentOS ${LINUX_DIST_VER})
+
+CONFLICTS= linux-f10-${PORTNAME}-[0-9]* linux-c6-${PORTNAME}-[0-9]*
+
+RPMVERSION= 1.el7
+USES= linux:c7
+USE_LDCONFIG= yes
+USE_LINUX= fontconfig pixman png xorglibs
+USE_LINUX_RPM= yes
+
+PORTDOCS= AUTHORS BIBLIOGRAPHY BUGS COPYING COPYING-LGPL-2.1 \
+ COPYING-MPL-1.1 NEWS README
+
+.include <bsd.port.mk>
diff --git a/graphics/linux-c7-cairo/distinfo.i386 b/graphics/linux-c7-cairo/distinfo.i386
new file mode 100644
index 000000000000..3b58c8e6f7c6
--- /dev/null
+++ b/graphics/linux-c7-cairo/distinfo.i386
@@ -0,0 +1,5 @@
+TIMESTAMP = 1473355866
+SHA256 (rpm/centos/7.2.1511/i386/cairo-1.14.2-1.el7.i686.rpm) = 5f50b93ddd90d42a3ac6ed23f9db59dfe6c269f49a05f225500e4f081abc1a46
+SIZE (rpm/centos/7.2.1511/i386/cairo-1.14.2-1.el7.i686.rpm) = 757648
+SHA256 (rpm/centos/7.2.1511/i386/cairo-1.14.2-1.el7.src.rpm) = b2d9ae1faae434bcddfcbe8424b864db1fd6b1538ef37147942cb9f4371f4214
+SIZE (rpm/centos/7.2.1511/i386/cairo-1.14.2-1.el7.src.rpm) = 35402204
diff --git a/graphics/linux-c7-cairo/distinfo.x86_64 b/graphics/linux-c7-cairo/distinfo.x86_64
new file mode 100644
index 000000000000..b87868cb7b78
--- /dev/null
+++ b/graphics/linux-c7-cairo/distinfo.x86_64
@@ -0,0 +1,7 @@
+TIMESTAMP = 1473674817
+SHA256 (rpm/centos/7.2.1511/x86_64/cairo-1.14.2-1.el7.i686.rpm) = 5f50b93ddd90d42a3ac6ed23f9db59dfe6c269f49a05f225500e4f081abc1a46
+SIZE (rpm/centos/7.2.1511/x86_64/cairo-1.14.2-1.el7.i686.rpm) = 757648
+SHA256 (rpm/centos/7.2.1511/x86_64/cairo-1.14.2-1.el7.x86_64.rpm) = 07085c61b8ae6bdffa9998479af91aa0296ee9b89dc372d95eda1017561b5c44
+SIZE (rpm/centos/7.2.1511/x86_64/cairo-1.14.2-1.el7.x86_64.rpm) = 727824
+SHA256 (rpm/centos/7.2.1511/x86_64/cairo-1.14.2-1.el7.src.rpm) = b2d9ae1faae434bcddfcbe8424b864db1fd6b1538ef37147942cb9f4371f4214
+SIZE (rpm/centos/7.2.1511/x86_64/cairo-1.14.2-1.el7.src.rpm) = 35402204
diff --git a/graphics/linux-c7-cairo/pkg-descr b/graphics/linux-c7-cairo/pkg-descr
new file mode 100644
index 000000000000..fca51bcc0c03
--- /dev/null
+++ b/graphics/linux-c7-cairo/pkg-descr
@@ -0,0 +1,15 @@
+This is a Linux binary port of Cairo.
+
+Cairo is a vector graphics library with cross-device output
+support. Currently supported output targets include the X Window
+System and in-memory image buffers. PostScript and PDF file output is
+planned. Cairo is designed to produce identical output on all output
+media while taking advantage of display hardware acceleration when
+available (eg. through the X Render Extension).
+
+Cairo provides a stateful user-level API with capabilities similar to
+the PDF 1.4 imaging model. Cairo provides operations including stroking
+and filling Bezier cubic splines, transforming and compositing translucent
+images, and antialiased text rendering.
+
+WWW: http://www.cairographics.org/
diff --git a/graphics/linux-c7-cairo/pkg-plist.i386 b/graphics/linux-c7-cairo/pkg-plist.i386
new file mode 100644
index 000000000000..d6f933497ab4
--- /dev/null
+++ b/graphics/linux-c7-cairo/pkg-plist.i386
@@ -0,0 +1,2 @@
+usr/lib/libcairo.so.2
+usr/lib/libcairo.so.2.11400.2
diff --git a/graphics/linux-c7-cairo/pkg-plist.x86_64 b/graphics/linux-c7-cairo/pkg-plist.x86_64
new file mode 100644
index 000000000000..86c736450587
--- /dev/null
+++ b/graphics/linux-c7-cairo/pkg-plist.x86_64
@@ -0,0 +1,4 @@
+usr/lib/libcairo.so.2
+usr/lib/libcairo.so.2.11400.2
+usr/lib64/libcairo.so.2
+usr/lib64/libcairo.so.2.11400.2