aboutsummaryrefslogtreecommitdiff
path: root/graphics/lximage-qt
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2016-11-23 19:57:19 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2016-11-23 19:57:19 +0000
commit308a95c010c1f71b68baf3f3518d036125373c17 (patch)
tree2e7e62699e80413858a81a2d090f6c675549f21b /graphics/lximage-qt
parentb1929cf851da2de59b09af710cb07f2a2cfd9883 (diff)
downloadports-308a95c010c1f71b68baf3f3518d036125373c17.tar.gz
ports-308a95c010c1f71b68baf3f3518d036125373c17.zip
Fix build (linker error) for FreeBSD >= 10
Notes
Notes: svn path=/head/; revision=426963
Diffstat (limited to 'graphics/lximage-qt')
-rw-r--r--graphics/lximage-qt/files/patch-src_CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/graphics/lximage-qt/files/patch-src_CMakeLists.txt b/graphics/lximage-qt/files/patch-src_CMakeLists.txt
new file mode 100644
index 000000000000..fe626b2f8044
--- /dev/null
+++ b/graphics/lximage-qt/files/patch-src_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- src/CMakeLists.txt.orig 2016-09-23 22:50:09 UTC
++++ src/CMakeLists.txt
+@@ -83,7 +83,7 @@ set(QT_LIBRARIES Qt5::Widgets Qt5::Core
+ target_link_libraries(lximage-qt
+ fm-qt
+ ${QT_LIBRARIES}
+- ${EXIF_LIBRARIES}
++ ${EXIF_LDFLAGS}
+ ${X11_LIBRARIES}
+ ${XFIXES_LIBRARIES}
+ )