aboutsummaryrefslogtreecommitdiff
path: root/graphics/magnum/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-02-18 22:19:31 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-02-18 22:19:31 +0000
commit642ed436da60c2899382d785bf0064debedbe59d (patch)
tree59b99efaa72211fb7327d0da6b7ca31749207d77 /graphics/magnum/Makefile
parent625c6df414bffb907bc239ecb124c957c30fcfe0 (diff)
downloadports-642ed436da60c2899382d785bf0064debedbe59d.tar.gz
ports-642ed436da60c2899382d785bf0064debedbe59d.zip
Notes
Diffstat (limited to 'graphics/magnum/Makefile')
-rw-r--r--graphics/magnum/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/graphics/magnum/Makefile b/graphics/magnum/Makefile
new file mode 100644
index 000000000000..9ed63c4a5814
--- /dev/null
+++ b/graphics/magnum/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= magnum
+DISTVERSIONPREFIX= v
+DISTVERSION= 2019.01
+CATEGORIES= graphics
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Lightweight, modular graphics middleware for games, data visualization
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libCorradeUtility.so:devel/corrade
+
+USES= cmake compiler:c++14-lang gl
+USE_GITHUB= yes
+GH_ACCOUNT= mosra
+GH_TUPLE= mosra:toolchains:a3e0aff:t/toolchains
+USE_GL= gl
+USE_LDCONFIG= yes
+
+CMAKE_ARGS= -DLIB_SUFFIX:STRING=""
+
+.include <bsd.port.mk>