aboutsummaryrefslogtreecommitdiff
path: root/graphics/mandelbulber
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2019-01-05 19:35:19 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2019-01-05 19:35:19 +0000
commit788dbc9ae07208bc8fedfd7a81ab3f59e7c671c1 (patch)
tree442116b65abbd4c3d79784be8870fb939b9b9506 /graphics/mandelbulber
parent5734c7e473914fabd4a9592ec7d59c278db9c19f (diff)
downloadports-788dbc9ae07208bc8fedfd7a81ab3f59e7c671c1.tar.gz
ports-788dbc9ae07208bc8fedfd7a81ab3f59e7c671c1.zip
- Update to 2.16
Notes
Notes: svn path=/head/; revision=489370
Diffstat (limited to 'graphics/mandelbulber')
-rw-r--r--graphics/mandelbulber/Makefile57
-rw-r--r--graphics/mandelbulber/distinfo5
-rw-r--r--graphics/mandelbulber/files/patch-makefiles-makefile11
-rw-r--r--graphics/mandelbulber/files/patch-makefiles-src-subdir.mk11
-rw-r--r--graphics/mandelbulber/files/patch-src-netrender.cpp10
-rw-r--r--graphics/mandelbulber/files/patch-src-netrender.hpp10
-rw-r--r--graphics/mandelbulber/files/patch-src_texture.cpp10
-rw-r--r--graphics/mandelbulber/files/patch-src_timeline.cpp10
-rw-r--r--graphics/mandelbulber/pkg-descr2
-rw-r--r--graphics/mandelbulber/pkg-plist3
10 files changed, 40 insertions, 89 deletions
diff --git a/graphics/mandelbulber/Makefile b/graphics/mandelbulber/Makefile
index 1bf5debafdeb..5ae18528ab9b 100644
--- a/graphics/mandelbulber/Makefile
+++ b/graphics/mandelbulber/Makefile
@@ -2,43 +2,52 @@
# $FreeBSD$
PORTNAME= mandelbulber
-DISTVERSION= 1.13-1
-PORTREVISION= 1
+PORTVERSION= 2.16
CATEGORIES= graphics
-MASTER_SITES= SF/${PORTNAME}
-DISTNAME= ${PORTNAME}${DISTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= 3D Mandelbrot fractal renderer
-LICENSE= GPLv3
-LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN= fails to build
+LIB_DEPENDS= libgsl.so:math/gsl \
+ libpng.so:graphics/png \
+ libtiff.so:graphics/tiff \
+ liblzo2.so:archivers/lzo2
-USES= desktop-file-utils gmake pkgconfig
-USE_GNOME= glib20 gtk20
-BUILD_WRKSRC= ${WRKSRC}/makefiles
-MAKEFILE= makefile
-CXXFLAGS+= -DSHARED_DIR=\\\"${DATADIR}\\\"
+USE_GITHUB= yes
+GH_ACCOUNT= buddhi1980
+GH_PROJECT= ${PORTNAME}2
-PLIST_FILES= bin/${PORTNAME} share/applications/${PORTNAME}.desktop
+USES= cmake gnome jpeg localbase:ldflags pkgconfig qt:5
+USE_QT= core widgets network gui multimedia testlib \
+ qmake_build buildtools_build uitools_build
+INSTALLS_ICONS= yes
-PORTDOCS= README NEWS
+CMAKE_SOURCE_PATH= ${WRKSRC}/mandelbulber2/cmake
+
+PORTDOCS= CONTRIBUTING.md README.md RESOURCES.md
PORTDATA= *
+DATADIR= ${PREFIX}/share/${PORTNAME}2
+
+OPTIONS_DEFINE= OPENCL OPENMP DOCS
+OPTIONS_EXCLUDE= OPENMP # not properly supported yet
+
+OPENCL_BUILD_DEPENDS= opencl>=0:devel/opencl
+
+OPENMP_LIB_DEPENDS= libomp.so:devel/openmp
-OPTIONS_DEFINE= DOCS
+post-patch-OPENMP-off:
+ @${REINPLACE_CMD} -e 's|-fopenmp||' \
+ ${CMAKE_SOURCE_PATH}/CMakeLists.txt
-post-patch:
- @${REINPLACE_CMD} -e 's|/usr/share/mandelbulber|${DATADIR}|' \
- ${WRKSRC}/${PORTNAME}.desktop
+post-patch-OPENCL-off:
+ @${REINPLACE_CMD} -e '/find_package.*OpenCL/ d' \
+ ${CMAKE_SOURCE_PATH}/CMakeLists.txt
-do-install:
- ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${STAGEDIR}${PREFIX}/share/applications/
- ${MKDIR} ${STAGEDIR}${DATADIR}
- cd ${WRKSRC}/usr/share && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
.endfor
diff --git a/graphics/mandelbulber/distinfo b/graphics/mandelbulber/distinfo
index 63c5249ff574..b3dd7ea78668 100644
--- a/graphics/mandelbulber/distinfo
+++ b/graphics/mandelbulber/distinfo
@@ -1,2 +1,3 @@
-SHA256 (mandelbulber1.13-1.tar.gz) = 97edc8b08fc229e68ea58fd835581274b783ff4211b4db87c81efbdef799bd92
-SIZE (mandelbulber1.13-1.tar.gz) = 1200010
+TIMESTAMP = 1545751082
+SHA256 (buddhi1980-mandelbulber2-2.16_GH0.tar.gz) = 1c7b78f4345a2c3527acbc54ac2cd17efd4b7d36cedcd1deb85603cb48c09d8b
+SIZE (buddhi1980-mandelbulber2-2.16_GH0.tar.gz) = 54566672
diff --git a/graphics/mandelbulber/files/patch-makefiles-makefile b/graphics/mandelbulber/files/patch-makefiles-makefile
deleted file mode 100644
index 4afc83c42f31..000000000000
--- a/graphics/mandelbulber/files/patch-makefiles-makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- makefiles/makefile.orig 2012-12-02 20:22:54.000000000 +0400
-+++ makefiles/makefile 2012-12-13 01:08:10.313933225 +0400
-@@ -44,7 +44,7 @@
- mandelbulber: $(OBJS) $(USER_OBJS)
- @echo 'Building target: $@'
- @echo 'Invoking: GCC C++ Linker'
-- g++ -o"mandelbulber" -L/usr/lib/x86_64-linux-gnu/ $(OBJS) $(USER_OBJS) $(LIBS)
-+ $(CXX) -o"mandelbulber" -L$(LOCALBASE)/lib $(OBJS) $(USER_OBJS) $(LIBS)
- @echo 'Finished building target: $@'
- @echo ' '
-
diff --git a/graphics/mandelbulber/files/patch-makefiles-src-subdir.mk b/graphics/mandelbulber/files/patch-makefiles-src-subdir.mk
deleted file mode 100644
index 93e30c4ff8a6..000000000000
--- a/graphics/mandelbulber/files/patch-makefiles-src-subdir.mk
+++ /dev/null
@@ -1,11 +0,0 @@
---- makefiles/src/subdir.mk.orig 2012-12-02 20:22:54.000000000 +0400
-+++ makefiles/src/subdir.mk 2012-12-13 01:07:24.472933242 +0400
-@@ -71,7 +71,7 @@
- src/%.o: ../src/%.cpp
- @echo 'Building file: $<'
- @echo 'Invoking: GCC C++ Compiler'
-- g++ -O2 -ffast-math -Wall -c -fmessage-length=0 `pkg-config --cflags gtk+-2.0 gthread-2.0;` -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" -o"$@" "$<"
-+ $(CXX) $(CXXFLAGS) -ffast-math -Wall -c -fmessage-length=0 `pkg-config --cflags gtk+-2.0 gthread-2.0;` -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" -o"$@" "$<"
- @echo 'Finished building: $<'
- @echo ' '
-
diff --git a/graphics/mandelbulber/files/patch-src-netrender.cpp b/graphics/mandelbulber/files/patch-src-netrender.cpp
deleted file mode 100644
index bce85f52b099..000000000000
--- a/graphics/mandelbulber/files/patch-src-netrender.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/netrender.cpp.orig 2012-12-02 20:22:54.000000000 +0400
-+++ src/netrender.cpp 2012-12-13 01:06:24.748933214 +0400
-@@ -7,6 +7,7 @@
-
- #include "netrender.hpp"
- #include <stdio.h>
-+#include <netinet/in.h>
- #ifndef WIN32
- #include <arpa/inet.h>
- #endif
diff --git a/graphics/mandelbulber/files/patch-src-netrender.hpp b/graphics/mandelbulber/files/patch-src-netrender.hpp
deleted file mode 100644
index 0e9e02391012..000000000000
--- a/graphics/mandelbulber/files/patch-src-netrender.hpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/netrender.hpp.orig 2012-12-02 20:22:54.000000000 +0400
-+++ src/netrender.hpp 2012-12-13 01:05:50.537932343 +0400
-@@ -19,6 +19,7 @@
- #include <winsock2.h>
- #define INET6_ADDRSTRLEN 46
- #else
-+ #include <arpa/inet.h>
- #include <sys/socket.h>
- #include <netdb.h>
- #endif
diff --git a/graphics/mandelbulber/files/patch-src_texture.cpp b/graphics/mandelbulber/files/patch-src_texture.cpp
deleted file mode 100644
index 913c75dd6ece..000000000000
--- a/graphics/mandelbulber/files/patch-src_texture.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/texture.cpp.orig 2012-12-02 16:22:54 UTC
-+++ src/texture.cpp
-@@ -4,6 +4,7 @@
- * Created on: 2010-02-07
- * Author: krzysztof
- */
-+#include <cstring>
- #include <stdio.h>
- #include "texture.hpp"
- #include "files.h"
diff --git a/graphics/mandelbulber/files/patch-src_timeline.cpp b/graphics/mandelbulber/files/patch-src_timeline.cpp
deleted file mode 100644
index ef90734d0cb6..000000000000
--- a/graphics/mandelbulber/files/patch-src_timeline.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/timeline.cpp.orig 2012-12-02 16:22:54 UTC
-+++ src/timeline.cpp
-@@ -6,6 +6,7 @@
- */
-
- #include <cstdlib>
-+#include <cstring>
-
- #include "timeline.hpp"
- #include "files.h"
diff --git a/graphics/mandelbulber/pkg-descr b/graphics/mandelbulber/pkg-descr
index e044c022ad43..d96d05206129 100644
--- a/graphics/mandelbulber/pkg-descr
+++ b/graphics/mandelbulber/pkg-descr
@@ -5,4 +5,4 @@ Menger Sponge, Quaternion, Trigonometric, Hypercomplex, and Iterated
Function Systems (IFS). All of these can be combined into infinite
variations with the ability to hybridize different formulas together.
-WWW: http://www.mandelbulber.com/
+WWW: https://mandelbulber.com/
diff --git a/graphics/mandelbulber/pkg-plist b/graphics/mandelbulber/pkg-plist
new file mode 100644
index 000000000000..92b46445aefb
--- /dev/null
+++ b/graphics/mandelbulber/pkg-plist
@@ -0,0 +1,3 @@
+bin/mandelbulber2
+share/applications/mandelbulber2.desktop
+share/icons/hicolor/256x256/apps/mandelbulber2.png