aboutsummaryrefslogtreecommitdiff
path: root/graphics/mandelbulber
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2020-11-16 16:46:02 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2020-11-16 16:46:02 +0000
commitdcafb73623cd0ba3d191ed3ff354198a73a55c29 (patch)
tree70d79103f391fa8a68e8e73f8b776a80fc5b43d3 /graphics/mandelbulber
parentf2489a91c0aa07710414c4cb98699d1662421764 (diff)
downloadports-dcafb73623cd0ba3d191ed3ff354198a73a55c29.tar.gz
ports-dcafb73623cd0ba3d191ed3ff354198a73a55c29.zip
- Update to 2.23
Notes
Notes: svn path=/head/; revision=555497
Diffstat (limited to 'graphics/mandelbulber')
-rw-r--r--graphics/mandelbulber/Makefile6
-rw-r--r--graphics/mandelbulber/distinfo6
-rw-r--r--graphics/mandelbulber/files/patch-mandelbulber2_src_radiance__hdr.cpp11
3 files changed, 19 insertions, 4 deletions
diff --git a/graphics/mandelbulber/Makefile b/graphics/mandelbulber/Makefile
index 7ca0fa470f37..2d4e54f0bebb 100644
--- a/graphics/mandelbulber/Makefile
+++ b/graphics/mandelbulber/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mandelbulber
-DISTVERSION= 2.22
+PORTVERSION= 2.23
CATEGORIES= graphics
MAINTAINER= amdmi3@FreeBSD.org
@@ -15,6 +15,7 @@ LIB_DEPENDS= libgsl.so:math/gsl \
libpng.so:graphics/png \
libtiff.so:graphics/tiff \
liblzo2.so:archivers/lzo2
+BUILD_DEPENDS= ${LOCALBASE}/include/stb/stb_image.h:devel/stb
USE_GITHUB= yes
GH_ACCOUNT= buddhi1980
@@ -37,6 +38,9 @@ OPTIONS_EXCLUDE= OPENMP # not properly supported yet
OPENCL_BUILD_DEPENDS= opencl>=0:devel/opencl
+post-extract:
+ @${RM} -rf ${WRKSRC}/mandelbulber2/third-party
+
post-patch-OPENMP-off:
@${REINPLACE_CMD} -e 's|-fopenmp||' \
${CMAKE_SOURCE_PATH}/CMakeLists.txt
diff --git a/graphics/mandelbulber/distinfo b/graphics/mandelbulber/distinfo
index e8b3ffc48078..8f8a05ab3a31 100644
--- a/graphics/mandelbulber/distinfo
+++ b/graphics/mandelbulber/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1594156159
-SHA256 (buddhi1980-mandelbulber2-2.22_GH0.tar.gz) = f545254bc2254f8b6d1719a60071094a05322010c7dc68ed33ab40bf1684a984
-SIZE (buddhi1980-mandelbulber2-2.22_GH0.tar.gz) = 85911088
+TIMESTAMP = 1603671800
+SHA256 (buddhi1980-mandelbulber2-2.23_GH0.tar.gz) = d48f16ccb183f777ae1ad744ff5a37058ea57f9d282f72147c73c041b6b3125c
+SIZE (buddhi1980-mandelbulber2-2.23_GH0.tar.gz) = 89977115
diff --git a/graphics/mandelbulber/files/patch-mandelbulber2_src_radiance__hdr.cpp b/graphics/mandelbulber/files/patch-mandelbulber2_src_radiance__hdr.cpp
new file mode 100644
index 000000000000..20a6a6f04059
--- /dev/null
+++ b/graphics/mandelbulber/files/patch-mandelbulber2_src_radiance__hdr.cpp
@@ -0,0 +1,11 @@
+--- mandelbulber2/src/radiance_hdr.cpp.orig 2020-09-28 17:07:46 UTC
++++ mandelbulber2/src/radiance_hdr.cpp
+@@ -40,7 +40,7 @@
+ // custom includes
+ #define STB_IMAGE_IMPLEMENTATION
+ #define STBI_ONLY_HDR
+-#include "third-party/stb/stb_image.h"
++#include <stb/stb_image.h>
+
+ cRadianceHDR::cRadianceHDR()
+ {