aboutsummaryrefslogtreecommitdiff
path: root/graphics/mapnik/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-21 20:56:00 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-21 20:56:00 +0000
commit884edfd13f1c4d6a99ac359f62fdd6dd716600d6 (patch)
tree59b8cd5037820e0357c4261ab37476099f736705 /graphics/mapnik/Makefile
parent35a76a162ef7bc8db7baf98f85c0edb9954308fa (diff)
Notes
Diffstat (limited to 'graphics/mapnik/Makefile')
-rw-r--r--graphics/mapnik/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/graphics/mapnik/Makefile b/graphics/mapnik/Makefile
new file mode 100644
index 000000000000..319ad0e4db7a
--- /dev/null
+++ b/graphics/mapnik/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: mapnik
+# Date created: Nov 10, 2008
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mapnik
+PORTVERSION= 0.5.1
+CATEGORIES= graphics geography
+MASTER_SITES= ${MASTER_SITE_BERLIOS}/${PORTNAME}/
+DISTNAME= mapnik_src-${PORTVERSION}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A Free Toolkit For Developing Mapping Applications
+
+LIB_DEPENDS= geos:${PORTSDIR}/graphics/geos \
+ proj:${PORTSDIR}/graphics/proj \
+ ltdl:${PORTSDIR}/devel/libltdl15 \
+ png:${PORTSDIR}/graphics/png \
+ tiff:${PORTSDIR}/graphics/tiff \
+ iconv:${PORTSDIR}/converters/libiconv
+BUILD_DEPENDS= ${LOCALBASE}/bin/freetype-config:${PORTSDIR}/print/freetype2 \
+ ${LOCALBASE}/include/boost/python.hpp:${PORTSDIR}/devel/boost-python
+
+NO_BUILD= yes
+USE_PYTHON= 2.4+
+USE_LDCONFIG= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} scons/scons.py install
+
+.include <bsd.port.post.mk>