aboutsummaryrefslogtreecommitdiff
path: root/graphics/mapnik
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2020-01-10 20:59:19 +0000
committerRene Ladan <rene@FreeBSD.org>2020-01-10 20:59:19 +0000
commit3fb72e318f7be626e4315a026032d644cbce5540 (patch)
tree2a596dd3fcd96be66f808d42941a229b7263d43e /graphics/mapnik
parente326d6ecabc7c690696221959746ed24f26c6420 (diff)
downloadports-3fb72e318f7be626e4315a026032d644cbce5540.tar.gz
ports-3fb72e318f7be626e4315a026032d644cbce5540.zip
Notes
Diffstat (limited to 'graphics/mapnik')
-rw-r--r--graphics/mapnik/Makefile111
-rw-r--r--graphics/mapnik/distinfo7
-rw-r--r--graphics/mapnik/files/patch-SConstruct13
-rw-r--r--graphics/mapnik/files/patch-boost-1.6962
-rw-r--r--graphics/mapnik/files/patch-icu5939
-rw-r--r--graphics/mapnik/pkg-descr15
-rw-r--r--graphics/mapnik/pkg-plist486
7 files changed, 0 insertions, 733 deletions
diff --git a/graphics/mapnik/Makefile b/graphics/mapnik/Makefile
deleted file mode 100644
index 149faf0663b4..000000000000
--- a/graphics/mapnik/Makefile
+++ /dev/null
@@ -1,111 +0,0 @@
-# Created by: Wen Heping <wenheping@gmail.com>
-# $FreeBSD$
-
-PORTNAME= mapnik
-PORTVERSION= 3.0.9
-DISTVERSIONPREFIX= v
-PORTREVISION= 30
-CATEGORIES= graphics geography
-MASTER_SITES= http://mapnik.s3.amazonaws.com/dist/v${PORTVERSION}/
-
-PATCH_SITES= https://github.com/mapnik/mapnik/commit/
-PATCHFILES= 1ddfe6c31548.patch:-p1
-PATCHFILES+= c067eb7eec32.patch:-p1
-
-MAINTAINER= littlesavage@rambler.ru
-COMMENT= Free Toolkit For Developing Mapping Applications
-
-LICENSE= LGPL21+
-LICENSE_FILE= ${WRKSRC}/COPYING
-
-BROKEN= fails to build with boost 1.70, see bug 237016
-DEPRECATED= Broken for more than 8 months
-EXPIRATION_DATE= 2020-01-10
-BROKEN_powerpc= fails to install: runs out of virtual memory
-
-LIB_DEPENDS= libicuuc.so:devel/icu \
- libboost_system.so:devel/boost-libs \
- libfreetype.so:print/freetype2 \
- libharfbuzz.so:print/harfbuzz
-
-USES= compiler:c++11-lib gnome pkgconfig python scons tar:bzip2
-USE_GNOME= libxml2
-USE_LDCONFIG= yes
-MAKE_ARGS= INPUT_PLUGINS="`${ECHO} ${INPUT_PLUGINS} | ${TR} ' ' ,`" \
- CUSTOM_CFLAGS="${CFLAGS}" CUSTOM_CXXFLAGS="${CXXFLAGS}" \
- CUSTOM_LDFLAGS="${LDFLAGS}"
-
-PORTDOCS= *
-
-INPUT_PLUGINS= csv raster shape geojson topojson
-
-OPTIONS_DEFINE= DOCS CAIRO JPEG PNG TIFF WEBP PROJ
-OPTIONS_DEFAULT=CAIRO GDAL OGR POSTGIS PGRASTER SQLITE3 JPEG PNG TIFF PROJ WEBP
-OPTIONS_GROUP= INPUT
-OPTIONS_GROUP_INPUT= GDAL OGR POSTGIS PGRASTER SQLITE3
-OPTIONS_SUB= yes
-
-INPUT_DESC= Input plugins
-GDAL_DESC= GDAL input plugin
-OGR_DESC= OGR input plugin
-POSTGIS_DESC= PostGIS input plugin
-PGRASTER_DESC= PGraster input plugin
-SQLITE3_DESC= SQLite input plugin
-
-PROJ_DESC= proj4 support
-
-CAIRO_DESC= Enable cairo rendering
-
-GDAL_VARS= INPUT_PLUGINS+=gdal
-GDAL_LIB_DEPENDS= libgdal.so:graphics/gdal
-OGR_VARS= INPUT_PLUGINS+=ogr
-OGR_LIB_DEPENDS= libgdal.so:graphics/gdal
-POSTGIS_VARS= INPUT_PLUGINS+=postgis
-POSTGIS_USES= pgsql
-PGRASTER_VARS= INPUT_PLUGINS+=pgraster
-PGRASTER_USES= pgsql
-SQLITE3_VARS= INPUT_PLUGINS+=sqlite
-SQLITE3_LIB_DEPENDS= libsqlite3.so:databases/sqlite3
-
-PNG_LIB_DEPENDS= libpng.so:graphics/png
-PNG_MAKE_ARGS_OFF= PNG=False
-JPEG_USES= jpeg
-JPEG_MAKE_ARGS_OFF= JPEG=False
-TIFF_LIB_DEPENDS= libtiff.so:graphics/tiff
-TIFF_MAKE_ARGS_OFF= TIFF=False
-WEBP_LIB_DEPENDS= libwebp.so:graphics/webp
-WEBP_MAKE_ARGS_OFF= WEBP=False
-PROJ_LIB_DEPENDS= libproj.so:graphics/proj
-PROJ_MAKE_ARGS_OFF= PROJ=False
-
-CAIRO_LIB_DEPENDS= libcairo.so:graphics/cairo
-CAIRO_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cairo>=1.8.2:graphics/py-cairo@${PY_FLAVOR}
-CAIRO_MAKE_ARGS_OFF= CAIRO=False
-
-pre-configure-SQLITE3-on:
- @if ! ${LOCALBASE}/bin/sqlite3 :memory: 'create virtual table foo using rtree(pkid, xmin, xmax, ymin, ymax)' > /dev/null 2>&1; then \
- ${ECHO_MSG} "" ; \
- ${ECHO_MSG} "The SQLite plugin requires libsqlite3 built with RTREE support"; \
- ${ECHO_MSG} "Please, reinstall 'databases/sqlite3' port with R*Tree module enabled"; \
- ${ECHO_MSG} "" ; \
- ${FALSE} ; \
- fi
-
-post-patch:
- @${REINPLACE_CMD} -e 's#/usr/local#${LOCALBASE}#g' \
- -e 's#/usr/include#${LOCALBASE}/include#g' \
- ${WRKSRC}/SConstruct
-
-post-install:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/mapnik-index \
- ${STAGEDIR}${PREFIX}/bin/mapnik-render \
- ${STAGEDIR}${PREFIX}/bin/shapeindex
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/*.so
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/mapnik/input/*.input
-
-post-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- @cd ${WRKSRC} && ${COPYTREE_SHARE} "AUTHORS.md CHANGELOG.md README.md docs" \
- ${STAGEDIR}${DOCSDIR}
-
-.include <bsd.port.mk>
diff --git a/graphics/mapnik/distinfo b/graphics/mapnik/distinfo
deleted file mode 100644
index 5b7dcd0de148..000000000000
--- a/graphics/mapnik/distinfo
+++ /dev/null
@@ -1,7 +0,0 @@
-TIMESTAMP = 1448548335
-SHA256 (mapnik-v3.0.9.tar.bz2) = 3a3f67532b05f8a527a5bab32effd7dd5aa59165c7e24505268f6d827955d3da
-SIZE (mapnik-v3.0.9.tar.bz2) = 75213927
-SHA256 (1ddfe6c31548.patch) = fab754996485dc607108a4fd69d0df82414928eb5a210b329a84f47e90da0c8a
-SIZE (1ddfe6c31548.patch) = 2148
-SHA256 (c067eb7eec32.patch) = ac00d86197bba3ea5d6f72d23ea336412effd29ce779cedd8acafbcc563b81dc
-SIZE (c067eb7eec32.patch) = 2405
diff --git a/graphics/mapnik/files/patch-SConstruct b/graphics/mapnik/files/patch-SConstruct
deleted file mode 100644
index 8ad4634ad5ca..000000000000
--- a/graphics/mapnik/files/patch-SConstruct
+++ /dev/null
@@ -1,13 +0,0 @@
---- SConstruct.orig 2016-02-15 15:52:54 UTC
-+++ SConstruct
-@@ -1789,10 +1789,6 @@ if not preconfigured:
-
- if env['DEBUG']:
- env.Append(CXXFLAGS = common_cxx_flags + '-O0')
-- else:
-- # TODO - add back -fvisibility-inlines-hidden
-- # https://github.com/mapnik/mapnik/issues/1863
-- env.Append(CXXFLAGS = common_cxx_flags + '-O%s' % (env['OPTIMIZATION']))
- if env['DEBUG_UNDEFINED']:
- env.Append(CXXFLAGS = '-fsanitize=undefined-trap -fsanitize-undefined-trap-on-error -ftrapv -fwrapv')
-
diff --git a/graphics/mapnik/files/patch-boost-1.69 b/graphics/mapnik/files/patch-boost-1.69
deleted file mode 100644
index 23d3ac35a2f7..000000000000
--- a/graphics/mapnik/files/patch-boost-1.69
+++ /dev/null
@@ -1,62 +0,0 @@
-https://github.com/mapnik/mapnik/issues/4000
-
---- deps/agg/src/agg_pixfmt_rgba.cpp.orig 2015-11-26 14:32:15 UTC
-+++ deps/agg/src/agg_pixfmt_rgba.cpp
-@@ -3,7 +3,12 @@
-
- #pragma GCC diagnostic push
- #include <mapnik/warning_ignore.hpp>
-+#include <boost/version.hpp>
-+#if BOOST_VERSION >= 106900
-+#include <boost/gil.hpp>
-+#else
- #include <boost/gil/gil_all.hpp>
-+#endif
- #include <boost/gil/extension/toolbox/hsv.hpp>
- #include <boost/gil/extension/toolbox/hsl.hpp>
- #pragma GCC diagnostic pop
---- deps/boost/gil/extension/toolbox/hsl.hpp.orig 2015-11-26 14:32:15 UTC
-+++ deps/boost/gil/extension/toolbox/hsl.hpp
-@@ -16,7 +16,12 @@
-
- #pragma GCC diagnostic push
- #include <mapnik/warning_ignore.hpp>
-+#include <boost/version.hpp>
-+#if BOOST_VERSION >= 106900
-+#include <boost/gil.hpp>
-+#else
- #include <boost/gil/gil_all.hpp>
-+#endif
- #pragma GCC diagnostic pop
-
- namespace boost { namespace gil {
---- deps/boost/gil/extension/toolbox/hsv.hpp.orig 2015-11-26 14:32:15 UTC
-+++ deps/boost/gil/extension/toolbox/hsv.hpp
-@@ -16,7 +16,12 @@
-
- #pragma GCC diagnostic push
- #include <mapnik/warning_ignore.hpp>
-+#include <boost/version.hpp>
-+#if BOOST_VERSION >= 106900
-+#include <boost/gil.hpp>
-+#else
- #include <boost/gil/gil_all.hpp>
-+#endif
- #pragma GCC diagnostic pop
-
- namespace boost { namespace gil {
---- include/mapnik/image_filter.hpp.orig 2015-11-26 14:32:15 UTC
-+++ include/mapnik/image_filter.hpp
-@@ -31,7 +31,12 @@
-
- #pragma GCC diagnostic push
- #include <mapnik/warning_ignore.hpp>
-+#include <boost/version.hpp>
-+#if BOOST_VERSION >= 106900
-+#include <boost/gil.hpp>
-+#else
- #include <boost/gil/gil_all.hpp>
-+#endif
- #pragma GCC diagnostic pop
-
- // agg
diff --git a/graphics/mapnik/files/patch-icu59 b/graphics/mapnik/files/patch-icu59
deleted file mode 100644
index 01bcdd6d76d0..000000000000
--- a/graphics/mapnik/files/patch-icu59
+++ /dev/null
@@ -1,39 +0,0 @@
-https://github.com/mapnik/mapnik/commit/9e58c890430d
-https://github.com/mapnik/mapnik/commit/093fcee6d1ba
-
---- include/mapnik/text/harfbuzz_shaper.hpp.orig 2015-11-26 14:32:15 UTC
-+++ include/mapnik/text/harfbuzz_shaper.hpp
-@@ -41,6 +41,7 @@
- #include <harfbuzz/hb-ft.h>
-
- // icu
-+#include <unicode/uvernum.h>
- #include <unicode/uscript.h>
-
- namespace mapnik
-@@ -55,7 +56,8 @@ static inline hb_script_t _icu_script_to_script(UScrip
- static inline const uint16_t * uchar_to_utf16(const UChar* src)
- {
- static_assert(sizeof(UChar) == sizeof(uint16_t),"UChar is eq size to uint16_t");
--#if defined(_MSC_VER)
-+#if defined(_MSC_VER) || (U_ICU_VERSION_MAJOR_NUM >= 59)
-+ // ^^ http://site.icu-project.org/download/59#TOC-ICU4C-char16_t1
- return reinterpret_cast<const uint16_t *>(src);
- #else
- return src;
---- include/mapnik/unicode.hpp.orig 2015-11-26 14:32:15 UTC
-+++ include/mapnik/unicode.hpp
-@@ -31,6 +31,13 @@
- // std
- #include <cstdint>
- #include <string>
-+// icu
-+#if (U_ICU_VERSION_MAJOR_NUM >= 59)
-+#pragma GCC diagnostic push
-+#include <mapnik/warning_ignore.hpp>
-+#include <unicode/unistr.h>
-+#pragma GCC diagnostic pop
-+#endif
-
- struct UConverter;
-
diff --git a/graphics/mapnik/pkg-descr b/graphics/mapnik/pkg-descr
deleted file mode 100644
index 499f9f4ead89..000000000000
--- a/graphics/mapnik/pkg-descr
+++ /dev/null
@@ -1,15 +0,0 @@
-Mapnik is a Free Toolkit for developing mapping applications. It's
-written in C++ and there are Python bindings to facilitate fast-paced
-agile development. It can comfortably be used for both desktop and web
-development, which was something wanted from the beginning.
-
-Mapnik is about making beautiful maps. It uses the AGG library and
-offers world class anti-aliasing rendering with subpixel accuracy for
-geographic data. It is written from scratch in modern C++ and doesn't
-suffer from design decisions made a decade ago. When it comes to
-handling common software tasks such as memory management, filesystem
-access, regular expressions, parsing and so on, Mapnik doesn't re-invent
-the wheel, but utilizes best of breed industry standard libraries from
-boost.org.
-
-WWW: http://www.mapnik.org/
diff --git a/graphics/mapnik/pkg-plist b/graphics/mapnik/pkg-plist
deleted file mode 100644
index 97d5c7f90745..000000000000
--- a/graphics/mapnik/pkg-plist
+++ /dev/null
@@ -1,486 +0,0 @@
-bin/mapnik-config
-bin/mapnik-index
-bin/mapnik-render
-bin/shapeindex
-include/mapnik/agg/agg_alpha_mask_u8.h
-include/mapnik/agg/agg_arc.h
-include/mapnik/agg/agg_array.h
-include/mapnik/agg/agg_arrowhead.h
-include/mapnik/agg/agg_basics.h
-include/mapnik/agg/agg_bezier_arc.h
-include/mapnik/agg/agg_bitset_iterator.h
-include/mapnik/agg/agg_blur.h
-include/mapnik/agg/agg_bounding_rect.h
-include/mapnik/agg/agg_bspline.h
-include/mapnik/agg/agg_clip_liang_barsky.h
-include/mapnik/agg/agg_color_gray.h
-include/mapnik/agg/agg_color_rgba.h
-include/mapnik/agg/agg_config.h
-include/mapnik/agg/agg_conv_adaptor_vcgen.h
-include/mapnik/agg/agg_conv_adaptor_vpgen.h
-include/mapnik/agg/agg_conv_bspline.h
-include/mapnik/agg/agg_conv_clip_polygon.h
-include/mapnik/agg/agg_conv_clip_polyline.h
-include/mapnik/agg/agg_conv_close_polygon.h
-include/mapnik/agg/agg_conv_concat.h
-include/mapnik/agg/agg_conv_contour.h
-include/mapnik/agg/agg_conv_curve.h
-include/mapnik/agg/agg_conv_dash.h
-include/mapnik/agg/agg_conv_gpc.h
-include/mapnik/agg/agg_conv_marker.h
-include/mapnik/agg/agg_conv_marker_adaptor.h
-include/mapnik/agg/agg_conv_offset.h
-include/mapnik/agg/agg_conv_segmentator.h
-include/mapnik/agg/agg_conv_shorten_path.h
-include/mapnik/agg/agg_conv_smooth_poly1.h
-include/mapnik/agg/agg_conv_stroke.h
-include/mapnik/agg/agg_conv_transform.h
-include/mapnik/agg/agg_conv_unclose_polygon.h
-include/mapnik/agg/agg_curves.h
-include/mapnik/agg/agg_dda_line.h
-include/mapnik/agg/agg_ellipse.h
-include/mapnik/agg/agg_ellipse_bresenham.h
-include/mapnik/agg/agg_embedded_raster_fonts.h
-include/mapnik/agg/agg_font_cache_manager.h
-include/mapnik/agg/agg_gamma_functions.h
-include/mapnik/agg/agg_gamma_lut.h
-include/mapnik/agg/agg_glyph_raster_bin.h
-include/mapnik/agg/agg_gradient_lut.h
-include/mapnik/agg/agg_gsv_text.h
-include/mapnik/agg/agg_image_accessors.h
-include/mapnik/agg/agg_image_filters.h
-include/mapnik/agg/agg_line_aa_basics.h
-include/mapnik/agg/agg_math.h
-include/mapnik/agg/agg_math_stroke.h
-include/mapnik/agg/agg_path_length.h
-include/mapnik/agg/agg_path_storage.h
-include/mapnik/agg/agg_path_storage_integer.h
-include/mapnik/agg/agg_pattern_filters_rgba.h
-include/mapnik/agg/agg_pixfmt_amask_adaptor.h
-include/mapnik/agg/agg_pixfmt_base.h
-include/mapnik/agg/agg_pixfmt_gray.h
-include/mapnik/agg/agg_pixfmt_rgb.h
-include/mapnik/agg/agg_pixfmt_rgb_packed.h
-include/mapnik/agg/agg_pixfmt_rgba.h
-include/mapnik/agg/agg_pixfmt_transposer.h
-include/mapnik/agg/agg_rasterizer_cells_aa.h
-include/mapnik/agg/agg_rasterizer_compound_aa.h
-include/mapnik/agg/agg_rasterizer_outline.h
-include/mapnik/agg/agg_rasterizer_outline_aa.h
-include/mapnik/agg/agg_rasterizer_scanline_aa.h
-include/mapnik/agg/agg_rasterizer_sl_clip.h
-include/mapnik/agg/agg_renderer_base.h
-include/mapnik/agg/agg_renderer_markers.h
-include/mapnik/agg/agg_renderer_mclip.h
-include/mapnik/agg/agg_renderer_outline_aa.h
-include/mapnik/agg/agg_renderer_outline_image.h
-include/mapnik/agg/agg_renderer_primitives.h
-include/mapnik/agg/agg_renderer_raster_text.h
-include/mapnik/agg/agg_renderer_scanline.h
-include/mapnik/agg/agg_rendering_buffer.h
-include/mapnik/agg/agg_rendering_buffer_dynarow.h
-include/mapnik/agg/agg_rounded_rect.h
-include/mapnik/agg/agg_scanline_bin.h
-include/mapnik/agg/agg_scanline_boolean_algebra.h
-include/mapnik/agg/agg_scanline_p.h
-include/mapnik/agg/agg_scanline_storage_aa.h
-include/mapnik/agg/agg_scanline_storage_bin.h
-include/mapnik/agg/agg_scanline_u.h
-include/mapnik/agg/agg_shorten_path.h
-include/mapnik/agg/agg_simul_eq.h
-include/mapnik/agg/agg_span_allocator.h
-include/mapnik/agg/agg_span_converter.h
-include/mapnik/agg/agg_span_gouraud.h
-include/mapnik/agg/agg_span_gouraud_gray.h
-include/mapnik/agg/agg_span_gouraud_rgba.h
-include/mapnik/agg/agg_span_gradient.h
-include/mapnik/agg/agg_span_gradient_alpha.h
-include/mapnik/agg/agg_span_image_filter.h
-include/mapnik/agg/agg_span_image_filter_gray.h
-include/mapnik/agg/agg_span_image_filter_rgb.h
-include/mapnik/agg/agg_span_image_filter_rgba.h
-include/mapnik/agg/agg_span_interpolator_adaptor.h
-include/mapnik/agg/agg_span_interpolator_linear.h
-include/mapnik/agg/agg_span_interpolator_persp.h
-include/mapnik/agg/agg_span_interpolator_trans.h
-include/mapnik/agg/agg_span_pattern_gray.h
-include/mapnik/agg/agg_span_pattern_rgb.h
-include/mapnik/agg/agg_span_pattern_rgba.h
-include/mapnik/agg/agg_span_solid.h
-include/mapnik/agg/agg_span_subdiv_adaptor.h
-include/mapnik/agg/agg_trans_affine.h
-include/mapnik/agg/agg_trans_bilinear.h
-include/mapnik/agg/agg_trans_double_path.h
-include/mapnik/agg/agg_trans_lens.h
-include/mapnik/agg/agg_trans_perspective.h
-include/mapnik/agg/agg_trans_single_path.h
-include/mapnik/agg/agg_trans_viewport.h
-include/mapnik/agg/agg_trans_warp_magnifier.h
-include/mapnik/agg/agg_vcgen_bspline.h
-include/mapnik/agg/agg_vcgen_contour.h
-include/mapnik/agg/agg_vcgen_dash.h
-include/mapnik/agg/agg_vcgen_markers_term.h
-include/mapnik/agg/agg_vcgen_smooth_poly1.h
-include/mapnik/agg/agg_vcgen_stroke.h
-include/mapnik/agg/agg_vcgen_vertex_sequence.h
-include/mapnik/agg/agg_vertex_sequence.h
-include/mapnik/agg/agg_vpgen_clip_polygon.h
-include/mapnik/agg/agg_vpgen_clip_polyline.h
-include/mapnik/agg/agg_vpgen_segmentator.h
-include/mapnik/agg_helpers.hpp
-include/mapnik/agg_pattern_source.hpp
-include/mapnik/agg_rasterizer.hpp
-include/mapnik/agg_render_marker.hpp
-include/mapnik/agg_renderer.hpp
-include/mapnik/attribute.hpp
-include/mapnik/attribute_collector.hpp
-include/mapnik/attribute_descriptor.hpp
-include/mapnik/boolean.hpp
-include/mapnik/box2d.hpp
-include/mapnik/cairo/cairo_context.hpp
-include/mapnik/cairo/cairo_image_util.hpp
-include/mapnik/cairo/cairo_render_vector.hpp
-include/mapnik/cairo/cairo_renderer.hpp
-include/mapnik/cairo_io.hpp
-include/mapnik/color.hpp
-include/mapnik/color_factory.hpp
-include/mapnik/config.hpp
-include/mapnik/config_error.hpp
-include/mapnik/coord.hpp
-include/mapnik/css_color_grammar.hpp
-include/mapnik/css_color_grammar_impl.hpp
-include/mapnik/csv/csv_grammar.hpp
-include/mapnik/datasource.hpp
-include/mapnik/datasource_cache.hpp
-include/mapnik/datasource_geometry_type.hpp
-include/mapnik/debug.hpp
-include/mapnik/ellipsoid.hpp
-include/mapnik/enumeration.hpp
-include/mapnik/evaluate_global_attributes.hpp
-include/mapnik/expression.hpp
-include/mapnik/expression_evaluator.hpp
-include/mapnik/expression_grammar.hpp
-include/mapnik/expression_grammar_impl.hpp
-include/mapnik/expression_node.hpp
-include/mapnik/expression_node_types.hpp
-include/mapnik/expression_string.hpp
-include/mapnik/factory.hpp
-include/mapnik/feature.hpp
-include/mapnik/feature_factory.hpp
-include/mapnik/feature_kv_iterator.hpp
-include/mapnik/feature_layer_desc.hpp
-include/mapnik/feature_style_processor.hpp
-include/mapnik/feature_style_processor_context.hpp
-include/mapnik/feature_style_processor_impl.hpp
-include/mapnik/feature_type_style.hpp
-include/mapnik/featureset.hpp
-include/mapnik/filter_factory.hpp
-include/mapnik/filter_featureset.hpp
-include/mapnik/font_engine_freetype.hpp
-include/mapnik/font_set.hpp
-include/mapnik/function_call.hpp
-include/mapnik/geom_util.hpp
-include/mapnik/geometry.hpp
-include/mapnik/geometry_adapters.hpp
-include/mapnik/geometry_centroid.hpp
-include/mapnik/geometry_correct.hpp
-include/mapnik/geometry_envelope.hpp
-include/mapnik/geometry_envelope_impl.hpp
-include/mapnik/geometry_fusion_adapted.hpp
-include/mapnik/geometry_is_empty.hpp
-include/mapnik/geometry_is_simple.hpp
-include/mapnik/geometry_is_valid.hpp
-include/mapnik/geometry_remove_empty.hpp
-include/mapnik/geometry_reprojection.hpp
-include/mapnik/geometry_reprojection_impl.hpp
-include/mapnik/geometry_strategy.hpp
-include/mapnik/geometry_to_path.hpp
-include/mapnik/geometry_transform.hpp
-include/mapnik/geometry_type.hpp
-include/mapnik/geometry_types.hpp
-include/mapnik/geometry_unique.hpp
-include/mapnik/global.hpp
-include/mapnik/gradient.hpp
-include/mapnik/grid/grid.hpp
-include/mapnik/grid/grid_pixel.hpp
-include/mapnik/grid/grid_pixfmt.hpp
-include/mapnik/grid/grid_rasterizer.hpp
-include/mapnik/grid/grid_render_marker.hpp
-include/mapnik/grid/grid_renderer.hpp
-include/mapnik/grid/grid_renderer_base.hpp
-include/mapnik/grid/grid_rendering_buffer.hpp
-include/mapnik/grid/grid_view.hpp
-include/mapnik/group/group_layout.hpp
-include/mapnik/group/group_layout_manager.hpp
-include/mapnik/group/group_rule.hpp
-include/mapnik/group/group_symbolizer_helper.hpp
-include/mapnik/group/group_symbolizer_properties.hpp
-include/mapnik/hextree.hpp
-include/mapnik/hit_test_filter.hpp
-include/mapnik/image.hpp
-include/mapnik/image_any.hpp
-include/mapnik/image_compositing.hpp
-include/mapnik/image_copy.hpp
-include/mapnik/image_filter.hpp
-include/mapnik/image_filter_grammar.hpp
-include/mapnik/image_filter_grammar_impl.hpp
-include/mapnik/image_filter_types.hpp
-include/mapnik/image_impl.hpp
-include/mapnik/image_null.hpp
-include/mapnik/image_options.hpp
-include/mapnik/image_reader.hpp
-include/mapnik/image_scaling.hpp
-include/mapnik/image_scaling_traits.hpp
-include/mapnik/image_util.hpp
-include/mapnik/image_util_jpeg.hpp
-include/mapnik/image_util_png.hpp
-include/mapnik/image_util_tiff.hpp
-include/mapnik/image_util_webp.hpp
-include/mapnik/image_view.hpp
-include/mapnik/image_view_any.hpp
-include/mapnik/image_view_impl.hpp
-include/mapnik/image_view_null.hpp
-include/mapnik/jpeg_io.hpp
-include/mapnik/json/error_handler.hpp
-include/mapnik/json/extract_bounding_box_grammar.hpp
-include/mapnik/json/extract_bounding_box_grammar_impl.hpp
-include/mapnik/json/feature_collection_grammar.hpp
-include/mapnik/json/feature_collection_grammar_impl.hpp
-include/mapnik/json/feature_generator.hpp
-include/mapnik/json/feature_generator_grammar.hpp
-include/mapnik/json/feature_generator_grammar_impl.hpp
-include/mapnik/json/feature_grammar.hpp
-include/mapnik/json/feature_grammar_impl.hpp
-include/mapnik/json/feature_parser.hpp
-include/mapnik/json/generic_json.hpp
-include/mapnik/json/geometry_generator_grammar.hpp
-include/mapnik/json/geometry_generator_grammar_impl.hpp
-include/mapnik/json/geometry_grammar.hpp
-include/mapnik/json/geometry_grammar_impl.hpp
-include/mapnik/json/geometry_parser.hpp
-include/mapnik/json/geometry_util.hpp
-include/mapnik/json/positions_grammar.hpp
-include/mapnik/json/positions_grammar_impl.hpp
-include/mapnik/json/properties_generator_grammar.hpp
-include/mapnik/json/properties_generator_grammar_impl.hpp
-include/mapnik/json/symbolizer_grammar.hpp
-include/mapnik/json/topojson_grammar.hpp
-include/mapnik/json/topojson_grammar_impl.hpp
-include/mapnik/json/topojson_utils.hpp
-include/mapnik/json/topology.hpp
-include/mapnik/json/value_converters.hpp
-include/mapnik/label_collision_detector.hpp
-include/mapnik/layer.hpp
-include/mapnik/load_map.hpp
-include/mapnik/make_unique.hpp
-include/mapnik/map.hpp
-include/mapnik/mapped_memory_cache.hpp
-include/mapnik/marker.hpp
-include/mapnik/marker_cache.hpp
-include/mapnik/marker_helpers.hpp
-include/mapnik/markers_placement.hpp
-include/mapnik/markers_placements/interior.hpp
-include/mapnik/markers_placements/line.hpp
-include/mapnik/markers_placements/point.hpp
-include/mapnik/markers_placements/vertext_first.hpp
-include/mapnik/markers_placements/vertext_last.hpp
-include/mapnik/memory_datasource.hpp
-include/mapnik/memory_featureset.hpp
-include/mapnik/miniz_png.hpp
-include/mapnik/octree.hpp
-include/mapnik/offset_converter.hpp
-include/mapnik/palette.hpp
-include/mapnik/params.hpp
-include/mapnik/params_impl.hpp
-include/mapnik/parse_path.hpp
-include/mapnik/parse_transform.hpp
-include/mapnik/path.hpp
-include/mapnik/path_expression.hpp
-include/mapnik/path_expression_grammar.hpp
-include/mapnik/path_expression_grammar_impl.hpp
-include/mapnik/pixel_position.hpp
-include/mapnik/pixel_types.hpp
-include/mapnik/plugin.hpp
-include/mapnik/png_io.hpp
-include/mapnik/pool.hpp
-include/mapnik/proj_strategy.hpp
-include/mapnik/proj_transform.hpp
-include/mapnik/projection.hpp
-include/mapnik/ptree_helpers.hpp
-include/mapnik/quad_tree.hpp
-include/mapnik/query.hpp
-include/mapnik/raster.hpp
-include/mapnik/raster_colorizer.hpp
-include/mapnik/renderer_common.hpp
-include/mapnik/request.hpp
-include/mapnik/rule.hpp
-include/mapnik/rule_cache.hpp
-include/mapnik/safe_cast.hpp
-include/mapnik/save_map.hpp
-include/mapnik/scale_denominator.hpp
-include/mapnik/segment.hpp
-include/mapnik/simplify.hpp
-include/mapnik/simplify_converter.hpp
-include/mapnik/sparsehash/dense_hash_map
-include/mapnik/sparsehash/internal/densehashtable.h
-include/mapnik/sparsehash/internal/hashtable-common.h
-include/mapnik/sparsehash/internal/libc_allocator_with_realloc.h
-include/mapnik/sparsehash/internal/sparseconfig.h
-include/mapnik/sparsehash/template_util.h
-include/mapnik/sparsehash/type_traits.h
-include/mapnik/sql_utils.hpp
-include/mapnik/sse.hpp
-include/mapnik/svg/geometry_svg_generator.hpp
-include/mapnik/svg/geometry_svg_generator_impl.hpp
-include/mapnik/svg/svg_converter.hpp
-include/mapnik/svg/svg_parser.hpp
-include/mapnik/svg/svg_parser_exception.hpp
-include/mapnik/svg/svg_path_adapter.hpp
-include/mapnik/svg/svg_path_attributes.hpp
-include/mapnik/svg/svg_path_commands.hpp
-include/mapnik/svg/svg_path_grammar.hpp
-include/mapnik/svg/svg_path_parser.hpp
-include/mapnik/svg/svg_points_grammar.hpp
-include/mapnik/svg/svg_renderer_agg.hpp
-include/mapnik/svg/svg_storage.hpp
-include/mapnik/svg/svg_transform_grammar.hpp
-include/mapnik/symbolizer.hpp
-include/mapnik/symbolizer_base.hpp
-include/mapnik/symbolizer_default_values.hpp
-include/mapnik/symbolizer_dispatch.hpp
-include/mapnik/symbolizer_enumerations.hpp
-include/mapnik/symbolizer_hash.hpp
-include/mapnik/symbolizer_keys.hpp
-include/mapnik/symbolizer_utils.hpp
-include/mapnik/text/evaluated_format_properties_ptr.hpp
-include/mapnik/text/face.hpp
-include/mapnik/text/font_feature_settings.hpp
-include/mapnik/text/font_library.hpp
-include/mapnik/text/formatting/base.hpp
-include/mapnik/text/formatting/format.hpp
-include/mapnik/text/formatting/layout.hpp
-include/mapnik/text/formatting/list.hpp
-include/mapnik/text/formatting/registry.hpp
-include/mapnik/text/formatting/text.hpp
-include/mapnik/text/glyph_info.hpp
-include/mapnik/text/glyph_positions.hpp
-include/mapnik/text/harfbuzz_shaper.hpp
-include/mapnik/text/icu_shaper.hpp
-include/mapnik/text/itemizer.hpp
-include/mapnik/text/placement_finder.hpp
-include/mapnik/text/placement_finder_impl.hpp
-include/mapnik/text/placements/base.hpp
-include/mapnik/text/placements/dummy.hpp
-include/mapnik/text/placements/list.hpp
-include/mapnik/text/placements/registry.hpp
-include/mapnik/text/placements/simple.hpp
-include/mapnik/text/properties_util.hpp
-include/mapnik/text/renderer.hpp
-include/mapnik/text/rotation.hpp
-include/mapnik/text/scrptrun.hpp
-include/mapnik/text/symbolizer_helpers.hpp
-include/mapnik/text/text_layout.hpp
-include/mapnik/text/text_line.hpp
-include/mapnik/text/text_properties.hpp
-include/mapnik/tiff_io.hpp
-include/mapnik/timer.hpp
-include/mapnik/tolerance_iterator.hpp
-include/mapnik/transform_expression.hpp
-include/mapnik/transform_expression_grammar.hpp
-include/mapnik/transform_expression_grammar_impl.hpp
-include/mapnik/transform_path_adapter.hpp
-include/mapnik/transform_processor.hpp
-include/mapnik/unicode.hpp
-include/mapnik/util/const_rendering_buffer.hpp
-include/mapnik/util/container_adapter.hpp
-include/mapnik/util/conversions.hpp
-include/mapnik/util/dasharray_parser.hpp
-include/mapnik/util/feature_to_geojson.hpp
-include/mapnik/util/featureset_buffer.hpp
-include/mapnik/util/file_io.hpp
-include/mapnik/util/fs.hpp
-include/mapnik/util/geometry_to_ds_type.hpp
-include/mapnik/util/geometry_to_geojson.hpp
-include/mapnik/util/geometry_to_svg.hpp
-include/mapnik/util/geometry_to_wkb.hpp
-include/mapnik/util/geometry_to_wkt.hpp
-include/mapnik/util/hsl.hpp
-include/mapnik/util/is_clockwise.hpp
-include/mapnik/util/math.hpp
-include/mapnik/util/noncopyable.hpp
-include/mapnik/util/path_iterator.hpp
-include/mapnik/util/recursive_wrapper.hpp
-include/mapnik/util/rounding_cast.hpp
-include/mapnik/util/singleton.hpp
-include/mapnik/util/spatial_index.hpp
-include/mapnik/util/spirit_transform_attribute.hpp
-include/mapnik/util/timer.hpp
-include/mapnik/util/trim.hpp
-include/mapnik/util/utf_conv_win.hpp
-include/mapnik/util/variant.hpp
-include/mapnik/util/variant_io.hpp
-include/mapnik/value.hpp
-include/mapnik/value_error.hpp
-include/mapnik/value_hash.hpp
-include/mapnik/value_types.hpp
-include/mapnik/version.hpp
-include/mapnik/vertex.hpp
-include/mapnik/vertex_adapters.hpp
-include/mapnik/vertex_cache.hpp
-include/mapnik/vertex_converters.hpp
-include/mapnik/vertex_processor.hpp
-include/mapnik/vertex_vector.hpp
-include/mapnik/view_strategy.hpp
-include/mapnik/view_transform.hpp
-include/mapnik/warning_ignore.hpp
-include/mapnik/warp.hpp
-include/mapnik/webp_io.hpp
-include/mapnik/well_known_srs.hpp
-include/mapnik/wkb.hpp
-include/mapnik/wkt/wkt_factory.hpp
-include/mapnik/wkt/wkt_generator_grammar.hpp
-include/mapnik/wkt/wkt_generator_grammar_impl.hpp
-include/mapnik/wkt/wkt_grammar.hpp
-include/mapnik/wkt/wkt_grammar_impl.hpp
-include/mapnik/xml_attribute_cast.hpp
-include/mapnik/xml_loader.hpp
-include/mapnik/xml_node.hpp
-include/mapnik/xml_tree.hpp
-lib/libmapnik-json.a
-lib/libmapnik-wkt.a
-lib/libmapnik.so
-lib/libmapnik.so.3.0
-lib/libmapnik.so.3.0.9
-lib/mapnik/fonts/DejaVuSans-Bold.ttf
-lib/mapnik/fonts/DejaVuSans-BoldOblique.ttf
-lib/mapnik/fonts/DejaVuSans-ExtraLight.ttf
-lib/mapnik/fonts/DejaVuSans-Oblique.ttf
-lib/mapnik/fonts/DejaVuSans.ttf
-lib/mapnik/fonts/DejaVuSansCondensed-Bold.ttf
-lib/mapnik/fonts/DejaVuSansCondensed-BoldOblique.ttf
-lib/mapnik/fonts/DejaVuSansCondensed-Oblique.ttf
-lib/mapnik/fonts/DejaVuSansCondensed.ttf
-lib/mapnik/fonts/DejaVuSansMono-Bold.ttf
-lib/mapnik/fonts/DejaVuSansMono-BoldOblique.ttf
-lib/mapnik/fonts/DejaVuSansMono-Oblique.ttf
-lib/mapnik/fonts/DejaVuSansMono.ttf
-lib/mapnik/fonts/DejaVuSerif-Bold.ttf
-lib/mapnik/fonts/DejaVuSerif-BoldItalic.ttf
-lib/mapnik/fonts/DejaVuSerif-Italic.ttf
-lib/mapnik/fonts/DejaVuSerif.ttf
-lib/mapnik/fonts/DejaVuSerifCondensed-Bold.ttf
-lib/mapnik/fonts/DejaVuSerifCondensed-BoldItalic.ttf
-lib/mapnik/fonts/DejaVuSerifCondensed-Italic.ttf
-lib/mapnik/fonts/DejaVuSerifCondensed.ttf
-lib/mapnik/fonts/unifont-8.0.01.ttf
-@comment =====[ Uncomment these after boost 1.60 hits the tree ]=====
-@comment lib/mapnik/input/csv.input
-%%GDAL%%lib/mapnik/input/gdal.input
-@comment lib/mapnik/input/geojson.input
-%%OGR%%lib/mapnik/input/ogr.input
-%%PGRASTER%%lib/mapnik/input/pgraster.input
-%%POSTGIS%%lib/mapnik/input/postgis.input
-lib/mapnik/input/raster.input
-lib/mapnik/input/shape.input
-%%SQLITE3%%lib/mapnik/input/sqlite.input
-@comment lib/mapnik/input/topojson.input