aboutsummaryrefslogtreecommitdiff
path: root/graphics/mapnik
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
commit551be3c7231225ed9c26479af2b8914fb2ef0ea8 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /graphics/mapnik
parent02f9c9be1699251467efc027f210049dfe14f9c5 (diff)
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Notes
Notes: svn path=/head/; revision=455210
Diffstat (limited to 'graphics/mapnik')
-rw-r--r--graphics/mapnik/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/graphics/mapnik/Makefile b/graphics/mapnik/Makefile
index 53da6d2fa288..b2432b5413f3 100644
--- a/graphics/mapnik/Makefile
+++ b/graphics/mapnik/Makefile
@@ -73,7 +73,7 @@ PROJ_LIB_DEPENDS= libproj.so:graphics/proj
PROJ_MAKE_ARGS_OFF= PROJ=False
CAIRO_LIB_DEPENDS= libcairo.so:graphics/cairo
-CAIRO_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cairo>=1.8.2:graphics/py-cairo
+CAIRO_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cairo>=1.8.2:graphics/py-cairo@${PY_FLAVOR}
CAIRO_MAKE_ARGS_OFF= CAIRO=False
.include <bsd.port.pre.mk>