aboutsummaryrefslogtreecommitdiff
path: root/graphics/mapserver
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2017-12-20 19:34:11 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2017-12-20 19:34:11 +0000
commit2e9911f602efb133285d096c6955cad324328edb (patch)
treebac7657b7c809f134de666e3748eb52500cad676 /graphics/mapserver
parent0a89159f7aec94ccc7a0d529aac87c2ddccfa17c (diff)
downloadports-2e9911f602efb133285d096c6955cad324328edb.tar.gz
ports-2e9911f602efb133285d096c6955cad324328edb.zip
Switch from swig 2.0 to swig 3.0
Notes
Notes: svn path=/head/; revision=456845
Diffstat (limited to 'graphics/mapserver')
-rw-r--r--graphics/mapserver/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/graphics/mapserver/Makefile b/graphics/mapserver/Makefile
index e216c9edee31..e67b2f3bbbd0 100644
--- a/graphics/mapserver/Makefile
+++ b/graphics/mapserver/Makefile
@@ -44,7 +44,8 @@ WCS_DESC= WCS Server support
.if ${PORT_OPTIONS:MPYTHON}
USES+= python:2
-BUILD_DEPENDS+= swig2.0:devel/swig20
+BUILD_DEPENDS+= swig3.0:devel/swig30
+BINARY_ALIAS= swig=swig3.0
CMAKE_ARGS+= -DWITH_PYTHON=yes
PLIST_SUB+= PYTHON=""
MAP_EGG= MapScript-${PORTVERSION}-${PYTHON_VERSION:S/thon//}
@@ -137,9 +138,10 @@ PLIST_SUB+= PHP="@comment "
.if ${PORT_OPTIONS:MPERL}
USES+= perl5
-BUILD_DEPENDS= ${LOCALBASE}/bin/swig2.0:devel/swig20
+BUILD_DEPENDS= swig3.0:devel/swig30
CMAKE_ARGS+= -DWITH_PERL=1
PLIST_SUB+= PERL=""
+BINARY_ALIAS= swig=swig3.0
.else
CMAKE_ARGS+= -DWITH_PERL=0
PLIST_SUB+= PERL="@comment "