aboutsummaryrefslogtreecommitdiff
path: root/graphics/mesa-dri
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2019-10-30 19:07:32 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2019-10-30 19:07:32 +0000
commit0824125a0c2efc10f09a594df85774e1262cfce2 (patch)
treeeb8f37a1d48b00a46494ba907f60ac5ab4f39b5d /graphics/mesa-dri
parent7b907ca3e1c510a977535cf6a773692515d77879 (diff)
downloadports-0824125a0c2efc10f09a594df85774e1262cfce2.tar.gz
ports-0824125a0c2efc10f09a594df85774e1262cfce2.zip
graphics/mesa: Add -D_GNU_SOURCE to compile flags
Add -D_GNU_SOURCE to compile flags when building on FreeBSD. This is needed to have mesa work with various locales, that for instance use , instead of . as a decmal separator. Bump portrevision on all mesa related ports. PR: 241506 Reported by: Jesper Schmitz Mouridsen MFH: 2019Q4
Notes
Notes: svn path=/head/; revision=516100
Diffstat (limited to 'graphics/mesa-dri')
-rw-r--r--graphics/mesa-dri/Makefile2
-rw-r--r--graphics/mesa-dri/files/patch-configure25
2 files changed, 18 insertions, 9 deletions
diff --git a/graphics/mesa-dri/Makefile b/graphics/mesa-dri/Makefile
index a2f38e0400c1..8e4565b7227a 100644
--- a/graphics/mesa-dri/Makefile
+++ b/graphics/mesa-dri/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mesa-dri
PORTVERSION= ${MESAVERSION}
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= graphics
COMMENT= OpenGL hardware acceleration drivers for DRI2+
diff --git a/graphics/mesa-dri/files/patch-configure b/graphics/mesa-dri/files/patch-configure
index 7143b3263833..d4cb2ec4a765 100644
--- a/graphics/mesa-dri/files/patch-configure
+++ b/graphics/mesa-dri/files/patch-configure
@@ -1,6 +1,15 @@
---- configure.orig 2018-11-09 11:03:06 UTC
+--- configure.orig 2019-01-17 11:26:29 UTC
+++ configure
-@@ -22659,12 +22659,13 @@ case "$host_os" in
+@@ -20767,7 +20767,7 @@ case "$host_os" in
+ *-android*)
+ android=yes
+ ;;
+-linux*|*-gnu*|gnu*|cygwin*)
++linux*|*-gnu*|gnu*|cygwin*|freebsd*)
+ DEFINES="$DEFINES -D_GNU_SOURCE"
+ ;;
+ solaris*)
+@@ -22648,12 +22648,13 @@ case "$host_os" in
darwin*)
;;
*)
@@ -18,7 +27,7 @@
_ACEOF
CLOCK_LIB=
else
-@@ -23330,8 +23331,12 @@ $as_echo_n "checking whether pthread_setaffinity_np is
+@@ -23319,8 +23320,12 @@ $as_echo_n "checking whether pthread_setaffinity_np is
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
@@ -31,7 +40,7 @@
int main() {
void *a = (void*) &pthread_setaffinity_np;
long b = (long) a;
-@@ -23350,11 +23355,20 @@ rm -f core conftest.err conftest.$ac_objext \
+@@ -23339,11 +23344,20 @@ rm -f core conftest.err conftest.$ac_objext \
conftest$ac_exeext conftest.$ac_ext
LIBS="$save_LIBS"
@@ -55,7 +64,7 @@
# Check whether --enable-selinux was given.
-@@ -24252,7 +24266,7 @@ fi
+@@ -24241,7 +24255,7 @@ fi
case "$host_os" in
@@ -64,7 +73,7 @@
dri3_default=yes
;;
*)
-@@ -26640,31 +26654,11 @@ fi
+@@ -26542,31 +26556,11 @@ fi
# Put the nasty error message in config.log where it belongs
echo "$XCB_RANDR_PKG_ERRORS" >&5
@@ -98,7 +107,7 @@
else
XCB_RANDR_CFLAGS=$pkg_cv_XCB_RANDR_CFLAGS
XCB_RANDR_LIBS=$pkg_cv_XCB_RANDR_LIBS
-@@ -26732,31 +26726,11 @@ fi
+@@ -26634,31 +26628,11 @@ fi
# Put the nasty error message in config.log where it belongs
echo "$XLIB_RANDR_PKG_ERRORS" >&5
@@ -132,7 +141,7 @@
else
XLIB_RANDR_CFLAGS=$pkg_cv_XLIB_RANDR_CFLAGS
XLIB_RANDR_LIBS=$pkg_cv_XLIB_RANDR_LIBS
-@@ -28792,9 +28766,6 @@ rm -f core conftest.err conftest.$ac_objext conftest.$
+@@ -28694,9 +28668,6 @@ rm -f core conftest.err conftest.$ac_objext conftest.$
CLANG_LIBDIR=${LLVM_LIBDIR}
fi
CLANG_RESOURCE_DIR=$CLANG_LIBDIR/clang/${LLVM_VERSION}