aboutsummaryrefslogtreecommitdiff
path: root/graphics/mesa-dri
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-11-27 00:23:11 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-11-27 00:23:11 +0000
commit99ed1a64da88b955b30b53207f4441087b1c5aa0 (patch)
tree3e0578db57730db7f0e7f1b9deb2ac2e0b769306 /graphics/mesa-dri
parentc71e67139741942468176397b9a21abff1bf543f (diff)
downloadports-99ed1a64da88b955b30b53207f4441087b1c5aa0.tar.gz
ports-99ed1a64da88b955b30b53207f4441087b1c5aa0.zip
graphics/mesa-dri: make powerpc64 use LLVM10
LLVM90 requirement was introduced when Mesa used LLVM80 and 90 gave much better experience on powerpc64. Now that everyone moved to 10, make a move on powerpc64 as well.
Notes
Notes: svn path=/head/; revision=556423
Diffstat (limited to 'graphics/mesa-dri')
-rw-r--r--graphics/mesa-dri/Makefile2
-rw-r--r--graphics/mesa-dri/Makefile.common8
2 files changed, 1 insertions, 9 deletions
diff --git a/graphics/mesa-dri/Makefile b/graphics/mesa-dri/Makefile
index a819ceefe824..63d6cc7da96d 100644
--- a/graphics/mesa-dri/Makefile
+++ b/graphics/mesa-dri/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mesa-dri
PORTVERSION= ${MESAVERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
COMMENT= OpenGL hardware acceleration drivers for DRI2+
diff --git a/graphics/mesa-dri/Makefile.common b/graphics/mesa-dri/Makefile.common
index 51bf2783a109..95cb221eab5b 100644
--- a/graphics/mesa-dri/Makefile.common
+++ b/graphics/mesa-dri/Makefile.common
@@ -95,19 +95,11 @@ EXTRA_PATCHES+= ${PATCHDIR}/extra-src_gallium_auxiliary_meson.build \
BINARY_ALIAS+= python3=${PYTHON_VERSION}
-.if ${ARCH} == powerpc64
-LLVM_DEFAULT= 90
-BUILD_DEPENDS+= llvm${LLVM_DEFAULT}>=9.0.1_2:devel/llvm${LLVM_DEFAULT}
-.if ${COMPONENT} != libs
-RUN_DEPENDS+= llvm${LLVM_DEFAULT}>=9.0.1_2:devel/llvm${LLVM_DEFAULT}
-.endif
-.else
LLVM_DEFAULT= 10
BUILD_DEPENDS+= llvm${LLVM_DEFAULT}>=10.0.1_1:devel/llvm${LLVM_DEFAULT}
.if ${COMPONENT} != libs
RUN_DEPENDS+= llvm${LLVM_DEFAULT}>=10.0.1_1:devel/llvm${LLVM_DEFAULT}
.endif
-.endif
MESON_ARGS+= --native-file="${WRKSRC}/llvm.ini"
LDFLAGS+= -Wl,-rpath=${LOCALBASE}/llvm${LLVM_DEFAULT}/lib