aboutsummaryrefslogtreecommitdiff
path: root/graphics/mesa-dri
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2020-06-09 19:56:17 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2020-06-09 19:56:17 +0000
commita568c2781c1125e6216bed0f18d7c4d3a52698e1 (patch)
treed20a4c52036c8dc3ef362f2f37ac6c7a41a3f41b /graphics/mesa-dri
parenta512f780d8e35e2cb585efda4fd580b18522ceec (diff)
downloadports-a568c2781c1125e6216bed0f18d7c4d3a52698e1.tar.gz
ports-a568c2781c1125e6216bed0f18d7c4d3a52698e1.zip
mesa: Fix build empty DRI_DRIVER
In some cases, such as on sparc64, armv6 and armv7 etc, DRI_DRIVER, GALLIUM_DRIVER and/or VULKAN_DRIVER might be undefined. This causes an error similar to make: "/usr/ports/graphics/mesa-dri/Makefile" line 106: Malformed conditional (${DRI_DRIVERS:M${:UI915}}) Fix this by checking if [DRI,GALLIUM,VULKAN]_DRIVER is defined before checking what it is set to. While here, remove textproc/py-mako dependency from mesa-dri/Makefile, it's already included in mesa-dri/Makefile.common, no need to depend on it twice. PR: 247117 Reported by: jbeich
Notes
Notes: svn path=/head/; revision=538339
Diffstat (limited to 'graphics/mesa-dri')
-rw-r--r--graphics/mesa-dri/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/graphics/mesa-dri/Makefile b/graphics/mesa-dri/Makefile
index df080cd6a19f..8c72ba58b7d0 100644
--- a/graphics/mesa-dri/Makefile
+++ b/graphics/mesa-dri/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mesa-dri
PORTVERSION= ${MESAVERSION}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics
COMMENT= OpenGL hardware acceleration drivers for DRI2+
@@ -44,10 +44,7 @@ ALL_VULKAN_DRIVERS= INTEL AMD
.if ${ARCH} == aarch64 || ${ARCH} == amd64 || ${ARCH:Marm*} || ${ARCH} == i386 || ${ARCH:Mmips*} || ${ARCH:Mpowerpc*}
GALLIUM_DRIVERS= SWRAST # llvmpipe
-.else
-GALLIUM_DRIVERS= ""
.endif
-VULKAN_DRIVERS= #
.if ${ARCH} == aarch64 || ${ARCH} == amd64 || ${ARCH} == i386 \
|| ${ARCH} == powerpc || ${ARCH} == powerpc64
@@ -65,8 +62,7 @@ EXTRA_PATCHES+= ${PATCHDIR}/extra-src_mesa_drivers_dri_i965_intel__screen.c
VULKAN_DRIVERS+= INTEL
.endif
-.if ${VULKAN_DRIVERS}
-BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}mako>0:textproc/py-mako@${PY_FLAVOR}
+.if defined(VULKAN_DRIVERS)
USE_XORG+= xcb xrandr
.endif
@@ -103,7 +99,7 @@ MESON_ARGS+= -Dgallium-xa=false \
-Dtools=""
.for _d in ${ALL_DRI_DRIVERS}
-. if ${DRI_DRIVERS:M${_d}}
+. if defined(DRI_DRIVERS) && ${DRI_DRIVERS:M${_d}}
PLIST_SUB+= ${_d}_DRIVER=""
. else
PLIST_SUB+= ${_d}_DRIVER="@comment "
@@ -111,7 +107,7 @@ PLIST_SUB+= ${_d}_DRIVER="@comment "
.endfor
.for _gd in ${ALL_GALLIUM_DRIVERS}
-. if ${GALLIUM_DRIVERS:M${_gd}}
+. if defined(GALLIUM_DRIVERS) && ${GALLIUM_DRIVERS:M${_gd}}
PLIST_SUB+= ${_gd}_GDRIVER=""
. else
PLIST_SUB+= ${_gd}_GDRIVER="@comment "
@@ -120,7 +116,7 @@ PLIST_SUB+= ${_gd}_GDRIVER="@comment "
PLIST_SUB += ARCH=${ARCH:S/amd/x86_/}
.for _vd in ${ALL_VULKAN_DRIVERS}
-. if ${VULKAN_DRIVERS:M${_vd}}
+. if defined(VULKAN_DRIVERS) && ${VULKAN_DRIVERS:M${_vd}}
PLIST_SUB+= ${_vd}_VDRIVER=""
. else
PLIST_SUB+= ${_vd}_VDRIVER="@comment "