aboutsummaryrefslogtreecommitdiff
path: root/graphics/mesa-dri
diff options
context:
space:
mode:
authorEmmanuel Vadot <manu@FreeBSD.org>2020-09-17 09:22:29 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2020-09-17 09:22:29 +0000
commitbee928efb536d65a5bb4c4d7467b099838f0ad22 (patch)
tree6dbe620a62c3fb1f9b2c339678ff4fb7e7da2692 /graphics/mesa-dri
parentb661ab0ec22824e77033ed8a0cb34ace096b5d1d (diff)
downloadports-bee928efb536d65a5bb4c4d7467b099838f0ad22.tar.gz
ports-bee928efb536d65a5bb4c4d7467b099838f0ad22.zip
mesa*: Only add x11 dependancy if it's requested
This allow to have a full setup without any x11 deps. PR: 247029 Reviewed by: zeising Approved by: x11 (zeising@) Differential Revision: https://reviews.freebsd.org/D26438
Notes
Notes: svn path=/head/; revision=548829
Diffstat (limited to 'graphics/mesa-dri')
-rw-r--r--graphics/mesa-dri/Makefile13
-rw-r--r--graphics/mesa-dri/Makefile.common4
2 files changed, 8 insertions, 9 deletions
diff --git a/graphics/mesa-dri/Makefile b/graphics/mesa-dri/Makefile
index 9bd0787b97c0..5bfb749f1012 100644
--- a/graphics/mesa-dri/Makefile
+++ b/graphics/mesa-dri/Makefile
@@ -8,9 +8,6 @@ CATEGORIES= graphics
COMMENT= OpenGL hardware acceleration drivers for DRI2+
-USES= xorg
-USE_XORG= xorgproto x11 xdamage xext xfixes xshmfence
-
OPTIONS_GROUP= PLATFORM
OPTIONS_GROUP_PLATFORM= PLATFORM_X11 PLATFORM_WAYLAND PLATFORM_DRM PLATFORM_SURFACELESS
PLATFORM_X11_DESC= Enable X11 support for GBM/EGL
@@ -54,8 +51,8 @@ DRI_DRIVERS+= R100 R200
GALLIUM_DRIVERS+= R300 R600 RADEONSI
VULKAN_DRIVERS+= AMD
. if ${PORT_OPTIONS:MPLATFORM_X11}
-USE_XORG+= xv xvmc
MESON_ARGS+= -Dgallium-xvmc=true
+USE_XORG+= xvmc
. endif
.endif
.if ${ARCH} == amd64 || ${ARCH} == i386
@@ -67,14 +64,14 @@ EXTRA_PATCHES+= ${PATCHDIR}/extra-src_mesa_drivers_dri_i965_intel__screen.c
VULKAN_DRIVERS+= INTEL
.endif
-.if defined(VULKAN_DRIVERS)
-USE_XORG+= xcb xrandr
-.endif
-
LDFLAGS_i386= -Wl,-znotext
.if ${PORT_OPTIONS:MPLATFORM_X11}
MESA_PLATFORMS+= x11
+USE_XORG+= xorgproto x11 xdamage xext xfixes xshmfence xv
+.if defined(VULKAN_DRIVERS)
+USE_XORG+= xcb xrandr
+.endif
.endif
.if ${PORT_OPTIONS:MPLATFORM_DRM}
diff --git a/graphics/mesa-dri/Makefile.common b/graphics/mesa-dri/Makefile.common
index 74c635c34877..6e31dca69bd3 100644
--- a/graphics/mesa-dri/Makefile.common
+++ b/graphics/mesa-dri/Makefile.common
@@ -33,7 +33,9 @@ BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:devel/libpthread
${PYTHON_PKGNAMEPREFIX}mako>0:textproc/py-mako@${PY_FLAVOR}
LIB_DEPENDS+= libexpat.so:textproc/expat2
.if ${COMPONENT} != clover
-USES+= xorg
+.if ${PORT_OPTIONS:MPLATFORM_X11}
+USES+= xorg
+.endif
.endif
.if ${COMPONENT} != osmesa
LIB_DEPENDS+= libdrm.so:graphics/libdrm