aboutsummaryrefslogtreecommitdiff
path: root/graphics/mesa-libs
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-04-17 11:02:45 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-04-17 11:02:45 +0000
commit14f4762b8929deba643e86400d5aca5bf1f4b1b2 (patch)
tree7e179c0178e5ab3f84ac364faaad62b562835d4b /graphics/mesa-libs
parent54f81f82919c2c89153c144c80dde31f80e8f6c4 (diff)
downloadports-14f4762b8929deba643e86400d5aca5bf1f4b1b2.tar.gz
ports-14f4762b8929deba643e86400d5aca5bf1f4b1b2.zip
graphics/mesa-libs: fix build on powerpc head
Clang currently lacks atomic functions on powerpc, making build fail: u_atomic.c:64:1: error: definition of builtin function '__sync_val_compare_and_swap_8' Use GCC for now.
Notes
Notes: svn path=/head/; revision=531925
Diffstat (limited to 'graphics/mesa-libs')
-rw-r--r--graphics/mesa-libs/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/graphics/mesa-libs/Makefile b/graphics/mesa-libs/Makefile
index 6eb24bc585b4..ff5b0d2ea6ff 100644
--- a/graphics/mesa-libs/Makefile
+++ b/graphics/mesa-libs/Makefile
@@ -44,6 +44,8 @@ MESA_INSTALL_WRKSRC+= src/egl
.if ${ARCH} == "i386"
# PR230239 Fix the build for i386 when WITH_LLD_IS_LD is set
LDFLAGS+=-Wl,-z,notext
+.elif ${ARCH} == "powerpc"
+USE_GCC= yes
.endif
.include "${MASTERDIR}/Makefile.targets"