aboutsummaryrefslogtreecommitdiff
path: root/graphics/mesa-libs
diff options
context:
space:
mode:
authorEmmanuel Vadot <manu@FreeBSD.org>2020-10-12 08:30:54 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2020-10-12 08:30:54 +0000
commit57ce68a0c0cab56c3d08120e6f55c11a8c248f06 (patch)
tree88e8ad4aa5aa680ec7c0bbc956676c47044a89fc /graphics/mesa-libs
parent3870ad6c4bb281c7abf1b06de72b9adfd658d96f (diff)
downloadports-57ce68a0c0cab56c3d08120e6f55c11a8c248f06.tar.gz
ports-57ce68a0c0cab56c3d08120e6f55c11a8c248f06.zip
graphics/mesa*: Update to 20.2
Update to 20.2 Move graphics/libxatracker to graphics/mesa-gallium-xa Remove VAAPI and VDPAU options in mesa-libs in favor of two new ports : mesa-gallium-va and mesa-gallium-vdpau Bump needed llvm to llvm10 Change a lot of meson option from false to disabled as it's deprecated. Remove the drm and surfaceless platform from mesa* as it's always enabled now. Add zstd option, used for shader cache. Reviewed by: x11 (zeising@) Differential Revision: https://reviews.freebsd.org/D26682
Notes
Notes: svn path=/head/; revision=552109
Diffstat (limited to 'graphics/mesa-libs')
-rw-r--r--graphics/mesa-libs/Makefile33
-rw-r--r--graphics/mesa-libs/pkg-plist2
2 files changed, 13 insertions, 22 deletions
diff --git a/graphics/mesa-libs/Makefile b/graphics/mesa-libs/Makefile
index 601547690ae5..401077ea5277 100644
--- a/graphics/mesa-libs/Makefile
+++ b/graphics/mesa-libs/Makefile
@@ -3,7 +3,6 @@
PORTNAME= mesa-libs
PORTVERSION= ${MESAVERSION}
-PORTREVISION= 3
CATEGORIES= graphics
COMMENT= OpenGL libraries that support GLX and EGL clients
@@ -11,15 +10,13 @@ COMMENT= OpenGL libraries that support GLX and EGL clients
CONFLICTS_INSTALL= libglvnd # include/GL/gl.h
OPTIONS_GROUP= PLATFORM
-OPTIONS_GROUP_PLATFORM= PLATFORM_X11 PLATFORM_WAYLAND PLATFORM_DRM PLATFORM_SURFACELESS
+OPTIONS_GROUP_PLATFORM= PLATFORM_X11 PLATFORM_WAYLAND
PLATFORM_X11_DESC= Enable X11 support for GBM/EGL
PLATFORM_WAYLAND_DESC= Enable Wayland support for GBM/EGL
-PLATFORM_DRM_DESC= Enable DRM support for GBM/EGL
-PLATFORM_SURFACELESS_DESC= Enable Surfaceless support for GBM/EGL
PLATFORM_WAYLAND_IMPLIES= WAYLAND
-OPTIONS_DEFINE= WAYLAND
-OPTIONS_DEFAULT=WAYLAND PLATFORM_X11 PLATFORM_WAYLAND PLATFORM_DRM PLATFORM_SURFACELESS
+OPTIONS_DEFINE= WAYLAND ZSTD
+OPTIONS_DEFAULT=WAYLAND PLATFORM_X11 PLATFORM_WAYLAND ZSTD
OPTIONS_SUB= yes
WAYLAND_DESC= Enable support for the Wayland platform in EGL
@@ -27,21 +24,25 @@ WAYLAND_BUILD_DEPENDS= wayland-protocols>=1.8:graphics/wayland-protocols
WAYLAND_LIB_DEPENDS= libwayland-egl.so:graphics/wayland
WAYLAND_IMPLIES= PLATFORM_WAYLAND
+ZSTD_DESC= Use ZSTD for shader cache
+ZSTD_LIB_DEPENDS= libzstd.so:archivers/zstd
+ZSTD_MESON_ENABLED= zstd
+
.include <bsd.port.options.mk>
.include "${.CURDIR:H:H}/graphics/mesa-dri/Makefile.common"
MESON_ARGS+= -Dgallium-drivers="" \
- -Dgallium-vdpau=false \
- -Dgallium-xvmc=false \
+ -Dgallium-vdpau=disabled \
+ -Dgallium-xvmc=disabled \
-Dgallium-omx=disabled \
- -Dgallium-va=false \
- -Dgallium-xa=false \
+ -Dgallium-va=disabled \
+ -Dgallium-xa=disabled \
-Dgallium-nine=false \
-Dgallium-clover=disabled \
-Dosmesa=none \
-Dtools="" \
- -Degl=true \
- -Dgbm=true \
+ -Degl=enabled \
+ -Dgbm=enabled \
-Dvulkan-drivers=""
# Building EGL and GBM requires a dri driver so add swrast
MESON_ARGS+= -Ddri-drivers="swrast"
@@ -60,14 +61,6 @@ PLIST_SUB+= GLX="@comment "
MESA_PLATFORMS+= wayland
.endif
-.if ${PORT_OPTIONS:MPLATFORM_DRM}
-MESA_PLATFORMS+= drm
-.endif
-
-.if ${PORT_OPTIONS:MPLATFORM_SURFACELESS}
-MESA_PLATFORMS+= surfaceless
-.endif
-
MESON_ARGS+= -Dplatforms="${MESA_PLATFORMS:ts,:tl}"
.if ${ARCH} == "i386"
diff --git a/graphics/mesa-libs/pkg-plist b/graphics/mesa-libs/pkg-plist
index ffd9f7b66c48..04dcaa4f87a5 100644
--- a/graphics/mesa-libs/pkg-plist
+++ b/graphics/mesa-libs/pkg-plist
@@ -4,11 +4,9 @@ include/EGL/eglextchromium.h
include/EGL/eglmesaext.h
include/EGL/eglplatform.h
include/GL/gl.h
-include/GL/gl_mangle.h
include/GL/glcorearb.h
include/GL/glext.h
%%GLX%%include/GL/glx.h
-%%GLX%%include/GL/glx_mangle.h
%%GLX%%include/GL/glxext.h
@comment include/GL/internal/dri_interface.h
include/GLES/egl.h