aboutsummaryrefslogtreecommitdiff
path: root/graphics/metapixel/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-23 19:07:58 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-23 19:07:58 +0000
commitbff5acba31c26011c053860ed03dc08930757a0d (patch)
tree27ea571c503cfd3ddd4148e8b2d684e3b078cfd0 /graphics/metapixel/Makefile
parent7a3bbb8698ff243242906d5d94ae4608898619e4 (diff)
downloadports-bff5acba31c26011c053860ed03dc08930757a0d.tar.gz
ports-bff5acba31c26011c053860ed03dc08930757a0d.zip
add metapixel 0.7
Metapixel is a program for generating photomosaics PR: 38464 Submitted by: Tilman Linneweh <tilman@arved.de>
Notes
Notes: svn path=/head/; revision=59818
Diffstat (limited to 'graphics/metapixel/Makefile')
-rw-r--r--graphics/metapixel/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/graphics/metapixel/Makefile b/graphics/metapixel/Makefile
new file mode 100644
index 000000000000..9c9d09865929
--- /dev/null
+++ b/graphics/metapixel/Makefile
@@ -0,0 +1,27 @@
+# Ports collection makefile for: metapixel
+# Date created: 2002-05-23
+# Whom: Tilman Linneweh <freebsdports@arved.de>
+#
+# $FreeBSD$
+
+PORTNAME= metapixel
+PORTVERSION= 0.7
+CATEGORIES= graphics
+MASTER_SITES= http://www.complang.tuwien.ac.at/~schani/metapixel/
+
+MAINTAINER= freebsdports@arved.de
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+
+USE_GMAKE= yes
+
+post-patch:
+ @${RM} ${WRKSRC}/getopt.h
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/metapixel ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/metapixel-prepare ${PREFIX}/bin
+
+.include <bsd.port.mk>