aboutsummaryrefslogtreecommitdiff
path: root/graphics/mupdf
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2016-06-30 16:05:54 +0000
committerPawel Pekala <pawel@FreeBSD.org>2016-06-30 16:05:54 +0000
commit5557089bd7b992b8d1b909d800f8c45b1854847c (patch)
tree92265a88a3e858302207bee81bcc467361e31f24 /graphics/mupdf
parentb045ae83c37f9dd4b31af6e19698a9c01c1afd7f (diff)
downloadports-5557089bd7b992b8d1b909d800f8c45b1854847c.tar.gz
ports-5557089bd7b992b8d1b909d800f8c45b1854847c.zip
- Update graphics/mupdf to version 1.9a [1]
- Fix graphics/zathura-pdf-mupdf after mupdf update [1] - Fix graphics/llpp after mupdf update [2] PR: 210398 Submitted by: Zsolt Udvari (maintainer) [1] Tobias Kortkamp (maintainer) [2]
Notes
Notes: svn path=/head/; revision=417832
Diffstat (limited to 'graphics/mupdf')
-rw-r--r--graphics/mupdf/Makefile26
-rw-r--r--graphics/mupdf/distinfo5
-rw-r--r--graphics/mupdf/files/patch-scripts_fontdump.c10
-rw-r--r--graphics/mupdf/pkg-plist8
4 files changed, 37 insertions, 12 deletions
diff --git a/graphics/mupdf/Makefile b/graphics/mupdf/Makefile
index 51c1b89fe458..53590b09045a 100644
--- a/graphics/mupdf/Makefile
+++ b/graphics/mupdf/Makefile
@@ -2,12 +2,12 @@
# $FreeBSD$
PORTNAME= mupdf
-PORTVERSION= 1.8
+PORTVERSION= 1.9a
DISTVERSIONSUFFIX= -source
PORTEPOCH= 1
CATEGORIES= graphics
-MASTER_SITES= http://www.mupdf.com/download/ \
- http://www.mupdf.com/download/archive/
+MASTER_SITES= http://www.mupdf.com/downloads/ \
+ http://www.mupdf.com/downloads/archive/
MAINTAINER= udvzsolt@gmail.com
COMMENT= Lightweight PDF viewer and toolkit
@@ -17,14 +17,16 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libcurl.so:ftp/curl \
libfreetype.so:print/freetype2 \
+ libharfbuzz.so:print/harfbuzz \
libjbig2dec.so:graphics/jbig2dec \
libopenjp2.so:graphics/openjpeg
-CFLAGS+= -I${WRKSRC}/include/mupdf
+CFLAGS+= -I${WRKSRC}/include/mupdf -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
MAKE_ARGS= build=release prefix=${PREFIX} mandir=${PREFIX}/man verbose=yes
USES= cpe compiler:c++11-lang gmake jpeg pkgconfig
-USE_XORG= x11 xext
+USE_XORG= x11 xcursor xext xinerama xrandr
+USE_GL= gl
CPE_VENDOR= artifex
@@ -45,9 +47,13 @@ post-patch:
-e 's|/usr/local|${LOCALBASE}|' \
-e 's/Linux/FreeBSD/' \
${WRKSRC}/Makerules
- @${REINPLACE_CMD} '/^CFLAGS/s|$$| -I${LOCALBASE}/include|' \
- ${WRKSRC}/Makefile
- @${RM} -r ${WRKSRC}/thirdparty/*
+ @${RM} -r ${WRKSRC}/thirdparty/curl \
+ ${WRKSRC}/thirdparty/jbig2dec \
+ ${WRKSRC}/thirdparty/freetype \
+ ${WRKSRC}/thirdparty/harfbuzz \
+ ${WRKSRC}/thirdparty/jpeg \
+ ${WRKSRC}/thirdparty/openjpeg \
+ ${WRKSRC}/thirdparty/zlib
post-build:
(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} \
@@ -56,8 +62,10 @@ post-build:
post-install:
${INSTALL_DATA} ${WRKSRC}/build/pic/libmupdf.a \
${STAGEDIR}${PREFIX}/lib/libmupdf_pic.a
+ ${INSTALL_DATA} ${WRKSRC}/build/pic/libmupdfthird.a \
+ ${STAGEDIR}${PREFIX}/lib/libmupdfthird_pic.a
${MV} ${STAGEDIR}${PREFIX}/bin/mupdf-x11 ${STAGEDIR}${PREFIX}/bin/mupdf
-.for binary in mutool mujstest mupdf mupdf-x11-curl
+.for binary in mutool mujstest mupdf mupdf-gl mupdf-x11-curl
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${binary}
.endfor
diff --git a/graphics/mupdf/distinfo b/graphics/mupdf/distinfo
index 9c363f0a2ea8..b69d3375bdfc 100644
--- a/graphics/mupdf/distinfo
+++ b/graphics/mupdf/distinfo
@@ -1,2 +1,3 @@
-SHA256 (mupdf-1.8-source.tar.gz) = a2a3c64d8b24920f87cf4ea9339a25abf7388496440f13b37482d1403c33c206
-SIZE (mupdf-1.8-source.tar.gz) = 14169777
+TIMESTAMP = 1466328793
+SHA256 (mupdf-1.9a-source.tar.gz) = 8015c55f4e6dd892d3c50db4f395c1e46660a10b460e2ecd180a497f55bbc4cc
+SIZE (mupdf-1.9a-source.tar.gz) = 20493793
diff --git a/graphics/mupdf/files/patch-scripts_fontdump.c b/graphics/mupdf/files/patch-scripts_fontdump.c
new file mode 100644
index 000000000000..092f416d896f
--- /dev/null
+++ b/graphics/mupdf/files/patch-scripts_fontdump.c
@@ -0,0 +1,10 @@
+--- scripts/fontdump.c.orig 2016-06-12 09:11:56 UTC
++++ scripts/fontdump.c
+@@ -50,7 +50,6 @@ main(int argc, char **argv)
+ fprintf(fo, "#ifndef __STRICT_ANSI__\n");
+ fprintf(fo, "#if defined(__linux__) || defined(__FreeBSD__) || defined(__OpenBSD__)\n");
+ fprintf(fo, "#if !defined(__ICC)\n");
+- fprintf(fo, "#define HAVE_INCBIN\n");
+ fprintf(fo, "#endif\n");
+ fprintf(fo, "#endif\n");
+ fprintf(fo, "#endif\n");
diff --git a/graphics/mupdf/pkg-plist b/graphics/mupdf/pkg-plist
index 524cee1df7ec..c46b19c1fd88 100644
--- a/graphics/mupdf/pkg-plist
+++ b/graphics/mupdf/pkg-plist
@@ -1,9 +1,11 @@
bin/mujstest
bin/mupdf
+bin/mupdf-gl
bin/mupdf-x11-curl
bin/mutool
include/mupdf/fitz.h
include/mupdf/fitz/annotation.h
+include/mupdf/fitz/bidi.h
include/mupdf/fitz/bitmap.h
include/mupdf/fitz/buffer.h
include/mupdf/fitz/colorspace.h
@@ -27,12 +29,14 @@ include/mupdf/fitz/outline.h
include/mupdf/fitz/output-pcl.h
include/mupdf/fitz/output-png.h
include/mupdf/fitz/output-pnm.h
+include/mupdf/fitz/output-ps.h
include/mupdf/fitz/output-pwg.h
include/mupdf/fitz/output-svg.h
include/mupdf/fitz/output-tga.h
include/mupdf/fitz/output.h
include/mupdf/fitz/path.h
include/mupdf/fitz/pixmap.h
+include/mupdf/fitz/pool.h
include/mupdf/fitz/separation.h
include/mupdf/fitz/shade.h
include/mupdf/fitz/store.h
@@ -47,7 +51,6 @@ include/mupdf/fitz/ucdn.h
include/mupdf/fitz/unzip.h
include/mupdf/fitz/util.h
include/mupdf/fitz/version.h
-include/mupdf/fitz/write-document.h
include/mupdf/fitz/xml.h
include/mupdf/html.h
include/mupdf/memento.h
@@ -62,6 +65,7 @@ include/mupdf/pdf/document.h
include/mupdf/pdf/event.h
include/mupdf/pdf/field.h
include/mupdf/pdf/font.h
+include/mupdf/pdf/graft.h
include/mupdf/pdf/interpret.h
include/mupdf/pdf/javascript.h
include/mupdf/pdf/name-table.h
@@ -74,6 +78,8 @@ include/mupdf/pdf/widget.h
include/mupdf/pdf/xref.h
include/mupdf/xps.h
lib/libmupdf.a
+lib/libmupdfthird.a
+lib/libmupdfthird_pic.a
lib/libmupdf_pic.a
man/man1/mupdf.1.gz
man/man1/mutool.1.gz