aboutsummaryrefslogtreecommitdiff
path: root/graphics/mupdf
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2018-07-14 07:37:00 +0000
committerThomas Zander <riggs@FreeBSD.org>2018-07-14 07:37:00 +0000
commit73663b8b514dab0948f1aa56735529351b735d8a (patch)
tree2fb16216f9365dc293cb5429516275c00e9319cb /graphics/mupdf
parent834c1cba1f65dadde613f2af6d5c7cc6f91945d2 (diff)
downloadports-73663b8b514dab0948f1aa56735529351b735d8a.tar.gz
ports-73663b8b514dab0948f1aa56735529351b735d8a.zip
Update to upstream version 1.13.0
Detailed maintainer log: - Update to 1.13.0 - Install tools manually - Changelog: https://mupdf.com/news.html PR: 229110 Submitted by: uzsolt@uzsolt.hu (maintainer)
Notes
Notes: svn path=/head/; revision=474621
Diffstat (limited to 'graphics/mupdf')
-rw-r--r--graphics/mupdf/Makefile9
-rw-r--r--graphics/mupdf/distinfo6
-rw-r--r--graphics/mupdf/files/patch-Makerules4
-rw-r--r--graphics/mupdf/files/patch-source__fitz__load-jpx.c33
4 files changed, 13 insertions, 39 deletions
diff --git a/graphics/mupdf/Makefile b/graphics/mupdf/Makefile
index ec1696b19c6a..2b7c6351796b 100644
--- a/graphics/mupdf/Makefile
+++ b/graphics/mupdf/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mupdf
-PORTVERSION= 1.12.0
+PORTVERSION= 1.13.0
DISTVERSIONSUFFIX= -source
PORTEPOCH= 1
CATEGORIES= graphics
@@ -27,6 +27,7 @@ CFLAGS+= -I${WRKSRC}/include/mupdf -fPIC
LIBS+= -L${LOCALBASE}/lib
MAKE_ARGS= build=release prefix=${PREFIX} mandir=${PREFIX}/man verbose=yes \
SOVERSION=${PORTVERSION}
+ALL_TARGET= all extra
USES= cpe compiler:c++11-lang gmake jpeg pkgconfig
USE_XORG= x11 xcursor xext xinerama xrandr
USE_GL= gl glut
@@ -61,6 +62,12 @@ post-patch:
post-install:
${MV} ${STAGEDIR}${PREFIX}/bin/mupdf-x11 ${STAGEDIR}${PREFIX}/bin/mupdf
+ ${INSTALL_PROGRAM} \
+ ${WRKSRC}/build/release/mjsgen \
+ ${WRKSRC}/build/release/mujstest \
+ ${WRKSRC}/build/release/mupdf-x11-curl \
+ ${WRKSRC}/build/release/muraster \
+ ${STAGEDIR}${PREFIX}/bin
${LN} -s libmupdf.so.${PORTVERSION} \
${STAGEDIR}${PREFIX}/lib/libmupdf.so
${LN} -s libmupdfthird.so.${PORTVERSION} \
diff --git a/graphics/mupdf/distinfo b/graphics/mupdf/distinfo
index ea384d365461..ec465502a10c 100644
--- a/graphics/mupdf/distinfo
+++ b/graphics/mupdf/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1514557967
-SHA256 (mupdf-1.12.0-source.tar.gz) = 5c6353a82f1512f4f5280cf69a3725d1adac9c8b22377ec2a447c4fc45528755
-SIZE (mupdf-1.12.0-source.tar.gz) = 51508917
+TIMESTAMP = 1529321680
+SHA256 (mupdf-1.13.0-source.tar.gz) = 071c6962cbee1136188da62136596a9d704b81e35fe617cd34874bbb0ae7ca09
+SIZE (mupdf-1.13.0-source.tar.gz) = 51425034
diff --git a/graphics/mupdf/files/patch-Makerules b/graphics/mupdf/files/patch-Makerules
index c5a0c9f13e69..7b1f77534089 100644
--- a/graphics/mupdf/files/patch-Makerules
+++ b/graphics/mupdf/files/patch-Makerules
@@ -1,4 +1,4 @@
---- Makerules.orig 2017-12-13 14:00:30 UTC
+--- Makerules.orig 2018-06-18 11:40:10 UTC
+++ Makerules
@@ -87,7 +87,7 @@ LD = xcrun ld
RANLIB_CMD = xcrun ranlib $@
@@ -13,7 +13,7 @@
SYS_GLUT_CFLAGS :=
SYS_GLUT_LIBS := -lglut -lGL
--ifeq "$(shell pkg-config --exists 'libcrypto <= 1.0.1t' && echo yes)" "yes"
+-ifeq "$(shell pkg-config --exists 'libcrypto >= 1.1.0' && echo yes)" "yes"
-HAVE_LIBCRYPTO := yes
-SYS_LIBCRYPTO_CFLAGS := -DHAVE_LIBCRYPTO $(shell pkg-config --cflags libcrypto)
-SYS_LIBCRYPTO_LIBS := $(shell pkg-config --libs libcrypto)
diff --git a/graphics/mupdf/files/patch-source__fitz__load-jpx.c b/graphics/mupdf/files/patch-source__fitz__load-jpx.c
deleted file mode 100644
index 17151d9a60d5..000000000000
--- a/graphics/mupdf/files/patch-source__fitz__load-jpx.c
+++ /dev/null
@@ -1,33 +0,0 @@
---- source/fitz/load-jpx.c.orig 2017-12-13 14:00:30 UTC
-+++ source/fitz/load-jpx.c
-@@ -445,14 +445,18 @@ fz_load_jpx_info(fz_context *ctx, const
-
- #else /* HAVE_LURATECH */
-
-+#ifdef __cplusplus
-+extern "C"
-+{
- #define OPJ_STATIC
- #define OPJ_HAVE_INTTYPES_H
- #if !defined(_MSC_VER) || _MSC_VER >= 1600
- #define OPJ_HAVE_STDINT_H
- #endif
-+#endif
- #define USE_JPIP
-
--#include <openjpeg.h>
-+#include <openjpeg-2.3/openjpeg.h>
-
- struct fz_jpxd_s
- {
-@@ -930,6 +934,10 @@ fz_load_jpx_info(fz_context *ctx, const
- *yresp = state.yres;
- }
-
-+#ifdef __cplusplus
-+}
-+#endif
-+
- #endif /* HAVE_LURATECH */
-
- #else /* FZ_ENABLE_JPX */