aboutsummaryrefslogtreecommitdiff
path: root/graphics/netpbm
diff options
context:
space:
mode:
authorCraig Leres <leres@FreeBSD.org>2023-08-21 21:30:59 +0000
committerCraig Leres <leres@FreeBSD.org>2023-08-21 21:30:59 +0000
commitb253eb3a1ac05342e8f9232e8fe8e92ccc4b24a6 (patch)
tree754d247cc1ff62c75ef858ed64fe6ebd237d76e4 /graphics/netpbm
parent07bc8eac09d2c8a463d6abe0ac56b163ad3112a0 (diff)
downloadports-b253eb3a1ac05342e8f9232e8fe8e92ccc4b24a6.tar.gz
ports-b253eb3a1ac05342e8f9232e8fe8e92ccc4b24a6.zip
graphics/netpbm: Unbreak build WITH_PIE
While we're here fix portlint nit. Reported by: netchild PR: 268982
Diffstat (limited to 'graphics/netpbm')
-rw-r--r--graphics/netpbm/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/graphics/netpbm/Makefile b/graphics/netpbm/Makefile
index 8618dbdb26f3..e28f2b2430b3 100644
--- a/graphics/netpbm/Makefile
+++ b/graphics/netpbm/Makefile
@@ -82,6 +82,12 @@ post-patch:
@${REINPLACE_CMD} -e 's|pkg-config|false|g' ${WRKSRC}/GNUmakefile
@${REINPLACE_CMD} ${_DISABLE_TESTS:@.test.@-e '/${.test.}/d'@} \
${WRKSRC}/test/Test-Order
+.ifdef WITH_PIE
+.for dn in buildtools test
+ @${REINPLACE_CMD} -e '/^all:/s/^/CFLAGS_FOR_BUILD+=${PIE_CFLAGS}\n/' \
+ ${WRKSRC}/${dn}/Makefile
+.endfor
+.endif
post-patch-STATIC-on:
@${REINPLACE_CMD} -e 's|$$(LD)|$$(LD) -static|g' \
@@ -122,7 +128,7 @@ NETPBM_SERIES= advanced
netpbm-version-check:
@REV=`svnlite info ${NETPBM_REPO}/${NETPBM_SERIES}/version.mk | ${SED} -n 's/Last Changed Rev: //p'`; \
- VERSION=`(svnlite cat -r$$REV ${NETPBM_REPO}/${NETPBM_SERIES}/version.mk; \
+ VERSION=`(svnlite ${CAT} -r$$REV ${NETPBM_REPO}/${NETPBM_SERIES}/version.mk; \
echo 'all:'; \
echo ' @printf "%02d.%02d.%02d" \'; \
echo ' $${NETPBM_MAJOR_RELEASE} \' ; \