aboutsummaryrefslogtreecommitdiff
path: root/graphics/nip2
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2014-07-01 18:59:49 +0000
committerMikhail Teterin <mi@FreeBSD.org>2014-07-01 18:59:49 +0000
commit1a79a9e86fc7035723be71cf79dfcfcd9227f611 (patch)
tree466084704da829da74fa49dd5974f93e7c0f51bd /graphics/nip2
parent046f632b9dad646fde1414d4317a1498298e8c29 (diff)
downloadports-1a79a9e86fc7035723be71cf79dfcfcd9227f611.tar.gz
ports-1a79a9e86fc7035723be71cf79dfcfcd9227f611.zip
Upgrade from 7.26.3 to 7.40.1 (nip2) and .2 (vips) -- the current
latest. Support staging in nip2. Add self-test target to nip2. Although the software is built against GraphicsMagick, some of the tests require ImageMagick's convert and therefor the tests are not (yet) labeled "regression-test". The author is working on the fix.
Notes
Notes: svn path=/head/; revision=360084
Diffstat (limited to 'graphics/nip2')
-rw-r--r--graphics/nip2/Makefile52
-rw-r--r--graphics/nip2/distinfo4
-rw-r--r--graphics/nip2/files/extra-patch-src-parser.h11
-rw-r--r--graphics/nip2/files/patch-src-graphwindow.c2
-rw-r--r--graphics/nip2/files/patch-tests57
-rw-r--r--graphics/nip2/files/run-nip2.sh.in10
-rw-r--r--graphics/nip2/pkg-plist183
7 files changed, 221 insertions, 98 deletions
diff --git a/graphics/nip2/Makefile b/graphics/nip2/Makefile
index 1b9553aec2f7..bb182ff3a485 100644
--- a/graphics/nip2/Makefile
+++ b/graphics/nip2/Makefile
@@ -2,44 +2,60 @@
# $FreeBSD$
PORTNAME= nip2
-PORTVERSION= 7.26.3
-PORTREVISION= 3
+PORTVERSION= 7.40.1
CATEGORIES= graphics
MASTER_SITES= http://www.vips.ecs.soton.ac.uk/supported/${PORTVERSION:R}/
MAINTAINER= mi@aldan.algebra.com
COMMENT= Graphical user interface for VIPS
-LIB_DEPENDS= libvips.so:${PORTSDIR}/graphics/vips \
- gsl:${PORTSDIR}/math/gsl \
+OPTIONS_DEFINE= DOCS
+LIB_DEPENDS= libvips.so:${PORTSDIR}/graphics/vips \
+ libgoffice-*.so:${PORTSDIR}/devel/goffice \
+ libgsl.so:${PORTSDIR}/math/gsl \
+ libgvc.so:${PORTSDIR}/graphics/graphviz \
xml2:${PORTSDIR}/textproc/libxml2
+BUILD_DEPENDS= xgettext:${PORTSDIR}/devel/gettext
-USES= bison gmake pkgconfig
+USES= bison dos2unix gettext gmake pkgconfig
USE_GNOME= gnomemimedata glib20 gtk20
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --mandir=${PREFIX}/man
+CONFIGURE_ENV+= XGETTEXT=${LOCALBASE}/bin/xgettext \
+ LIBGVC_LIBS="-L${LOCALBASE}/lib/graphviz -lgvc" \
+ LIBGVC_CFLAGS="-I${LOCALBASE}/include/graphviz"
+DOS2UNIX_GLOB= *.def
+SUB_FILES= run-nip2.sh
# This port has no man-pages. It installs a number of HTML files,
# which are available through the GUI's Help. For this reason, they
# are always installed, regardless of the NOPORTDOCS setting.
-NO_STAGE= yes
-# The PDF version of the documentation is another story:
-.if defined(NOPORTDOCS)
-EXTRACT_AFTER_ARGS= --exclude nipguide --exclude pdf
-.endif
# Somehow vendor's configure misses these:
MAKE_ENV+= UPDATE_MIME_DATABASE=update-mime-database \
UPDATE_DESKTOP_DATABASE=update-desktop-database
MAN1= nip2.1
-.include <bsd.port.options.mk>
-
-.if ${OSVERSION} >= 1000013
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src-parser.h
-.endif
+post-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/run-nip2.sh \
+ ${STAGEDIR}/${PREFIX}/bin/
post-patch:
- @${REINPLACE_CMD} -e 's|n_bytes|x_n_bytes|g' -e 's|text_size|x_text_size|g' \
- ${WRKSRC}/src/gtkitementry.c
+ ${REINPLACE_CMD} -e 's|/bin/bash|/bin/sh|g' \
+ ${WRKSRC}/test/scripts/*
+
+test check: build
+ #
+ # Checks currently require ImageMagick's convert to be available
+ # and aren't enabled by default. They take a long time -- tail
+ # the log-file:
+ # ${WRKSRC}/test/test_all.sh.log
+ #
+ ${GMAKE} -C ${WRKSRC} check
+
+.include <bsd.port.pre.mk>
+
+.if ! ${PORT_OPTIONS:MDOCS}
+EXTRACT_AFTER_ARGS+= --exclude nipguide.pdf --exclude pdf
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/nip2/distinfo b/graphics/nip2/distinfo
index ffc79630175f..94343f98fdef 100644
--- a/graphics/nip2/distinfo
+++ b/graphics/nip2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nip2-7.26.3.tar.gz) = 94d842ffb6ba1d210ce7358c62f4f4cfa52c5663a2deb03f662aba29a0bee9d8
-SIZE (nip2-7.26.3.tar.gz) = 8681267
+SHA256 (nip2-7.40.1.tar.gz) = 67b46e6e6b488c6ed4e9212100d59ddeee34fac0977cc0c32aa0a21f29653a4d
+SIZE (nip2-7.40.1.tar.gz) = 9628285
diff --git a/graphics/nip2/files/extra-patch-src-parser.h b/graphics/nip2/files/extra-patch-src-parser.h
deleted file mode 100644
index 99565d9e1796..000000000000
--- a/graphics/nip2/files/extra-patch-src-parser.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/parser.h.orig 2011-01-25 19:44:07.000000000 +0300
-+++ src/parser.h 2013-11-28 04:22:09.853554221 +0400
-@@ -54,7 +54,7 @@
- */
- void yyerror( const char *sub, ... )
- __attribute__((format(printf, 1, 2)));
--extern int yyleng; /* lex stuff */
-+extern size_t yyleng; /* lex stuff */
-
- /* Lex gathers tokens here for workspace.c
- */
diff --git a/graphics/nip2/files/patch-src-graphwindow.c b/graphics/nip2/files/patch-src-graphwindow.c
index e8c5c6e1c528..e20fa3a7f689 100644
--- a/graphics/nip2/files/patch-src-graphwindow.c
+++ b/graphics/nip2/files/patch-src-graphwindow.c
@@ -1,4 +1,4 @@
---- src/graphwindow.c.orig 2011-01-25 19:44:07.000000000 +0300
+--- src/graphwindow.c 2011-01-25 19:44:07.000000000 +0300
+++ src/graphwindow.c 2013-11-28 03:48:15.996694984 +0400
@@ -260,7 +260,7 @@
diff --git a/graphics/nip2/files/patch-tests b/graphics/nip2/files/patch-tests
new file mode 100644
index 000000000000..3b5160656ef9
--- /dev/null
+++ b/graphics/nip2/files/patch-tests
@@ -0,0 +1,57 @@
+--- test/scripts/test_threading.sh 2013-08-19 16:56:45.000000000 -0400
++++ test/scripts/test_threading.sh 2014-07-01 11:54:10.000000000 -0400
+@@ -1,3 +1,3 @@
+-#!/bin/bash
++#!/bin/sh
+
+ # set -x
+@@ -28,14 +28,14 @@
+ vips im_abs $tmp/t8.v $tmp/t9.v
+ max=`vips im_max $tmp/t9.v`
+- if [[ $max > 0 ]]; then
++ if [ $max -gt 0 ]; then
+ break
+ fi
+ done
+- if [[ $max > 0 ]]; then
++ if [ $max -gt 0 ]; then
+ break
+ fi
+ done
+
+-if [[ $max > 0 ]]; then
++if [ $max -gt 0 ]; then
+ echo error, max == $max
+ exit 1
+@@ -43,3 +43,2 @@
+ echo all threading tests passed
+ fi
+-
+--- test/scripts/test_seq.sh 2014-06-23 15:17:21.000000000 -0400
++++ test/scripts/test_seq.sh 2014-07-01 12:38:53.000000000 -0400
+@@ -1,3 +1,3 @@
+-#!/bin/bash
++#!/bin/sh
+
+ # set -x
+@@ -18,5 +18,5 @@
+ rm -f $tmp/x.png
+ vipsthumbnail $huge -o $tmp/x.png
+-if ! vipsheader $tmp/x.png &> /dev/null ; then
++if ! vipsheader $tmp/x.png ; then
+ echo "vipsthumbnail failed in basic mode"
+ exit 1
+@@ -33,5 +33,5 @@
+ rm -f $tmp/x.png
+ vipsthumbnail $huge -o $tmp/x.png
+-if ! vipsheader $tmp/x.png &> /dev/null ; then
++if ! vipsheader $tmp/x.png ; then
+ echo "vipsthumbnail made a temp"
+ exit 1
+@@ -42,5 +42,5 @@
+ rm -f $tmp/x.png
+ vips shrink $huge $tmp/x.png 230 230
+-if ! vipsheader $tmp/x.png &> /dev/null; then
++if ! vipsheader $tmp/x.png ; then
+ echo "shrink made a temp"
+ exit 1
diff --git a/graphics/nip2/files/run-nip2.sh.in b/graphics/nip2/files/run-nip2.sh.in
new file mode 100644
index 000000000000..85aa89fa83de
--- /dev/null
+++ b/graphics/nip2/files/run-nip2.sh.in
@@ -0,0 +1,10 @@
+#!/bin/sh
+if [ -z "$VIPSHOME" ]
+then
+ export VIPSHOME=%%PREFIX%%
+fi
+if [ -z "$GDK_USE_XFT" ]
+then
+ export GDK_USE_XFT=1
+fi
+exec %%PREFIX%%/bin/nip2 "$@"
diff --git a/graphics/nip2/pkg-plist b/graphics/nip2/pkg-plist
index ace380096c30..994d4e051bd0 100644
--- a/graphics/nip2/pkg-plist
+++ b/graphics/nip2/pkg-plist
@@ -51,6 +51,8 @@ share/nip2/data/stock-led-blue-18.png
share/nip2/data/stock-led-cyan-18.png
share/nip2/data/stock-led-yellow-18.png
share/nip2/data/stock-led-off-18.png
+share/nip2/start/_magick.def
+share/nip2/start/Magick.def
share/nip2/start/Math.def
share/nip2/start/Image.def
share/nip2/start/Colour.def
@@ -194,7 +196,6 @@ share/nip2/compat/7.24/Image.def
share/nip2/compat/7.24/Math.def
share/nip2/compat/7.24/Matrix.def
share/nip2/compat/7.24/Object.def
-share/nip2/compat/7.24/Preferences.ws
share/nip2/compat/7.24/Tasks.def
share/nip2/compat/7.24/Widgets.def
share/nip2/compat/7.24/_Object.def
@@ -206,6 +207,60 @@ share/nip2/compat/7.24/_list.def
share/nip2/compat/7.24/_predicate.def
share/nip2/compat/7.24/_stdenv.def
share/nip2/compat/7.24/_types.def
+share/nip2/compat/7.26/Math.def
+share/nip2/compat/7.26/Image.def
+share/nip2/compat/7.26/Colour.def
+share/nip2/compat/7.26/Tasks.def
+share/nip2/compat/7.26/Object.def
+share/nip2/compat/7.26/Filter.def
+share/nip2/compat/7.26/Matrix.def
+share/nip2/compat/7.26/Widgets.def
+share/nip2/compat/7.26/Histogram.def
+share/nip2/compat/7.26/_joe_extra.def
+share/nip2/compat/7.26/_joe_utilities.def
+share/nip2/compat/7.26/_convert.def
+share/nip2/compat/7.26/_generate.def
+share/nip2/compat/7.26/_list.def
+share/nip2/compat/7.26/_predicate.def
+share/nip2/compat/7.26/_stdenv.def
+share/nip2/compat/7.26/_Object.def
+share/nip2/compat/7.26/_types.def
+share/nip2/compat/7.28/Math.def
+share/nip2/compat/7.28/Image.def
+share/nip2/compat/7.28/Colour.def
+share/nip2/compat/7.28/Tasks.def
+share/nip2/compat/7.28/Object.def
+share/nip2/compat/7.28/Filter.def
+share/nip2/compat/7.28/Matrix.def
+share/nip2/compat/7.28/Widgets.def
+share/nip2/compat/7.28/Histogram.def
+share/nip2/compat/7.28/_joe_extra.def
+share/nip2/compat/7.28/_joe_utilities.def
+share/nip2/compat/7.28/_convert.def
+share/nip2/compat/7.28/_generate.def
+share/nip2/compat/7.28/_list.def
+share/nip2/compat/7.28/_predicate.def
+share/nip2/compat/7.28/_stdenv.def
+share/nip2/compat/7.28/_Object.def
+share/nip2/compat/7.28/_types.def
+share/nip2/compat/7.38/Math.def
+share/nip2/compat/7.38/Image.def
+share/nip2/compat/7.38/Colour.def
+share/nip2/compat/7.38/Tasks.def
+share/nip2/compat/7.38/Object.def
+share/nip2/compat/7.38/Filter.def
+share/nip2/compat/7.38/Matrix.def
+share/nip2/compat/7.38/Widgets.def
+share/nip2/compat/7.38/Histogram.def
+share/nip2/compat/7.38/_joe_extra.def
+share/nip2/compat/7.38/_joe_utilities.def
+share/nip2/compat/7.38/_convert.def
+share/nip2/compat/7.38/_generate.def
+share/nip2/compat/7.38/_list.def
+share/nip2/compat/7.38/_predicate.def
+share/nip2/compat/7.38/_stdenv.def
+share/nip2/compat/7.38/_Object.def
+share/nip2/compat/7.38/_types.def
share/nip2/data/examples/1_point_mosaic/1pt_mosaic.ws
share/nip2/data/examples/1_point_mosaic/cd1.1.jpg
share/nip2/data/examples/1_point_mosaic/cd1.2.jpg
@@ -224,6 +279,8 @@ share/nip2/data/examples/2_point_mosaic/example_im_04.jpg
share/nip2/data/examples/2_point_mosaic/example_im_05.jpg
share/nip2/data/examples/2_point_mosaic/example_im_06.jpg
share/nip2/data/examples/2_point_mosaic/full_image.jpg
+share/nip2/data/stock-padlock-closed-22.png
+share/nip2/data/stock-alert-22.png
@dirrm share/nip2/data/examples/2_point_mosaic
@dirrm share/nip2/compat/7.8
@dirrm share/nip2/compat/7.9
@@ -232,6 +289,9 @@ share/nip2/data/examples/2_point_mosaic/full_image.jpg
@dirrm share/nip2/compat/7.14
@dirrm share/nip2/compat/7.16
@dirrm share/nip2/compat/7.24
+@dirrm share/nip2/compat/7.26
+@dirrm share/nip2/compat/7.28
+@dirrm share/nip2/compat/7.38
@dirrm share/nip2/compat
@dirrm share/nip2/data/examples/businesscard
@dirrm share/nip2/data/examples/clone
@@ -245,91 +305,82 @@ share/nip2/data/examples/2_point_mosaic/full_image.jpg
@dirrm share/nip2/rc
@dirrm share/nip2/start
@dirrm share/nip2
-%%DOCSDIR%%/html/figs/ir1.jpg
-%%DOCSDIR%%/html/figs/ir2.jpg
-%%DOCSDIR%%/html/figs/ir3.jpg
-%%DOCSDIR%%/html/figs/ir4.jpg
-%%DOCSDIR%%/html/figs/ir5.jpg
-%%DOCSDIR%%/html/figs/ir6.jpg
%%DOCSDIR%%/html/figs/ir7.jpg
+%%DOCSDIR%%/html/figs/ir5.jpg
%%DOCSDIR%%/html/figs/ir8a.jpg
-%%DOCSDIR%%/html/figs/ir9.jpg
-%%DOCSDIR%%/html/figs/mos2.png
-%%DOCSDIR%%/html/figs/scr21a.png
-%%DOCSDIR%%/html/figs/scr22.png
-%%DOCSDIR%%/html/figs/scr23.jpg
-%%DOCSDIR%%/html/figs/scr24.jpg
-%%DOCSDIR%%/html/figs/scr25.jpg
-%%DOCSDIR%%/html/figs/scr26.png
-%%DOCSDIR%%/html/figs/snap1.jpg
-%%DOCSDIR%%/html/figs/snap10.jpg
-%%DOCSDIR%%/html/figs/snap11.jpg
+%%DOCSDIR%%/html/figs/toolkit2.jpg
+%%DOCSDIR%%/html/figs/snap9.jpg
+%%DOCSDIR%%/html/figs/snap7a.jpg
%%DOCSDIR%%/html/figs/snap12.jpg
-%%DOCSDIR%%/html/figs/snap13.jpg
-%%DOCSDIR%%/html/figs/snap14.jpg
-%%DOCSDIR%%/html/figs/snap15.jpg
+%%DOCSDIR%%/html/figs/scr21a.png
+%%DOCSDIR%%/html/figs/ir3.jpg
%%DOCSDIR%%/html/figs/snap16.jpg
%%DOCSDIR%%/html/figs/snap2.jpg
-%%DOCSDIR%%/html/figs/snap3.jpg
+%%DOCSDIR%%/html/figs/snap13.jpg
+%%DOCSDIR%%/html/figs/snap14.jpg
%%DOCSDIR%%/html/figs/snap4.jpg
-%%DOCSDIR%%/html/figs/snap5.jpg
%%DOCSDIR%%/html/figs/snap6.jpg
-%%DOCSDIR%%/html/figs/snap7.jpg
-%%DOCSDIR%%/html/figs/snap7a.jpg
-%%DOCSDIR%%/html/figs/snap8.jpg
-%%DOCSDIR%%/html/figs/snap9.jpg
%%DOCSDIR%%/html/figs/toolkit.jpg
-%%DOCSDIR%%/html/figs/toolkit2.jpg
+%%DOCSDIR%%/html/figs/snap15.jpg
+%%DOCSDIR%%/html/figs/ir2.jpg
+%%DOCSDIR%%/html/figs/snap7.jpg
+%%DOCSDIR%%/html/figs/snap10.jpg
+%%DOCSDIR%%/html/figs/snap11.jpg
+%%DOCSDIR%%/html/figs/ir4.jpg
+%%DOCSDIR%%/html/figs/snap1.jpg
+%%DOCSDIR%%/html/figs/snap5.jpg
+%%DOCSDIR%%/html/figs/snap3.jpg
%%DOCSDIR%%/html/figs/toolkit3.jpg
-%%DOCSDIR%%/html/nipguide.css
-%%DOCSDIR%%/html/nipguide.html
-%%DOCSDIR%%/html/nipguide37.html
-%%DOCSDIR%%/html/nipguideap1.html
-%%DOCSDIR%%/html/nipguidech1.html
-%%DOCSDIR%%/html/nipguidech2.html
-%%DOCSDIR%%/html/nipguidech3.html
-%%DOCSDIR%%/html/nipguidech4.html
+%%DOCSDIR%%/html/figs/snap8.jpg
+%%DOCSDIR%%/html/nipguidese33.html
+%%DOCSDIR%%/html/nipguidese24.html
+%%DOCSDIR%%/html/nipguidese21.html
%%DOCSDIR%%/html/nipguidech5.html
+%%DOCSDIR%%/html/nipguidese31.html
%%DOCSDIR%%/html/nipguidech6.html
-%%DOCSDIR%%/html/nipguideli1.html
+%%DOCSDIR%%/html/nipguidese4.html
%%DOCSDIR%%/html/nipguideli2.html
-%%DOCSDIR%%/html/nipguideli3.html
-%%DOCSDIR%%/html/nipguidese1.html
-%%DOCSDIR%%/html/nipguidese10.html
-%%DOCSDIR%%/html/nipguidese11.html
-%%DOCSDIR%%/html/nipguidese12.html
-%%DOCSDIR%%/html/nipguidese13.html
-%%DOCSDIR%%/html/nipguidese14.html
-%%DOCSDIR%%/html/nipguidese15.html
-%%DOCSDIR%%/html/nipguidese16.html
-%%DOCSDIR%%/html/nipguidese17.html
-%%DOCSDIR%%/html/nipguidese18.html
-%%DOCSDIR%%/html/nipguidese19.html
+%%DOCSDIR%%/html/nipguidese8.html
%%DOCSDIR%%/html/nipguidese2.html
%%DOCSDIR%%/html/nipguidese20.html
-%%DOCSDIR%%/html/nipguidese21.html
-%%DOCSDIR%%/html/nipguidese22.html
-%%DOCSDIR%%/html/nipguidese23.html
-%%DOCSDIR%%/html/nipguidese24.html
+%%DOCSDIR%%/html/nipguidese6.html
+%%DOCSDIR%%/html/nipguidese16.html
+%%DOCSDIR%%/html/nipguide37.html
+%%DOCSDIR%%/html/nipguidese18.html
+%%DOCSDIR%%/html/nipguidese30.html
+%%DOCSDIR%%/html/nipguidese34.html
+%%DOCSDIR%%/html/nipguidese29.html
+%%DOCSDIR%%/html/nipguide.html
+%%DOCSDIR%%/html/nipguidech1.html
+%%DOCSDIR%%/html/nipguideli1.html
+%%DOCSDIR%%/html/nipguidese11.html
%%DOCSDIR%%/html/nipguidese25.html
+%%DOCSDIR%%/html/nipguide.css
+%%DOCSDIR%%/html/nipguidese9.html
+%%DOCSDIR%%/html/nipguidese3.html
+%%DOCSDIR%%/html/nipguidese22.html
+%%DOCSDIR%%/html/nipguidese15.html
%%DOCSDIR%%/html/nipguidese26.html
+%%DOCSDIR%%/html/nipguidese23.html
%%DOCSDIR%%/html/nipguidese27.html
+%%DOCSDIR%%/html/nipguideap1.html
+%%DOCSDIR%%/html/nipguidese1.html
+%%DOCSDIR%%/html/nipguidese5.html
+%%DOCSDIR%%/html/nipguidese12.html
%%DOCSDIR%%/html/nipguidese28.html
-%%DOCSDIR%%/html/nipguidese29.html
-%%DOCSDIR%%/html/nipguidese3.html
-%%DOCSDIR%%/html/nipguidese30.html
-%%DOCSDIR%%/html/nipguidese31.html
-%%DOCSDIR%%/html/nipguidese32.html
-%%DOCSDIR%%/html/nipguidese33.html
-%%DOCSDIR%%/html/nipguidese34.html
-%%DOCSDIR%%/html/nipguidese35.html
+%%DOCSDIR%%/html/nipguidese17.html
+%%DOCSDIR%%/html/nipguidech3.html
%%DOCSDIR%%/html/nipguidese36.html
-%%DOCSDIR%%/html/nipguidese4.html
-%%DOCSDIR%%/html/nipguidese5.html
-%%DOCSDIR%%/html/nipguidese6.html
+%%DOCSDIR%%/html/nipguideli3.html
%%DOCSDIR%%/html/nipguidese7.html
-%%DOCSDIR%%/html/nipguidese8.html
-%%DOCSDIR%%/html/nipguidese9.html
+%%DOCSDIR%%/html/nipguidese19.html
+%%DOCSDIR%%/html/nipguidech4.html
+%%DOCSDIR%%/html/nipguidese32.html
+%%DOCSDIR%%/html/nipguidese13.html
+%%DOCSDIR%%/html/nipguidech2.html
+%%DOCSDIR%%/html/nipguidese10.html
+%%DOCSDIR%%/html/nipguidese14.html
+%%DOCSDIR%%/html/nipguidese35.html
%%PORTDOCS%%%%DOCSDIR%%/pdf/nipguide.pdf
%%PORTDOCS%%@dirrm %%DOCSDIR%%/pdf
@dirrm %%DOCSDIR%%/html/figs