aboutsummaryrefslogtreecommitdiff
path: root/graphics/ocaml-images/files
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-03-26 17:54:08 +0000
committerJohn Marino <marino@FreeBSD.org>2014-03-26 17:54:08 +0000
commit1c990c8f51eb9079e70f72915985b483f32b1ac3 (patch)
tree63045e9db09ad770e4edd11c63887152cbc4d13f /graphics/ocaml-images/files
parent130be520d3198b942b7bd6da4f125da0c37d1689 (diff)
downloadports-1c990c8f51eb9079e70f72915985b483f32b1ac3.tar.gz
ports-1c990c8f51eb9079e70f72915985b483f32b1ac3.zip
Notes
Diffstat (limited to 'graphics/ocaml-images/files')
-rw-r--r--graphics/ocaml-images/files/patch-OMakefile20
-rw-r--r--graphics/ocaml-images/files/patch-configure.ac10
-rw-r--r--graphics/ocaml-images/files/patch-src_OMakefile15
-rw-r--r--graphics/ocaml-images/files/patch-src_gifread.c10
-rw-r--r--graphics/ocaml-images/files/patch-src_gifwrite.c12
-rw-r--r--graphics/ocaml-images/files/patch-src_jpegread.c11
-rw-r--r--graphics/ocaml-images/files/patch-src_tiffread.c21
-rw-r--r--graphics/ocaml-images/files/patch-src_tiffwrite.c16
8 files changed, 89 insertions, 26 deletions
diff --git a/graphics/ocaml-images/files/patch-OMakefile b/graphics/ocaml-images/files/patch-OMakefile
new file mode 100644
index 000000000000..469d16c417d5
--- /dev/null
+++ b/graphics/ocaml-images/files/patch-OMakefile
@@ -0,0 +1,20 @@
+--- OMakefile.orig 2012-11-07 22:03:19.000000000 +0100
++++ OMakefile 2012-11-07 22:04:26.000000000 +0100
+@@ -22,13 +22,13 @@
+
+ # Specify non standard include directories
+ INCLUDES[]=
+- /usr/include/X11
+- /usr/local/include
++ %%INCLUDESPORTS%%
++ %%INCLUDESX11%%
++ %%INCLUDESPNG%%
+
+ # Specify non standard library directories
+ LDFLAGS[]+=
+-# for example,
+-# LDFLAGS[]+= -L/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/
++ %%LDFLAGSPORTS%%
+
+ # Specify directories where X's rgb.txt can be found
+ PATH_RGB_TXT[]=
diff --git a/graphics/ocaml-images/files/patch-configure.ac b/graphics/ocaml-images/files/patch-configure.ac
deleted file mode 100644
index a3e65e951247..000000000000
--- a/graphics/ocaml-images/files/patch-configure.ac
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.ac.orig 2010-03-26 01:15:49.000000000 -0700
-+++ configure.ac 2010-03-26 01:15:52.000000000 -0700
-@@ -5,7 +5,6 @@
-
- # Check ocaml
- AC_PROG_OCAML([3.08])
--AC_PROG_OCAML_TOOL(OCAMLMKLIB, ocamlmklib)
- AC_SUBST(OCAMLLIB)
-
- # Check versions to build
diff --git a/graphics/ocaml-images/files/patch-src_OMakefile b/graphics/ocaml-images/files/patch-src_OMakefile
new file mode 100644
index 000000000000..c6d85cfd4037
--- /dev/null
+++ b/graphics/ocaml-images/files/patch-src_OMakefile
@@ -0,0 +1,15 @@
+--- src/OMakefile.orig 2012-11-07 22:43:27.000000000 +0100
++++ src/OMakefile 2012-11-07 22:44:22.000000000 +0100
+@@ -262,10 +262,10 @@
+ $(glob i, *.so)
+
+ INSTALL()=
+- value $(OCAMLFIND) install $(LIBRARY_PREFIX) $(INSTALL_TARGETS)
++ value $(OCAMLFIND) install -ldconf ignore -destdir $(PREFIX)/lib/ocaml/site-lib $(LIBRARY_PREFIX) $(INSTALL_TARGETS)
+
+ UNINSTALL()=
+- value $(OCAMLFIND) remove $(LIBRARY_PREFIX)
++ value $(OCAMLFIND) remove -ldconf ignore -destdir $(PREFIX)/lib/ocaml/site-lib $(LIBRARY_PREFIX)
+
+ install: all
+ $(INSTALL)
diff --git a/graphics/ocaml-images/files/patch-src_gifread.c b/graphics/ocaml-images/files/patch-src_gifread.c
new file mode 100644
index 000000000000..360520019081
--- /dev/null
+++ b/graphics/ocaml-images/files/patch-src_gifread.c
@@ -0,0 +1,10 @@
+--- src/gifread.c.orig 2012-11-07 22:33:55.000000000 +0100
++++ src/gifread.c 2012-11-07 22:34:04.000000000 +0100
+@@ -200,7 +200,6 @@
+
+ if( DGifGetLine(GifFile, String_val(buf), GifFile->Image.Width )
+ == GIF_ERROR ){
+- PrintGifError ();
+ failwith("DGifGetLine");
+ }
+ CAMLreturn(buf);
diff --git a/graphics/ocaml-images/files/patch-src_gifwrite.c b/graphics/ocaml-images/files/patch-src_gifwrite.c
index 301d3821631f..15c2acb36171 100644
--- a/graphics/ocaml-images/files/patch-src_gifwrite.c
+++ b/graphics/ocaml-images/files/patch-src_gifwrite.c
@@ -1,5 +1,5 @@
---- ./src/gifwrite.c.orig 2010-04-09 03:01:01.000000000 -0700
-+++ ./src/gifwrite.c 2010-04-09 03:01:08.000000000 -0700
+--- src/gifwrite.c.orig 2011-06-22 20:04:32.000000000 +0200
++++ src/gifwrite.c 2012-11-07 22:32:25.000000000 +0100
@@ -25,7 +25,7 @@
#include <gif_lib.h>
@@ -9,3 +9,11 @@
{
CAMLparam1(list);
CAMLlocal1(l);
+@@ -133,7 +133,6 @@
+
+ if ( EGifPutLine(GifFileOut, String_val(buf), GifFileOut->Image.Width)
+ == GIF_ERROR ){
+- PrintGifError ();
+ failwith("EGifPutLine");
+ }
+ CAMLreturn(Val_unit);
diff --git a/graphics/ocaml-images/files/patch-src_jpegread.c b/graphics/ocaml-images/files/patch-src_jpegread.c
new file mode 100644
index 000000000000..4369ab05fd9d
--- /dev/null
+++ b/graphics/ocaml-images/files/patch-src_jpegread.c
@@ -0,0 +1,11 @@
+--- src/jpegread.c.orig 2011-06-22 20:04:32.000000000 +0200
++++ src/jpegread.c
+@@ -417,7 +417,7 @@
+ jpeg_read_scanlines( cinfop, row, 1 );
+ row[0] += scanline_bytes;
+ }
+- CAMLreturn0;
++ CAMLreturn(0);
+ }
+
+ value close_jpeg_file_for_read( jpegh )
diff --git a/graphics/ocaml-images/files/patch-src_tiffread.c b/graphics/ocaml-images/files/patch-src_tiffread.c
index 86b46390bb7a..73b684a3408e 100644
--- a/graphics/ocaml-images/files/patch-src_tiffread.c
+++ b/graphics/ocaml-images/files/patch-src_tiffread.c
@@ -1,11 +1,12 @@
---- src/tiffread.c.orig 2009-10-26 13:42:03.000000000 +0100
-+++ src/tiffread.c 2010-08-28 10:47:42.000000000 +0200
-@@ -20,15 +20,21 @@
- #include <caml/alloc.h>
- #include <caml/memory.h>
- #include <caml/fail.h>
-+#include "oversized.h"
+--- src/tiffread.c.orig 2011-06-22 20:04:32.000000000 +0200
++++ src/tiffread.c
+@@ -23,14 +23,22 @@
+ #include "oversized.h"
+
++/* Avoid redefinitions */
++#undef int16
++#undef uint16
/* These are defined in caml/config.h */
#define int16 int16tiff
#define uint16 uint16tiff
@@ -22,9 +23,9 @@
extern value *imglib_error;
value open_tiff_file_for_read( name )
-@@ -64,6 +70,10 @@
- TIFFGetField(tif, TIFFTAG_YRESOLUTION, &yres);
- TIFFGetField(tif, TIFFTAG_PHOTOMETRIC, &photometric);
+@@ -70,6 +78,10 @@
+ failwith_oversized("tiff");
+ }
+ if (oversized (imagewidth, imagelength)) {
+ failwith_oversized("tiff");
diff --git a/graphics/ocaml-images/files/patch-src_tiffwrite.c b/graphics/ocaml-images/files/patch-src_tiffwrite.c
index 3462835c81de..2e50b0b217b6 100644
--- a/graphics/ocaml-images/files/patch-src_tiffwrite.c
+++ b/graphics/ocaml-images/files/patch-src_tiffwrite.c
@@ -1,6 +1,14 @@
---- src/tiffwrite.c.orig 2009-10-26 13:42:03.000000000 +0100
-+++ src/tiffwrite.c 2010-08-28 10:46:35.000000000 +0200
-@@ -25,6 +25,8 @@
+--- src/tiffwrite.c.orig 2011-06-22 20:04:32.000000000 +0200
++++ src/tiffwrite.c
+@@ -20,11 +20,16 @@
+ #include <caml/memory.h>
+ #include <caml/fail.h>
+
++/* Avoid redefinitions */
++#undef int16
++#undef uint16
+ /* These are defined in caml/config.h */
+ #define int16 int16tiff
#define uint16 uint16tiff
#define int32 int32tiff
#define uint32 uint32tiff
@@ -9,7 +17,7 @@
#include <tiffio.h>
-@@ -32,6 +34,8 @@
+@@ -32,6 +37,8 @@
#undef uint16
#undef int32
#undef uint32