aboutsummaryrefslogtreecommitdiff
path: root/graphics/ocrad/Makefile
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2006-05-10 17:42:50 +0000
committerVolker Stolz <vs@FreeBSD.org>2006-05-10 17:42:50 +0000
commit70e264d25f8a926278836d2eb0c4bd1837be9530 (patch)
tree9fc1f18488e20db383a8c3c55e1b2b4a19061324 /graphics/ocrad/Makefile
parentd057202dee849a0747156175ecbbf64a31258ae7 (diff)
downloadports-70e264d25f8a926278836d2eb0c4bd1837be9530.tar.gz
ports-70e264d25f8a926278836d2eb0c4bd1837be9530.zip
Notes
Diffstat (limited to 'graphics/ocrad/Makefile')
-rw-r--r--graphics/ocrad/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/graphics/ocrad/Makefile b/graphics/ocrad/Makefile
index afac46608f9e..9a3f541c8431 100644
--- a/graphics/ocrad/Makefile
+++ b/graphics/ocrad/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ocrad
-PORTVERSION= 0.13
+PORTVERSION= 0.14
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -27,7 +27,12 @@ MAKE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
.if ${OSVERSION} < 500035
USE_GCC= 3.4
+post-patch:
+. for f in main.cc rational.cc
+ @${REINPLACE_CMD} 's/std::snprintf/snprintf/g' ${WRKSRC}/$f
+. endfor
.endif
+
.if ${OSVERSION} < 500041
MAKE_ENV+= CPPFLAGS="${CPPFLAGS} -DHAVE_DECL_GETOPT"
.endif