aboutsummaryrefslogtreecommitdiff
path: root/graphics/ocrfeeder/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2011-09-30 20:40:58 +0000
committerPawel Pekala <pawel@FreeBSD.org>2011-09-30 20:40:58 +0000
commita5aabc0a3d60df866c22e70bf27dc391b8b6dba3 (patch)
tree80ba0fabc2d5fb01695f0459dc2dce4aa00a9137 /graphics/ocrfeeder/Makefile
parent746d51c0d4ea2447e242f3f14ccad79dcc83ac41 (diff)
downloadports-a5aabc0a3d60df866c22e70bf27dc391b8b6dba3.tar.gz
ports-a5aabc0a3d60df866c22e70bf27dc391b8b6dba3.zip
Notes
Diffstat (limited to 'graphics/ocrfeeder/Makefile')
-rw-r--r--graphics/ocrfeeder/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/graphics/ocrfeeder/Makefile b/graphics/ocrfeeder/Makefile
new file mode 100644
index 000000000000..eac2d855f88e
--- /dev/null
+++ b/graphics/ocrfeeder/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: ocrfeeder
+# Date created: 5 August 2011
+# Whom: buganini@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= ocrfeeder
+PORTVERSION= 0.7.6
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR=sources/ocrfeeder/0.7
+
+MAINTAINER= buganini@gmail.com
+COMMENT= Document layout analysis and optical character recognition
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}enchant>=0:${PORTSDIR}/textproc/py-enchant \
+ ${PYTHON_PKGNAMEPREFIX}imaging>=0:${PORTSDIR}/graphics/py-imaging \
+ ${PYTHON_PKGNAMEPREFIX}sane>=0:${PORTSDIR}/graphics/py-sane \
+ ${PYTHON_PKGNAMEPREFIX}reportlab2>=0:${PORTSDIR}/print/py-reportlab2 \
+ ${PYTHON_PKGNAMEPREFIX}goocanvas>=0:${PORTSDIR}/graphics/py-goocanvas
+RUN_DEPENDS:= ${BUILD_DEPENDS} \
+ unpaper:${PORTSDIR}/graphics/unpaper
+
+MAN1= ocrfeeder-cli.1 ocrfeeder.1
+
+USE_XZ= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_PYTHON= yes
+USE_GNOME= pygtk2 pygnomeextras
+USE_GETTEXT= yes
+USE_GHOSTSCRIPT=yes
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>