aboutsummaryrefslogtreecommitdiff
path: root/graphics/okular-devel
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2024-01-22 21:42:11 +0000
committerDima Panov <fluffy@FreeBSD.org>2024-01-22 21:42:57 +0000
commit8aae4a6fb2fdd850d67287952d9fe2b83477aca1 (patch)
treed190d85ce5bc1e0faf4356b3f977dbd119d60592 /graphics/okular-devel
parent132a60dbd532d75019823e2084f623b1117a62bb (diff)
downloadports-8aae4a6fb2fdd850d67287952d9fe2b83477aca1.tar.gz
ports-8aae4a6fb2fdd850d67287952d9fe2b83477aca1.zip
Diffstat (limited to 'graphics/okular-devel')
-rw-r--r--graphics/okular-devel/Makefile31
-rw-r--r--graphics/okular-devel/pkg-plist85
2 files changed, 51 insertions, 65 deletions
diff --git a/graphics/okular-devel/Makefile b/graphics/okular-devel/Makefile
index f804ef41e384..2b7f760992d8 100644
--- a/graphics/okular-devel/Makefile
+++ b/graphics/okular-devel/Makefile
@@ -15,25 +15,26 @@ LIB_DEPENDS= libchm.so:misc/chmlib \
libdjvulibre.so:graphics/djvulibre \
libepub.so:textproc/ebook-tools \
libfreetype.so:print/freetype2 \
- libqmobipocket.so:graphics/kdegraphics-mobipocket \
+ libKExiv2Qt6.so:graphics/libkexiv2-devel \
libpoppler.so:graphics/poppler \
- libpoppler-qt5.so:graphics/poppler-qt5 \
+ libpoppler-qt6.so:graphics/poppler-qt6 \
libspectre.so:print/libspectre \
libtiff.so:graphics/tiff \
- libzip.so:archivers/libzip
+ libzip.so:archivers/libzip \
+ libxkbcommon.so:x11/libxkbcommon
+# libQMobipocket6.so:graphics/kdegraphics-mobipocket@qt6 \
-USES= cmake compiler:c++11-lib desktop-file-utils \
- gettext jpeg kde:5 cpe pkgconfig qca qt:5 tar:xz xorg
-USE_KDE= activities archive auth bookmarks codecs completion config \
- configwidgets coreaddons crash dbusaddons emoticons i18n \
- iconthemes init itemmodels itemviews jobwidgets js \
- kdelibs4support khtml kio libkexiv2 parts phonon pty \
- service solid sonnet textwidgets threadweaver wallet \
- widgetsaddons windowsystem xmlgui \
+USES= cmake compiler:c++11-lib cpe desktop-file-utils \
+ gettext gl jpeg \
+ kde:6 pkgconfig qca qt:6 tar:xz xorg
+USE_GL= gl opengl
+USE_KDE= activities archive auth bookmarks codecs colorscheme \
+ completion config configwidgets coreaddons crash i18n \
+ iconthemes itemmodels itemviews jobwidgets kio parts \
+ phonon pty service solid sonnet textwidgets threadweaver \
+ wallet widgetsaddons windowsystem xmlgui \
ecm:build
-USE_QT= concurrent core dbus declarative gui network printsupport speech \
- svg widgets xml \
- buildtools:build qmake:build testlib:build
+USE_QT= base declarative multimedia speech svg
USE_XORG= x11
OPTIONS_DEFINE= DOCS PURPOSE
@@ -41,6 +42,6 @@ OPTIONS_DEFAULT= PURPOSE
PURPOSE_DESC= Enable 'Share' menu
PURPOSE_USE= KDE=purpose
-PURPOSE_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_KF5Purpose
+PURPOSE_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_KF6Purpose
.include <bsd.port.mk>
diff --git a/graphics/okular-devel/pkg-plist b/graphics/okular-devel/pkg-plist
index e8fb06089b12..2fc9971ab618 100644
--- a/graphics/okular-devel/pkg-plist
+++ b/graphics/okular-devel/pkg-plist
@@ -29,31 +29,30 @@ include/okular/interfaces/guiinterface.h
include/okular/interfaces/printinterface.h
include/okular/interfaces/saveinterface.h
include/okular/interfaces/viewerinterface.h
-lib/cmake/Okular5/Okular5Config.cmake
-lib/cmake/Okular5/Okular5ConfigVersion.cmake
-lib/cmake/Okular5/Okular5Targets-%%CMAKE_BUILD_TYPE%%.cmake
-lib/cmake/Okular5/Okular5Targets.cmake
-lib/libOkular5Core.so
-lib/libOkular5Core.so.11
-lib/libOkular5Core.so.11.0.0
-%%QT_PLUGINDIR%%/kf5/kio/kio_msits.so
-%%QT_PLUGINDIR%%/okular/generators/okularGenerator_chmlib.so
-%%QT_PLUGINDIR%%/okular/generators/okularGenerator_comicbook.so
-%%QT_PLUGINDIR%%/okular/generators/okularGenerator_djvu.so
-%%QT_PLUGINDIR%%/okular/generators/okularGenerator_dvi.so
-%%QT_PLUGINDIR%%/okular/generators/okularGenerator_epub.so
-%%QT_PLUGINDIR%%/okular/generators/okularGenerator_fax.so
-%%QT_PLUGINDIR%%/okular/generators/okularGenerator_fb.so
-%%QT_PLUGINDIR%%/okular/generators/okularGenerator_ghostview.so
-%%QT_PLUGINDIR%%/okular/generators/okularGenerator_kimgio.so
-%%QT_PLUGINDIR%%/okular/generators/okularGenerator_md.so
-%%QT_PLUGINDIR%%/okular/generators/okularGenerator_mobi.so
-%%QT_PLUGINDIR%%/okular/generators/okularGenerator_plucker.so
-%%QT_PLUGINDIR%%/okular/generators/okularGenerator_poppler.so
-%%QT_PLUGINDIR%%/okular/generators/okularGenerator_tiff.so
-%%QT_PLUGINDIR%%/okular/generators/okularGenerator_txt.so
-%%QT_PLUGINDIR%%/okular/generators/okularGenerator_xps.so
-%%QT_PLUGINDIR%%/okularpart.so
+lib/cmake/Okular6/Okular6Config.cmake
+lib/cmake/Okular6/Okular6ConfigVersion.cmake
+lib/cmake/Okular6/Okular6Targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/Okular6/Okular6Targets.cmake
+lib/libOkular6Core.so
+lib/libOkular6Core.so.11
+lib/libOkular6Core.so.11.0.0
+%%QT_PLUGINDIR%%/kf6/parts/okularpart.so
+@comment %%QT_PLUGINDIR%%/okular_generators/okularGenerator_chmlib.so
+%%QT_PLUGINDIR%%/okular_generators/okularGenerator_comicbook.so
+%%QT_PLUGINDIR%%/okular_generators/okularGenerator_djvu.so
+%%QT_PLUGINDIR%%/okular_generators/okularGenerator_dvi.so
+%%QT_PLUGINDIR%%/okular_generators/okularGenerator_epub.so
+%%QT_PLUGINDIR%%/okular_generators/okularGenerator_fax.so
+%%QT_PLUGINDIR%%/okular_generators/okularGenerator_fb.so
+%%QT_PLUGINDIR%%/okular_generators/okularGenerator_ghostview.so
+%%QT_PLUGINDIR%%/okular_generators/okularGenerator_kimgio.so
+%%QT_PLUGINDIR%%/okular_generators/okularGenerator_md.so
+@comment %%QT_PLUGINDIR%%/okular_generators/okularGenerator_mobi.so
+%%QT_PLUGINDIR%%/okular_generators/okularGenerator_plucker.so
+%%QT_PLUGINDIR%%/okular_generators/okularGenerator_poppler.so
+%%QT_PLUGINDIR%%/okular_generators/okularGenerator_tiff.so
+%%QT_PLUGINDIR%%/okular_generators/okularGenerator_txt.so
+%%QT_PLUGINDIR%%/okular_generators/okularGenerator_xps.so
man/ca/man1/okular.1.gz
man/de/man1/okular.1.gz
man/es/man1/okular.1.gz
@@ -68,7 +67,7 @@ man/ru/man1/okular.1.gz
man/sv/man1/okular.1.gz
man/tr/man1/okular.1.gz
man/uk/man1/okular.1.gz
-share/applications/okularApplication_chm.desktop
+@comment share/applications/okularApplication_chm.desktop
share/applications/okularApplication_comicbook.desktop
share/applications/okularApplication_djvu.desktop
share/applications/okularApplication_dvi.desktop
@@ -78,13 +77,13 @@ share/applications/okularApplication_fb.desktop
share/applications/okularApplication_ghostview.desktop
share/applications/okularApplication_kimgio.desktop
share/applications/okularApplication_md.desktop
-share/applications/okularApplication_mobi.desktop
+@comment share/applications/okularApplication_mobi.desktop
share/applications/okularApplication_pdf.desktop
share/applications/okularApplication_plucker.desktop
share/applications/okularApplication_tiff.desktop
share/applications/okularApplication_txt.desktop
share/applications/okularApplication_xps.desktop
-share/applications/org.kde.mobile.okular_chm.desktop
+@comment share/applications/org.kde.mobile.okular_chm.desktop
share/applications/org.kde.mobile.okular_comicbook.desktop
share/applications/org.kde.mobile.okular_djvu.desktop
share/applications/org.kde.mobile.okular_dvi.desktop
@@ -94,7 +93,7 @@ share/applications/org.kde.mobile.okular_fb.desktop
share/applications/org.kde.mobile.okular_ghostview.desktop
share/applications/org.kde.mobile.okular_kimgio.desktop
share/applications/org.kde.mobile.okular_md.desktop
-share/applications/org.kde.mobile.okular_mobi.desktop
+@comment share/applications/org.kde.mobile.okular_mobi.desktop
share/applications/org.kde.mobile.okular_pdf.desktop
share/applications/org.kde.mobile.okular_plucker.desktop
share/applications/org.kde.mobile.okular_tiff.desktop
@@ -112,24 +111,6 @@ share/icons/hicolor/32x32/apps/okular.png
share/icons/hicolor/48x48/apps/okular.png
share/icons/hicolor/64x64/apps/okular.png
share/kconf_update/okular.upd
-share/kservices5/okularChm.desktop
-share/kservices5/okularComicbook.desktop
-share/kservices5/okularDjvu.desktop
-share/kservices5/okularDvi.desktop
-share/kservices5/okularEPub.desktop
-share/kservices5/okularFax.desktop
-share/kservices5/okularFb.desktop
-share/kservices5/okularGhostview.desktop
-share/kservices5/okularKimgio.desktop
-share/kservices5/okularMd.desktop
-share/kservices5/okularMobi.desktop
-share/kservices5/okularPlucker.desktop
-share/kservices5/okularPoppler.desktop
-share/kservices5/okularTiff.desktop
-share/kservices5/okularTxt.desktop
-share/kservices5/okularXps.desktop
-share/kservices5/okular_part.desktop
-share/kservicetypes5/okularGenerator.desktop
share/locale/ar/LC_MESSAGES/okular.mo
share/locale/ar/LC_MESSAGES/okular_chm.mo
share/locale/ar/LC_MESSAGES/okular_comicbook.mo
@@ -738,10 +719,14 @@ share/locale/lv/LC_MESSAGES/okular_fax.mo
share/locale/lv/LC_MESSAGES/okular_fictionbook.mo
share/locale/lv/LC_MESSAGES/okular_ghostview.mo
share/locale/lv/LC_MESSAGES/okular_kimgio.mo
+share/locale/lv/LC_MESSAGES/okular_markdown.mo
share/locale/lv/LC_MESSAGES/okular_mobi.mo
share/locale/lv/LC_MESSAGES/okular_plucker.mo
share/locale/lv/LC_MESSAGES/okular_poppler.mo
+share/locale/lv/LC_MESSAGES/okular_tiff.mo
+share/locale/lv/LC_MESSAGES/okular_txt.mo
share/locale/lv/LC_MESSAGES/okular_xps.mo
+share/locale/lv/LC_MESSAGES/org.kde.active.documentviewer.mo
share/locale/mk/LC_MESSAGES/okular.mo
share/locale/mk/LC_MESSAGES/okular_chm.mo
share/locale/mk/LC_MESSAGES/okular_djvu.mo
@@ -1274,7 +1259,7 @@ share/locale/zh_TW/LC_MESSAGES/okular_tiff.mo
share/locale/zh_TW/LC_MESSAGES/okular_txt.mo
share/locale/zh_TW/LC_MESSAGES/okular_xps.mo
share/locale/zh_TW/LC_MESSAGES/org.kde.active.documentviewer.mo
-share/metainfo/org.kde.okular-chm.metainfo.xml
+@comment share/metainfo/org.kde.okular-chm.metainfo.xml
share/metainfo/org.kde.okular-comicbook.metainfo.xml
share/metainfo/org.kde.okular-djvu.metainfo.xml
share/metainfo/org.kde.okular-dvi.metainfo.xml
@@ -1283,7 +1268,7 @@ share/metainfo/org.kde.okular-fax.metainfo.xml
share/metainfo/org.kde.okular-fb.metainfo.xml
share/metainfo/org.kde.okular-kimgio.metainfo.xml
share/metainfo/org.kde.okular-md.metainfo.xml
-share/metainfo/org.kde.okular-mobipocket.metainfo.xml
+@comment share/metainfo/org.kde.okular-mobipocket.metainfo.xml
share/metainfo/org.kde.okular-plucker.metainfo.xml
share/metainfo/org.kde.okular-poppler.metainfo.xml
share/metainfo/org.kde.okular-spectre.metainfo.xml
@@ -1333,4 +1318,4 @@ share/metainfo/org.kde.okular.appdata.xml
%%DATADIR%%/pics/upleftarrow.png
%%DATADIR%%/tools.xml
%%DATADIR%%/toolsQuick.xml
-share/qlogging-categories5/okular.categories
+share/qlogging-categories6/okular.categories