aboutsummaryrefslogtreecommitdiff
path: root/graphics/opencollada
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2018-05-19 06:54:14 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2018-05-19 06:54:14 +0000
commitf18183c88c9be06954680bada6d7b29e87f24dc3 (patch)
tree4160b133e6cad9d1733466800e2c8c9aff51e249 /graphics/opencollada
parent4ca94984e804c84027c85714068578162bae217d (diff)
downloadports-f18183c88c9be06954680bada6d7b29e87f24dc3.tar.gz
ports-f18183c88c9be06954680bada6d7b29e87f24dc3.zip
Fix build with pcre 8.42
PR: 220613 Submitted by: adamw
Notes
Notes: svn path=/head/; revision=470358
Diffstat (limited to 'graphics/opencollada')
-rw-r--r--graphics/opencollada/Makefile3
-rw-r--r--graphics/opencollada/files/patch-COLLADABaseUtils_include_COLLADABUPcreCompiledPattern.h13
2 files changed, 15 insertions, 1 deletions
diff --git a/graphics/opencollada/Makefile b/graphics/opencollada/Makefile
index aee17ea1e592..43b15f99cca4 100644
--- a/graphics/opencollada/Makefile
+++ b/graphics/opencollada/Makefile
@@ -29,7 +29,8 @@ CMAKE_ARGS+= -DUSE_SHARED:BOOL=ON -DUSE_STATIC:BOOL=OFF
BROKEN_sparc64= cannot build: runaway process
# for files/patch-2d66943
-DOS2UNIX_FILES= COLLADABaseUtils/src/COLLADABUURI.cpp
+DOS2UNIX_FILES= COLLADABaseUtils/include/COLLADABUPcreCompiledPattern.h \
+ COLLADABaseUtils/src/COLLADABUURI.cpp
post-patch:
@${REINPLACE_CMD} -e 's|$${OPENCOLLADA_INST_LIBRARY}/cmake|${PREFIX}/share/cmake/Modules|' \
diff --git a/graphics/opencollada/files/patch-COLLADABaseUtils_include_COLLADABUPcreCompiledPattern.h b/graphics/opencollada/files/patch-COLLADABaseUtils_include_COLLADABUPcreCompiledPattern.h
new file mode 100644
index 000000000000..6321170be864
--- /dev/null
+++ b/graphics/opencollada/files/patch-COLLADABaseUtils_include_COLLADABUPcreCompiledPattern.h
@@ -0,0 +1,13 @@
+--- COLLADABaseUtils/include/COLLADABUPcreCompiledPattern.h.orig 2018-03-26 12:11:34 UTC
++++ COLLADABaseUtils/include/COLLADABUPcreCompiledPattern.h
+@@ -13,8 +13,8 @@
+
+ #include "COLLADABUPrerequisites.h"
+
+-struct real_pcre;
+-typedef struct real_pcre pcre;
++struct real_pcre8_or_16;
++typedef struct real_pcre8_or_16 pcre;
+
+
+ namespace COLLADABU