aboutsummaryrefslogtreecommitdiff
path: root/graphics/opencolorio
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2018-12-08 12:57:37 +0000
committerKurt Jaeger <pi@FreeBSD.org>2018-12-08 12:57:37 +0000
commit08d3e82f908b5914d06ae9190dab09e074676d9a (patch)
tree3001609c7c4f801ead18270c589816109b65dedc /graphics/opencolorio
parent6974fa68e63782bde4a8f4faf5daf0f8ab590c4d (diff)
downloadports-08d3e82f908b5914d06ae9190dab09e074676d9a.tar.gz
ports-08d3e82f908b5914d06ae9190dab09e074676d9a.zip
graphics/opencolorio: update 1.0.9 -> 1.1.0
PR: 225941 Submitted by: Shane Ambler <FreeBSD@ShaneWare.Biz> (maintainer) Relnotes: http://opencolorio.org/ChangeLog.html
Notes
Notes: svn path=/head/; revision=486945
Diffstat (limited to 'graphics/opencolorio')
-rw-r--r--graphics/opencolorio/Makefile57
-rw-r--r--graphics/opencolorio/distinfo6
-rw-r--r--graphics/opencolorio/files/extra-patch-CMakeLists.txt10
-rw-r--r--graphics/opencolorio/files/libs/patch-CMakeLists.txt17
-rw-r--r--graphics/opencolorio/files/libs/patch-src_core_CMakeLists.txt (renamed from graphics/opencolorio/files/extra-patch-src_core_CMakeLists.txt)0
-rw-r--r--graphics/opencolorio/files/patch-CMakeLists.txt32
-rw-r--r--graphics/opencolorio/files/patch-share_sphinx_ExtractRstFromSourceCPP.py29
-rw-r--r--graphics/opencolorio/files/patch-src_core_Config.cpp11
-rw-r--r--graphics/opencolorio/files/tools/patch-CMakeLists.txt35
-rw-r--r--graphics/opencolorio/files/tools/patch-src_core_CMakeLists.txt (renamed from graphics/opencolorio/files/extra-tools-patch-src_core_CMakeLists.txt)12
-rw-r--r--graphics/opencolorio/pkg-plist11
11 files changed, 141 insertions, 79 deletions
diff --git a/graphics/opencolorio/Makefile b/graphics/opencolorio/Makefile
index 9dc6cf089fb5..2976051968ee 100644
--- a/graphics/opencolorio/Makefile
+++ b/graphics/opencolorio/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= opencolorio
-PORTVERSION= 1.0.9
-PORTREVISION?= 5
+PORTVERSION= 1.1.0
+DISTVERSIONPREFIX= v
CATEGORIES= graphics multimedia
MAINTAINER?= FreeBSD@Shaneware.biz
@@ -11,30 +11,31 @@ COMMENT?= Complete color management solution
LICENSE= BSD3CLAUSE
+USES= alias cmake:outsource compiler:c++11-lang pkgconfig shebangfix
+
USE_GITHUB= yes
GH_ACCOUNT= imageworks
GH_PROJECT= OpenColorIO
-GH_TAGNAME= 67e455b97e
-
-OPTIONS_DEFINE= DOCS
-
-DOCS_CMAKE_BOOL= OCIO_BUILD_DOCS
+CMAKE_ON= USE_EXTERNAL_TINYXML USE_EXTERNAL_YAML
+CMAKE_OFF= OCIO_BUILD_JNIGLUE OCIO_BUILD_NUKE OCIO_BUILD_STATIC
LDFLAGS+= -L${LOCALBASE}/lib
-USES= alias compiler:c++11-lang cmake:outsource pkgconfig shebangfix
-CMAKE_ARGS= -DOCIO_BUILD_JNIGLUE:BOOL=OFF \
- -DOCIO_BUILD_NUKE:BOOL=OFF \
- -DOCIO_BUILD_STATIC:BOOL=OFF \
- -DUSE_EXTERNAL_TINYXML:BOOL=ON \
- -DUSE_EXTERNAL_YAML:BOOL=ON
+# pyglue gives an error on use of register
+# this should only be an error using c++17
+CXXFLAGS+= -Wno-deprecated-register
+
SHEBANG_FILES= share/sphinx/ExtractRstFromSourceCPP.py \
share/sphinx/ExtractRstFromSourceSimple.py \
src/pyglue/createPyDocH.py
+OPTIONS_DEFINE= DOCS
+
+DOCS_CMAKE_BOOL= OCIO_BUILD_DOCS
+
.if ${MACHINE_CPU:Msse2}
-CMAKE_ARGS+= -DOCIO_USE_SSE:BOOL=ON
+CMAKE_ON+= OCIO_USE_SSE
.else
-CMAKE_ARGS+= -DOCIO_USE_SSE:BOOL=OFF
+CMAKE_OFF+= OCIO_USE_SSE
.endif
.include <bsd.port.options.mk>
@@ -43,23 +44,22 @@ CMAKE_ARGS+= -DOCIO_USE_SSE:BOOL=OFF
LIB_DEPENDS= liblcms2.so:graphics/lcms2 \
libOpenImageIO.so:graphics/openimageio \
libOpenColorIO.so:graphics/opencolorio
-CMAKE_ARGS+= -DOCIO_BUILD_APPS:BOOL=ON \
- -DOCIO_BUILD_SHARED:BOOL=OFF \
- -DOCIO_BUILD_PYGLUE:BOOL=OFF
+CMAKE_ON+= OCIO_BUILD_APPS USE_EXTERNAL_LCMS
+CMAKE_OFF+= OCIO_BUILD_SHARED OCIO_BUILD_PYGLUE
+LDFLAGS+= -lOpenColorIO
USE_GL= gl glu glut glew
USE_XORG= xi xmu
PLIST= ${PKGDIR}/pkg-plist-tools
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-CMakeLists.txt \
- ${FILESDIR}/extra-tools-patch-src_core_CMakeLists.txt
+EXTRA_PATCHES= ${PATCHDIR}/tools
.elif defined(OCIO_SLAVE) && ${OCIO_SLAVE} == pymodule
LIB_DEPENDS= libOpenImageIO.so:graphics/openimageio \
libOpenColorIO.so:graphics/opencolorio
USES+= python
USE_PYTHON= flavors
-CMAKE_ARGS+= -DOCIO_BUILD_APPS:BOOL=OFF \
- -DOCIO_BUILD_SHARED:BOOL=OFF \
- -DOCIO_BUILD_PYGLUE:BOOL=ON \
- -DPYTHON:STRING=${PYTHON_CMD}
+LDFLAGS+= -lOpenColorIO
+CMAKE_ON+= OCIO_BUILD_PYGLUE OCIO_PYGLUE_LINK
+CMAKE_OFF+= OCIO_BUILD_APPS OCIO_BUILD_SHARED
+CMAKE_ARGS+= -DPYTHON:FILEPATH=${PYTHON_CMD}
PLIST= ${PKGDIR}/pkg-plist-pyglue
.else # master port
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2@${PY_FLAVOR}
@@ -67,10 +67,9 @@ LIB_DEPENDS= libtinyxml.so:textproc/tinyxml \
libyaml-cpp03.so:devel/yaml-cpp03
USES+= python:2.7,build
USE_LDCONFIG= yes
-CMAKE_ARGS+= -DOCIO_BUILD_APPS:BOOL=OFF \
- -DOCIO_BUILD_SHARED:BOOL=ON \
- -DOCIO_BUILD_PYGLUE:BOOL=ON \
- -DPYTHON:FILEPATH=${PYTHON_CMD}
+CMAKE_ON+= OCIO_BUILD_SHARED OCIO_BUILD_PYGLUE
+CMAKE_OFF+= OCIO_BUILD_APPS
+CMAKE_ARGS+= -DPYTHON:FILEPATH=${PYTHON_CMD}
# we enable pyglue in master port. This makes the python module
# available when generating docs, we leave the python header in place
# but only install the python module with the py-opencolorio port
@@ -78,7 +77,7 @@ CMAKE_ARGS+= -DOCIO_BUILD_APPS:BOOL=OFF \
# doc building fails using python3 - but the py-opencolorio port can still
# be used to build a python 3 module
PLIST= ${PKGDIR}/pkg-plist
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-src_core_CMakeLists.txt
+EXTRA_PATCHES= ${PATCHDIR}/libs
.endif
post-patch:
diff --git a/graphics/opencolorio/distinfo b/graphics/opencolorio/distinfo
index 96ed7c988dac..38e5b57ed302 100644
--- a/graphics/opencolorio/distinfo
+++ b/graphics/opencolorio/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1474003473
-SHA256 (imageworks-OpenColorIO-1.0.9-67e455b97e_GH0.tar.gz) = cc932053f9b91c0f8549fe20bbb5d9ebc4c03e0638feac04b16a45dd73c37bc6
-SIZE (imageworks-OpenColorIO-1.0.9-67e455b97e_GH0.tar.gz) = 13744688
+TIMESTAMP = 1517541978
+SHA256 (imageworks-OpenColorIO-v1.1.0_GH0.tar.gz) = 228589879e1f11e455a555304007748a8904057088319ebbf172d9384b93c079
+SIZE (imageworks-OpenColorIO-v1.1.0_GH0.tar.gz) = 13826812
diff --git a/graphics/opencolorio/files/extra-patch-CMakeLists.txt b/graphics/opencolorio/files/extra-patch-CMakeLists.txt
deleted file mode 100644
index 12aba962839f..000000000000
--- a/graphics/opencolorio/files/extra-patch-CMakeLists.txt
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./CMakeLists.txt.orig 2012-10-07 21:57:35.533351894 +1030
-+++ ./CMakeLists.txt
-@@ -375,7 +375,6 @@
- configure_file(${CMAKE_SOURCE_DIR}/share/ocio/setup_ocio.sh.in
- ${CMAKE_CURRENT_BINARY_DIR}/share/ocio/setup_ocio.sh @ONLY)
-
--INSTALL(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/share/ocio/setup_ocio.sh DESTINATION share/ocio/)
-
- ###############################################################################
- ### CPACK ###
diff --git a/graphics/opencolorio/files/libs/patch-CMakeLists.txt b/graphics/opencolorio/files/libs/patch-CMakeLists.txt
new file mode 100644
index 000000000000..a7dba8317111
--- /dev/null
+++ b/graphics/opencolorio/files/libs/patch-CMakeLists.txt
@@ -0,0 +1,17 @@
+--- ./CMakeLists.txt.orig 2018-01-05 12:08:27 UTC
++++ ./CMakeLists.txt
+@@ -596,7 +599,7 @@ if(TARGET OpenColorIO_STATIC)
+ set(OCIO_STATIC_COMPILE_DEFINITIONS )
+ endif()
+ endif()
+-install(EXPORT OpenColorIO DESTINATION cmake)
++install(EXPORT OpenColorIO DESTINATION ${CMAKE_INSTALL_PREFIX}/share/cmake/Modules)
+ file(WRITE "${CMAKE_BINARY_DIR}/OpenColorIOConfig.cmake"
+ "
+ get_filename_component(OpenColorIO_DIR \"\${CMAKE_CURRENT_LIST_FILE}\" PATH)
+@@ -646,4 +649,4 @@ file(WRITE "${CMAKE_BINARY_DIR}/OpenColo
+ message(STATUS OPENCOLORIO_FOUND=\${OPENCOLORIO_FOUND})
+ "
+ )
+-install(FILES "${CMAKE_BINARY_DIR}/OpenColorIOConfig.cmake" DESTINATION .)
++install(FILES "${CMAKE_BINARY_DIR}/OpenColorIOConfig.cmake" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/cmake/Modules)
diff --git a/graphics/opencolorio/files/extra-patch-src_core_CMakeLists.txt b/graphics/opencolorio/files/libs/patch-src_core_CMakeLists.txt
index b598b621f1f4..b598b621f1f4 100644
--- a/graphics/opencolorio/files/extra-patch-src_core_CMakeLists.txt
+++ b/graphics/opencolorio/files/libs/patch-src_core_CMakeLists.txt
diff --git a/graphics/opencolorio/files/patch-CMakeLists.txt b/graphics/opencolorio/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..612d07718e4a
--- /dev/null
+++ b/graphics/opencolorio/files/patch-CMakeLists.txt
@@ -0,0 +1,32 @@
+--- CMakeLists.txt.orig 2018-01-05 12:08:27 UTC
++++ CMakeLists.txt
+@@ -3,6 +3,10 @@ set(OCIO_VERSION_MAJOR 1)
+ set(OCIO_VERSION_MINOR 1)
+ set(OCIO_VERSION_PATCH 0)
+
++set(CMAKE_CXX_STANDARD 11)
++set(CMAKE_CXX_STANDARD_REQUIRED ON)
++set(CMAKE_CXX_EXTENSIONS OFF)
++
+ cmake_minimum_required(VERSION 2.8)
+ set(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/share/cmake)
+ if(NOT DEFINED CMAKE_FIRST_RUN)
+@@ -218,8 +222,7 @@ else(USE_EXTERNAL_TINYXML)
+ ## => great news when build staticaly since we do not want another client project have to link also with tinyxml when he want to use this project
+ ## => could be problematic if the client project use another version of tinyxml... In this case build tinyxml as shared lib with all projects could be a solution
+ ## => TODO: so maybe provide a simple cmake way to build 3rdParty as shared and auto install with this project ?
+- set_target_properties(TINYXML_LIB PROPERTIES COMPILE_FLAGS "-DTIXML_USE_STL -fPIC -fvisibility-inlines-hidden -fvisibility=hidden")
+- add_definitions(-DTIXML_USE_STL) ## needed to build correctly, and also need to be propagated in child projects (client projects)
++ set_target_properties(TINYXML_LIB PROPERTIES COMPILE_FLAGS "-fPIC -fvisibility-inlines-hidden -fvisibility=hidden")
+ list(APPEND EXTERNAL_OBJECTS $<TARGET_OBJECTS:TINYXML_LIB>)
+ else()
+ find_package(Git REQUIRED) ## in order to apply patch (for crossplateform compatibility)
+@@ -384,7 +387,7 @@ else()
+ set(OCIO_INLINES_HIDDEN OFF)
+ endif()
+
+-set(EXTERNAL_COMPILE_FLAGS "-DTIXML_USE_STL ${YAML_CPP_COMPILE_FLAGS} ${GCC_COMPILE_FLAGS}")
++set(EXTERNAL_COMPILE_FLAGS "${YAML_CPP_COMPILE_FLAGS} ${GCC_COMPILE_FLAGS}")
+
+ set(EXTERNAL_LINK_FLAGS "")
+ set(EXTERNAL_LIBRARY_DIRS ${PROJECT_BINARY_DIR}/ext/dist/lib)
diff --git a/graphics/opencolorio/files/patch-share_sphinx_ExtractRstFromSourceCPP.py b/graphics/opencolorio/files/patch-share_sphinx_ExtractRstFromSourceCPP.py
deleted file mode 100644
index 197f38dc131c..000000000000
--- a/graphics/opencolorio/files/patch-share_sphinx_ExtractRstFromSourceCPP.py
+++ /dev/null
@@ -1,29 +0,0 @@
---- share/sphinx/ExtractRstFromSourceCPP.py.orig 2015-08-23 23:10:32 UTC
-+++ share/sphinx/ExtractRstFromSourceCPP.py
-@@ -146,7 +146,7 @@ class Comment:
-
- if buffer_lines[0] != '':
- buffer_lines.insert(0, '')
-- for x in xrange(0, len(buffer_lines)):
-+ for x in range(0, len(buffer_lines)):
- buffer_lines[x] = " %s" % buffer_lines[x]
- buffer_lines.append('')
- buffer = '\n'.join(buffer_lines)
-@@ -181,7 +181,7 @@ def ExtractRst(string, fileh):
- indent += 1
- # remove indent
- bufa = [buf_lines[0]]
-- for x in xrange(1, len(buf_lines)):
-+ for x in range(1, len(buf_lines)):
- bufa.append(buf_lines[x][indent:])
- buf = '\n'.join(bufa) + '\n'
- ##
-@@ -229,7 +229,7 @@ if __name__ == "__main__":
- sys.exit(1)
-
- src = open(sys.argv[1]).read()
-- output = file(sys.argv[2], 'w')
-+ output = open(sys.argv[2], 'w')
- ExtractRst(src, output)
- output.close()
-
diff --git a/graphics/opencolorio/files/patch-src_core_Config.cpp b/graphics/opencolorio/files/patch-src_core_Config.cpp
new file mode 100644
index 000000000000..bc5f727a585f
--- /dev/null
+++ b/graphics/opencolorio/files/patch-src_core_Config.cpp
@@ -0,0 +1,11 @@
+--- src/core/Config.cpp.orig 2018-09-04 18:15:21 UTC
++++ src/core/Config.cpp
+@@ -324,7 +324,7 @@ OCIO_NAMESPACE_ENTER
+ sanitytext_ = rhs.sanitytext_;
+
+ cacheids_ = rhs.cacheids_;
+- cacheidnocontext_ = cacheidnocontext_;
++ cacheidnocontext_ = rhs.cacheidnocontext_;
+ }
+ return *this;
+ }
diff --git a/graphics/opencolorio/files/tools/patch-CMakeLists.txt b/graphics/opencolorio/files/tools/patch-CMakeLists.txt
new file mode 100644
index 000000000000..eaeb072797a6
--- /dev/null
+++ b/graphics/opencolorio/files/tools/patch-CMakeLists.txt
@@ -0,0 +1,35 @@
+--- ./CMakeLists.txt.orig 2018-01-05 12:08:27 UTC
++++ ./CMakeLists.txt
+@@ -457,7 +460,7 @@ endif()
+ ###############################################################################
+ ### APPS ###
+
+-if(OCIO_BUILD_APPS AND (OCIO_BUILD_STATIC OR OCIO_BUILD_SHARED) )
++if(OCIO_BUILD_APPS)
+
+ # Try to find OpenImageIO (OIIO) and OpenGL stuff
+ OCIOFindOpenImageIO()
+@@ -531,7 +534,7 @@ endif()
+ configure_file(${CMAKE_SOURCE_DIR}/share/ocio/setup_ocio.sh.in
+ ${CMAKE_CURRENT_BINARY_DIR}/share/ocio/setup_ocio.sh @ONLY)
+
+-INSTALL(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/share/ocio/setup_ocio.sh DESTINATION share/ocio/)
++#INSTALL(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/share/ocio/setup_ocio.sh DESTINATION share/ocio/)
+
+ ###############################################################################
+ ### CPACK ###
+@@ -596,7 +595,7 @@ if(TARGET OpenColorIO_STATIC)
+ set(OCIO_STATIC_COMPILE_DEFINITIONS )
+ endif()
+ endif()
+-install(EXPORT OpenColorIO DESTINATION cmake)
++#install(EXPORT OpenColorIO DESTINATION cmake)
+ file(WRITE "${CMAKE_BINARY_DIR}/OpenColorIOConfig.cmake"
+ "
+ get_filename_component(OpenColorIO_DIR \"\${CMAKE_CURRENT_LIST_FILE}\" PATH)
+@@ -646,4 +649,4 @@ file(WRITE "${CMAKE_BINARY_DIR}/OpenColo
+ message(STATUS OPENCOLORIO_FOUND=\${OPENCOLORIO_FOUND})
+ "
+ )
+-install(FILES "${CMAKE_BINARY_DIR}/OpenColorIOConfig.cmake" DESTINATION .)
++#install(FILES "${CMAKE_BINARY_DIR}/OpenColorIOConfig.cmake" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/cmake/Modules)
diff --git a/graphics/opencolorio/files/extra-tools-patch-src_core_CMakeLists.txt b/graphics/opencolorio/files/tools/patch-src_core_CMakeLists.txt
index 447a1a187675..1845054ea11c 100644
--- a/graphics/opencolorio/files/extra-tools-patch-src_core_CMakeLists.txt
+++ b/graphics/opencolorio/files/tools/patch-src_core_CMakeLists.txt
@@ -1,9 +1,11 @@
---- src/core/CMakeLists.txt.orig 2014-09-12 04:38:18.000000000 +0930
+--- src/core/CMakeLists.txt.orig 2018-02-05 14:07:04 UTC
+++ src/core/CMakeLists.txt
-@@ -81,13 +81,3 @@ if(OCIO_BUILD_STATIC)
- install(TARGETS OpenColorIO_STATIC DESTINATION ${CMAKE_INSTALL_EXEC_PREFIX}/lib)
- endif()
-
+@@ -105,15 +105,3 @@ macro(target_link_OCIO target)
+ set_target_properties(${target} PROPERTIES COMPILE_DEFINITIONS OpenColorIO_STATIC)
+ endif()
+ endmacro()
+-
+-
-# public interface
-install(FILES ${core_export_headers}
- DESTINATION ${CMAKE_INSTALL_PREFIX}/include/OpenColorIO/)
diff --git a/graphics/opencolorio/pkg-plist b/graphics/opencolorio/pkg-plist
index ba9130edc705..f68a1591fa58 100644
--- a/graphics/opencolorio/pkg-plist
+++ b/graphics/opencolorio/pkg-plist
@@ -5,8 +5,11 @@ include/OpenColorIO/OpenColorTypes.h
include/PyOpenColorIO/PyOpenColorIO.h
lib/libOpenColorIO.so
lib/libOpenColorIO.so.1
-lib/libOpenColorIO.so.1.0.9
+lib/libOpenColorIO.so.1.1.0
libdata/pkgconfig/OpenColorIO.pc
+share/cmake/Modules/OpenColorIOConfig.cmake
+share/cmake/Modules/OpenColorIO-%%CMAKE_BUILD_TYPE%%.cmake
+share/cmake/Modules/OpenColorIO.cmake
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog.html
%%PORTDOCS%%%%DOCSDIR%%/CompatibleSoftware.html
%%PORTDOCS%%%%DOCSDIR%%/FAQ.html
@@ -25,11 +28,11 @@ libdata/pkgconfig/OpenColorIO.pc
%%PORTDOCS%%%%DOCSDIR%%/_sources/CompatibleSoftware.txt
%%PORTDOCS%%%%DOCSDIR%%/_sources/FAQ.txt
%%PORTDOCS%%%%DOCSDIR%%/_sources/License.txt
+%%PORTDOCS%%%%DOCSDIR%%/_sources/configurations/aces_1.0.3.txt
%%PORTDOCS%%%%DOCSDIR%%/_sources/configurations/allocation_vars.txt
%%PORTDOCS%%%%DOCSDIR%%/_sources/configurations/index.txt
%%PORTDOCS%%%%DOCSDIR%%/_sources/configurations/nuke_default.txt
%%PORTDOCS%%%%DOCSDIR%%/_sources/configurations/spi_anim.txt
-%%PORTDOCS%%%%DOCSDIR%%/_sources/configurations/spi_pipeline.txt
%%PORTDOCS%%%%DOCSDIR%%/_sources/configurations/spi_vfx.txt
%%PORTDOCS%%%%DOCSDIR%%/_sources/developers/api/OpenColorIO.txt
%%PORTDOCS%%%%DOCSDIR%%/_sources/developers/api/OpenColorTransforms.txt
@@ -48,6 +51,7 @@ libdata/pkgconfig/OpenColorIO.pc
%%PORTDOCS%%%%DOCSDIR%%/_sources/developers/usage_examples.txt
%%PORTDOCS%%%%DOCSDIR%%/_sources/downloads.txt
%%PORTDOCS%%%%DOCSDIR%%/_sources/index.txt
+%%PORTDOCS%%%%DOCSDIR%%/_sources/introduction.txt
%%PORTDOCS%%%%DOCSDIR%%/_sources/installation.txt
%%PORTDOCS%%%%DOCSDIR%%/_sources/userguide/baking_luts.txt
%%PORTDOCS%%%%DOCSDIR%%/_sources/userguide/config_syntax.txt
@@ -81,11 +85,11 @@ libdata/pkgconfig/OpenColorIO.pc
%%PORTDOCS%%%%DOCSDIR%%/_static/up-pressed.png
%%PORTDOCS%%%%DOCSDIR%%/_static/up.png
%%PORTDOCS%%%%DOCSDIR%%/_static/websupport.js
+%%PORTDOCS%%%%DOCSDIR%%/configurations/aces_1.0.3.html
%%PORTDOCS%%%%DOCSDIR%%/configurations/allocation_vars.html
%%PORTDOCS%%%%DOCSDIR%%/configurations/index.html
%%PORTDOCS%%%%DOCSDIR%%/configurations/nuke_default.html
%%PORTDOCS%%%%DOCSDIR%%/configurations/spi_anim.html
-%%PORTDOCS%%%%DOCSDIR%%/configurations/spi_pipeline.html
%%PORTDOCS%%%%DOCSDIR%%/configurations/spi_vfx.html
%%PORTDOCS%%%%DOCSDIR%%/developers/api/OpenColorIO.html
%%PORTDOCS%%%%DOCSDIR%%/developers/api/OpenColorTransforms.html
@@ -106,6 +110,7 @@ libdata/pkgconfig/OpenColorIO.pc
%%PORTDOCS%%%%DOCSDIR%%/genindex.html
%%PORTDOCS%%%%DOCSDIR%%/index.html
%%PORTDOCS%%%%DOCSDIR%%/installation.html
+%%PORTDOCS%%%%DOCSDIR%%/introduction.html
%%PORTDOCS%%%%DOCSDIR%%/objects.inv
%%PORTDOCS%%%%DOCSDIR%%/py-modindex.html
%%PORTDOCS%%%%DOCSDIR%%/search.html