aboutsummaryrefslogtreecommitdiff
path: root/graphics/opencsg
diff options
context:
space:
mode:
authorMichael Reifenberger <mr@FreeBSD.org>2011-08-19 10:54:46 +0000
committerMichael Reifenberger <mr@FreeBSD.org>2011-08-19 10:54:46 +0000
commit717babfdc4b4e9988fd8bc2686710b975ded30ec (patch)
tree4add11e79b2b938fc2b6f291fc2dacdfaae6d47c /graphics/opencsg
parent8db88ed817ede69fc2d0f46c8bd9bf92dec7db35 (diff)
downloadports-717babfdc4b4e9988fd8bc2686710b975ded30ec.tar.gz
ports-717babfdc4b4e9988fd8bc2686710b975ded30ec.zip
Add opencsg.
OpenCSG is a library that does image-based CSG rendering using OpenGL. OpenCSG is written in C++ and supports most modern graphics hardware. WWW: http://www.opencsg.org/ Obtained from (slightly): OpenBSD
Notes
Notes: svn path=/head/; revision=280008
Diffstat (limited to 'graphics/opencsg')
-rw-r--r--graphics/opencsg/Makefile36
-rw-r--r--graphics/opencsg/distinfo2
-rw-r--r--graphics/opencsg/pkg-descr20
-rw-r--r--graphics/opencsg/pkg-plist4
4 files changed, 62 insertions, 0 deletions
diff --git a/graphics/opencsg/Makefile b/graphics/opencsg/Makefile
new file mode 100644
index 000000000000..f666ba12d8c8
--- /dev/null
+++ b/graphics/opencsg/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: opencsg
+# Date created: 17 August 2011
+# Whom: Michael Reifenberger <mr@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= opencsg
+PORTVERSION= 1.3.1
+#PORTREVISION= 0
+CATEGORIES= graphics
+MASTER_SITES= http://www.opencsg.org/
+DISTNAME= OpenCSG-${PORTVERSION}
+
+MAINTAINER= mr@FreeBSD.org
+COMMENT= Constructive Solid Geometry rendering library
+
+USE_GL= glew
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+
+USE_QT_VER= 4
+QT_COMPONENTS= qmake_build
+PLIST_SUB= PORTVERSION=${PORTVERSION}
+#MAKE_JOBS_UNSAFE=yes
+
+do-configure:
+ cd ${WRKSRC} && ${QMAKE} src.pro
+
+do-install:
+ ${INSTALL_LIB} ${WRKDIR}/${DISTNAME}/lib/libopencsg.so.${PORTVERSION} \
+ ${PREFIX}/lib
+ ${LN} -sf libopencsg.so.${PORTVERSION} ${PREFIX}/lib/libopencsg.so.1
+ ${LN} -sf libopencsg.so.${PORTVERSION} ${PREFIX}/lib/libopencsg.so
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/include/opencsg.h ${PREFIX}/include
+
+.include <bsd.port.mk>
diff --git a/graphics/opencsg/distinfo b/graphics/opencsg/distinfo
new file mode 100644
index 000000000000..42ad2b448bed
--- /dev/null
+++ b/graphics/opencsg/distinfo
@@ -0,0 +1,2 @@
+SHA256 (OpenCSG-1.3.1.tar.gz) = d1e4f2404158e1a4084450288826e94f5286fb35766889cf8a84f6be3b27a0d9
+SIZE (OpenCSG-1.3.1.tar.gz) = 661106
diff --git a/graphics/opencsg/pkg-descr b/graphics/opencsg/pkg-descr
new file mode 100644
index 000000000000..5ae2610d5241
--- /dev/null
+++ b/graphics/opencsg/pkg-descr
@@ -0,0 +1,20 @@
+OpenCSG is a library that does image-based CSG rendering using OpenGL.
+OpenCSG is written in C++ and supports most modern graphics hardware.
+
+CSG is short for Constructive Solid Geometry and denotes an approach
+to model complex 3D-shapes using simpler ones. I.e., two shapes can be
+combined by taking the union of them, by intersecting them, or by
+subtracting one shape of the other. The most basic shapes, which are
+not result of such a CSG operation, are called primitives. Primitives
+must be solid, i.e., they must have a clearly defined interior and
+exterior. By construction, a CSG shape is also solid then.
+
+Image-based CSG rendering (also z-buffer CSG rendering) is a term that
+denotes algorithms for rendering CSG shapes without an explicit
+calculation of the geometric boundary of a CSG shape. Such algorithms
+use frame-buffer settings of the graphics hardware, e.g., the depth
+and stencil buffer, to compose CSG shapes. OpenCSG implements a
+variety of those algorithms, namely the Goldfeather algorithm and the
+SCS algorithm, both of them in several variants.
+
+WWW: http://www.opencsg.org/
diff --git a/graphics/opencsg/pkg-plist b/graphics/opencsg/pkg-plist
new file mode 100644
index 000000000000..42ee76a892c9
--- /dev/null
+++ b/graphics/opencsg/pkg-plist
@@ -0,0 +1,4 @@
+include/opencsg.h
+lib/libopencsg.so.%%PORTVERSION%%
+lib/libopencsg.so.1
+lib/libopencsg.so