aboutsummaryrefslogtreecommitdiff
path: root/graphics/opencsg
diff options
context:
space:
mode:
authorMichael Reifenberger <mr@FreeBSD.org>2018-01-21 16:58:31 +0000
committerMichael Reifenberger <mr@FreeBSD.org>2018-01-21 16:58:31 +0000
commite2b6f61df5bf5eec17e4aa37a957de681d541cb5 (patch)
treee665968b85638ab1e8b7eb073de70b43ba237e09 /graphics/opencsg
parent80ede26c82ce6586ea562d1850b841808f32c301 (diff)
downloadports-e2b6f61df5bf5eec17e4aa37a957de681d541cb5.tar.gz
ports-e2b6f61df5bf5eec17e4aa37a957de681d541cb5.zip
Try to simplify the Makefile and avoid linking to the unneeded qt libs.
PR: 212166
Notes
Notes: svn path=/head/; revision=459619
Diffstat (limited to 'graphics/opencsg')
-rw-r--r--graphics/opencsg/Makefile11
1 files changed, 2 insertions, 9 deletions
diff --git a/graphics/opencsg/Makefile b/graphics/opencsg/Makefile
index 1523577da2cf..b7ae97d0ab51 100644
--- a/graphics/opencsg/Makefile
+++ b/graphics/opencsg/Makefile
@@ -13,17 +13,10 @@ COMMENT= Constructive Solid Geometry rendering library
LICENSE= GPLv2
-USES= qmake:outsource
+USES= compiler:c++11-lang qmake
USE_GL= gl glew
-USE_QT4= corelib gui
+USE_QT4= qmake_build
WRKSRC= ${WRKDIR}/${DISTNAME}/src
PLIST_SUB= PORTVERSION=${PORTVERSION}
-do-install:
- ${INSTALL_LIB} ${WRKDIR}/lib/libopencsg.so.${PORTVERSION} \
- ${STAGEDIR}${PREFIX}/lib
- ${LN} -sf libopencsg.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libopencsg.so.1
- ${LN} -sf libopencsg.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libopencsg.so
- ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/include/opencsg.h ${STAGEDIR}${PREFIX}/include
-
.include <bsd.port.mk>