aboutsummaryrefslogtreecommitdiff
path: root/graphics/opendx
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-09-01 16:07:59 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-09-01 16:07:59 +0000
commit534fffca27bb18f7529d548c46ee3326505a89c7 (patch)
treea09ac440edd299d85a3517dea62caa2b115543fc /graphics/opendx
parent5bc499ce47fa1a8da853b36cc61cddf06075d203 (diff)
downloadports-534fffca27bb18f7529d548c46ee3326505a89c7.tar.gz
ports-534fffca27bb18f7529d548c46ee3326505a89c7.zip
Notes
Diffstat (limited to 'graphics/opendx')
-rw-r--r--graphics/opendx/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/graphics/opendx/Makefile b/graphics/opendx/Makefile
index 38bbe99de1a9..4b2f80a3cc18 100644
--- a/graphics/opendx/Makefile
+++ b/graphics/opendx/Makefile
@@ -27,6 +27,7 @@ USE_GMAKE= yes
USE_MESA= yes
USE_MOTIF= yes
USE_XLIB= yes
+USE_REINPLACE= yes
AUTOMAKE_ARGS= -a -i
GNU_CONFIGURE= yes
CONFIGURE_ENV= ARCH="" \
@@ -41,13 +42,13 @@ post-patch:
@${RM} -f ${WRKSRC}/include/stamp-h.in
post-configure:
- ${PERL} -pi -e "s;flex ;flex -l ;g" ${WRKSRC}/src/uipp/dxuilib/Makefile
+ ${REINPLACE_CMD} -e "s;flex ;flex -l ;g" ${WRKSRC}/src/uipp/dxuilib/Makefile
post-install:
@${ECHO_MSG} "===> Fixing path in the docs (/usr/lpp -> ${PREFIX})"
.for dir in doc help html man
- @find ${PREFIX}/dx/${dir} -type f | \
- xargs ${PERL} -pi -e "s;/usr/lpp;${PREFIX};g"
+ @${FIND} ${PREFIX}/dx/${dir} -type f | \
+ ${XARGS} ${REINPLACE_CMD} -e "s;/usr/lpp;${PREFIX};g"
.endfor
.include <bsd.port.mk>