aboutsummaryrefslogtreecommitdiff
path: root/graphics/openexr
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2020-01-11 19:17:37 +0000
committerMatthias Andree <mandree@FreeBSD.org>2020-01-11 19:17:37 +0000
commitdce9e747daf6d5bf8a0f1d226578dd4843d22834 (patch)
tree9a87ea319056622054bddf7cc3838987b7054e08 /graphics/openexr
parent339f59d1cf856d76bbd505ad72ce7373c1f42040 (diff)
downloadports-dce9e747daf6d5bf8a0f1d226578dd4843d22834.tar.gz
ports-dce9e747daf6d5bf8a0f1d226578dd4843d22834.zip
Port ilmbase build fixes including WITH_DEBUG=yes builds.
- under WITH_DEBUG=yes builds, avoid renaming the libraries with _d suffix. (else it breaks packaging, and we don't want separate lib names) [1] - while here, avoid creating symlinks from cmake, this causes staging violations due to cmake bug #17340, (poudriere testport) see https://gitlab.kitware.com/cmake/cmake/issues/17340 - while here, fix "make test" target - it is a left over from 2.3's gmake build. Use ctest instead. Removes TEST_TARGET. No PORTREVISION bump necessary because each and every fixed bug would cause a broken build and no install. PR: 243274 [1] Reported by: Marcin Cieslak [1] against graphics/ilmbase
Notes
Notes: svn path=/head/; revision=522707
Diffstat (limited to 'graphics/openexr')
-rw-r--r--graphics/openexr/Makefile3
-rw-r--r--graphics/openexr/files/patch-config_LibraryDefine.cmake11
-rw-r--r--graphics/openexr/files/patch-config_OpenEXRSetup.cmake13
3 files changed, 25 insertions, 2 deletions
diff --git a/graphics/openexr/Makefile b/graphics/openexr/Makefile
index 8dd18401c7bc..df86ff3d1bfb 100644
--- a/graphics/openexr/Makefile
+++ b/graphics/openexr/Makefile
@@ -17,7 +17,6 @@ LIB_DEPENDS= libImath-2_4.so.24:graphics/ilmbase
USES= cmake compiler:c++14-lang libtool pathfix pkgconfig
USE_LDCONFIG= yes
-TEST_TARGET= check
USE_GITHUB= yes
GH_TUPLE= AcademySoftwareFoundation:openexr:v2.4.0
@@ -93,7 +92,7 @@ post-install-DOCS-on:
post-install-DOCS-off:
@${RMDIR} ${STAGEDIR}${PREFIX}/share/doc/${PORTNAME} 2>/dev/null || :
-regression-test check:
+regression-test check test:
cd ${BUILD_WRKSRC} && ctest -j ${MAKE_JOBS_NUMBER}
.include <bsd.port.post.mk>
diff --git a/graphics/openexr/files/patch-config_LibraryDefine.cmake b/graphics/openexr/files/patch-config_LibraryDefine.cmake
new file mode 100644
index 000000000000..1f57ab1e9051
--- /dev/null
+++ b/graphics/openexr/files/patch-config_LibraryDefine.cmake
@@ -0,0 +1,11 @@
+--- config/LibraryDefine.cmake.orig 2019-09-18 01:02:06 UTC
++++ config/LibraryDefine.cmake
+@@ -94,8 +94,6 @@ function(OPENEXR_DEFINE_LIBRARY libname)
+ if(BUILD_SHARED_LIBS AND (NOT "${OPENEXR_LIB_SUFFIX}" STREQUAL ""))
+ set(verlibname ${CMAKE_SHARED_LIBRARY_PREFIX}${libname}${OPENEXR_LIB_SUFFIX}${CMAKE_SHARED_LIBRARY_SUFFIX})
+ set(baselibname ${CMAKE_SHARED_LIBRARY_PREFIX}${libname}${CMAKE_SHARED_LIBRARY_SUFFIX})
+- install(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E chdir ${CMAKE_INSTALL_FULL_LIBDIR} ${CMAKE_COMMAND} -E create_symlink ${verlibname} ${baselibname})")
+- install(CODE "message(\"-- Creating symlink in ${CMAKE_INSTALL_FULL_LIBDIR} ${baselibname} -> ${verlibname}\")")
+ set(verlibname)
+ set(baselibname)
+ endif()
diff --git a/graphics/openexr/files/patch-config_OpenEXRSetup.cmake b/graphics/openexr/files/patch-config_OpenEXRSetup.cmake
new file mode 100644
index 000000000000..3fe701732532
--- /dev/null
+++ b/graphics/openexr/files/patch-config_OpenEXRSetup.cmake
@@ -0,0 +1,13 @@
+--- config/OpenEXRSetup.cmake.orig 2019-09-18 01:02:06 UTC
++++ config/OpenEXRSetup.cmake
+@@ -42,10 +42,6 @@ set(OPENEXR_OUTPUT_SUBDIR OpenEXR CACHE STRING "Destin
+ # but is pretty harmless to set globally
+ set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+-# Suffix for debug configuration libraries
+-# (if you should choose to install those)
+-set(CMAKE_DEBUG_POSTFIX "_d" CACHE STRING "Suffix for debug builds")
+-
+ # Usual cmake option to build shared libraries or not
+ option(BUILD_SHARED_LIBS "Build shared library" ON)
+ # This allows a "double library" setup, where we compile both